locked
CRM 2011 Email Router Error: ExchangeOnline - One or more recipients are invalid. RRS feed

  • Question

  • Hi All,

    We have CRM 2011 on-premise deployment with email router configured to use ExchangeOnline. We are receiving many errors in event log mentioning:

    #61042 - An error occurred while processing the outgoing e-mail message with subject "XXXXXX" for ExchangeOnline: <CRM Org Url> for delivery through <Exchange services> Microsoft.Crm.Tools.Email.Providers.EmailException: Error: One or more recipients are invalid.

       at Microsoft.Crm.Tools.Email.Providers.ExchangeOnlinePollingSendEmailProvider.LogEwsResponseErrorWarning(String message, ResponseClassType responseClassType)

       at Microsoft.Crm.Tools.Email.Providers.ExchangeOnlinePollingSendEmailProvider.ProcessMessageInternal(Entity emailMessage)

       at Microsoft.Crm.Tools.Email.Providers.CrmPollingSendEmailProvider.Run()

     Same email message is being processed again & again returning same error. MaximumDeliveryAttempts is set to 10 (default value) but from event log, we can see that same message is being processed more than 10 times.

    So what is the reason behind the failure? and how can we reduce repeated processing of that failed message?

    Any suggestions/pointers would be much appreciated.

    Thank you.

    JayshriP

     

    Monday, July 27, 2015 9:30 AM

All replies

  • MAybe you forgot to wrote that you checked the email which is not being processed if the email is the standard address and reallly reachabel?

    gruss Daniel Ovadia MBSS - Microsoft Dynamics CRM MCNPS

    Tuesday, July 28, 2015 11:47 AM
  • Hello,

    Did you check if all the recipient have a correct address mail ? Are they approve in the CRM ?

    What is the stage of the email in the CRM ? Send or not ?


    Blog: crmandme.blogspot.com Twitter: https://twitter.com/Ju_li3n

    Thursday, July 30, 2015 12:18 PM
  • Hi Daniel,

    This outgoing email is not being processed by email router and I think "To Email" might be wrong; it's in format like "<xxxxx>@gmail.com." but surprisingly same email address is present in incoming email (outgoing email being processed is auto-reply created for one incoming email)

    Email router is processing same email again & again; Irrespective of reason, how can we stop email router from processing such email after say, 5 failed attempts?

    Thank you.

    JayshriP

    Friday, July 31, 2015 11:26 AM
  • Hi,

    Email is in "Sending" status in CRM. Recipient is contact record in CRM. This outgoing email is nothing but auto-reply created through some business feature in response to incoming email in CRM.

    Thank you.

    JayshriP

    Friday, July 31, 2015 11:28 AM
  • Hey,

    Can you give me the name of the step you use to create the email in the workflow.

    "Send Email" step or "Create" step ?


    Blog: crmandme.blogspot.com Twitter: https://twitter.com/Ju_li3n

    Friday, July 31, 2015 12:11 PM
  • Hi,

    Email in " Draft" status is created through plugin and user manually sends the email using "Send" button on Email entity form. no workflow is used here.

    Thank you.

    JayshriP

    Monday, August 3, 2015 11:31 AM