Microsoft CRM Asynchronous Processing Service (client) fails to start RRS feed

  • Question


    I am trying to install Data Migration Manager on a client PC to migrate data to a CRM 4.0 implementation for evaluation.


    When running the Data Migration Manager for CRM 4.0 for the first time, it fails to complete the initial configuration. The process hangs at the CRMAsync step.

    The Microsoft CRM Asynchronous Processing Service (client) installs in Automatic start mode.

    If a manual start of that service is attempted, the service appears to start and then immediately stop.


    I think that this service needs to be started to allow the DMM to function?


    I have uninstalled (with add/remove programs) and reinstalled 3 times with the same results.


    The client PC has XP Pro/SP3, with Outlook 2007 SP1. The client PC with the problem can access the CRM as a web client, and as an Outlook client with no obvious problems. The client PC is a developer workstation with VS2008, SQLServerExpress, and a lot of other tools loaded and functioning.


    Ideas anyone
    Monday, December 29, 2008 10:39 PM


  • There could be several reasons that the Async service is not running as expected.  You can try a repair on the CRM server.  That has worked for some. 


    If that does not work, check your event viewer to see if there are more detailed error messages.  Also, you might want to start a new post as this one is related to a DMM issue.



    Thursday, January 29, 2009 3:10 PM

All replies

  • Hi drhdrh,


    What is the user you used to run the CRM Asynchronous Processing Service? Network service?

    Try change to use local system to run and restart.



    toong yang

    Tuesday, December 30, 2008 3:22 AM



    I had a similar issue a few weeks back with a client of mine, where their windows domain password policy had forced a password change on their machine. 


    Turns out that the local Async service uses the domain users login details to authenticate, so when this was changed by the user the service could no longer log in.


    All that was needed was to open up the service properties and change the password to the current details and the DMM worked fine


    Hope that helps





    Tuesday, December 30, 2008 12:01 PM
  • Thank you Allan for your note, also Toong for your previous note.

    Unfortunately, the password was correct for the account being used (my domain account which is in the local administrators group and the CRM server's adminitrators group). I changed the service to use the local system account, but there was no change in behavior. The service attempts to start, then reports that it started and stopped again.


    The application even log shows an error each time the service attempts to start, but it is not very informative:



    The description for Event ID ( 17410 ) in Source ( MSCRMAsyncService$client ) cannot be found


    I have another PC that I have successfully installed and used DMM on. The async service starts and stays started. So this is definitely a local client problem.


    Thanks again, any other ideas gratefully received!

    Tuesday, December 30, 2008 6:02 PM
  • Are you installing with a direct connection to the CRM SQL server and installing for use with SQL server express edition.  If installing with a direct connection, try to run the install using a local instance of SQL and see if that works.  I would also try it on a different PC to determine if this is a PC issue.
    Tuesday, December 30, 2008 6:18 PM

    I am using the local SQLExpress instance.

    I configured another PC with minimal tools (i.e. I can't actually use it for development...), it works just fine, the MSCRMAsyncService starts and remains started. The DMM app runs and works on that PC

    The asyncservice is started and remains started on the server

    The MSCRMasyncservice starts and stops immediately on my development Laptop, thus DMM can't run.

    The application event log has the unhelpful message every time I try to start the service.


    Thanks for your help... any more ideas?

    Wednesday, December 31, 2008 6:56 PM
  • Ok so it appears to be a PC specific issue.  the only post I can find about the async service stopping unexpectedly is related to the server not having dot net 3.  Not sure if this will help at the PC level but you can try it.




    Wednesday, December 31, 2008 8:57 PM

    Thanks for the help.


    I have .NET3.5, probably that means I have 3.0 also, on both the local PC and the server. But i will double check now you have fingered it as a potential culprit


    I will continue digging... it seems a shame to have to dedicate one PC with only DMM on it in order to use DMM, but if thats what it takes I guess I will live with it...




    Monday, January 5, 2009 5:12 PM
  • Did you find a solution to this as I am having the same problem.  I'm not attempting a data migration but the Asynchronous Processing Service is needed for Workflows to run, and Dup Detection, so I need to get the service running.


    Thursday, January 29, 2009 1:15 PM
  • There could be several reasons that the Async service is not running as expected.  You can try a repair on the CRM server.  That has worked for some. 


    If that does not work, check your event viewer to see if there are more detailed error messages.  Also, you might want to start a new post as this one is related to a DMM issue.



    Thursday, January 29, 2009 3:10 PM
  • Hi,

    Just came across this post as I am currently researching this issue.

    In my experience, this happened in a staging environment in which I am testing Dynamics CRM rollups. I just downloaded the updates of rollup 7 and rollup 11, to be installed in this order.

    • First I installed the server update.
    • Then I went to install the client update in the workstations where the Outlook Client is installed (which is none)
    • Then I went back to the Dynamics CRM server where I am testing the rollups and I installed the update for the email Router. After its succesfull completion, the installation asked to reboot the server, which I did.

    As soon as the system restarted, I saw a message saying that at least one service failed to start. It was the CRMAsync with the following error:

    Event Type: Error
    Event Source: MSCRMAsyncService
    Event Category: None
    Event ID: 17410
    Date: 28/6/2010
    Time: 19:55:59
    User: N/A
    Computer: DYNCRM4-TESTING
    Host DYNCRM4-TESTING: failed while starting monitoring asynchronous operations queue. Exception: Microsoft.Crm.CrmConfigObjectNotFoundException: Server ID Was Not Found
      at Microsoft.Crm.ServerLocatorService.GetServerIdFromDatabase()
      at Microsoft.Crm.ServerLocatorService.GetServerId()
      at Microsoft.Crm.ServerLocatorService.GetServerRoles()
      at Microsoft.Crm.LocatorService.GetServerRoles()
      at Microsoft.Crm.Asynchronous.ServerConfiguration.InitializeOrganizationList()
      at Microsoft.Crm.Asynchronous.ServerConfiguration..ctor(ILocatorService locatorService)
      at Microsoft.Crm.Asynchronous.ConfigurationFactory.Create(CrmServiceFactory crmServiceFactory, AsyncServiceContext context)
      at Microsoft.Crm.Asynchronous.AsyncService.InitializeComponents()
      at Microsoft.Crm.Asynchronous.AsyncService.OnStart(String[] args)
    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
    Monday, June 28, 2010 11:00 PM