locked
Second user on PC has no acces to Live Mesh folder RRS feed

  • Question

  • Hello,

    I am using Live Mesh with my Windows Live ID and it works fine across several devices, including my main computer only used by me and a portable computer used by me as well as by other people. Both machines are running Windows 7 Home Premium x86

    Now I have several folders from my Live Mesh (e.g. my Music folder) also synced with the portable computer. I set them to sync with the Public Music folder, so it's location is "C:\Users\Public\Music".

    Now I also wanted to invite the other users of this computer to share this folder with me so it can be synced while I am not logged on. I foung out that the other users are not able to acces files. While they are able to see the different folders and copy the files onto their desktop and use them from there, they cannot open the files from the Public Music folder with WMP.

    As far as I understood, the files that are synced by Live Mesh cannot be accesed by other users on the computer.

    Does anybody know a solution to that problem?

    Monday, November 9, 2009 7:10 PM

Answers

  • Two options:
    On the source PC
    Navigate to the Music folder in Windows Explorer and right click the Music folder
    Select Share With - Advanced Sharing Options
    This opens the Advanced sharing settings in the Network and Sharing Center
    Make sure that Turn on File and printer Sharing is selected
    and make sure that Turn on Sharing.... in the Public folder sharing section is also selected.
    Click Save Changes.

    or

    On the source PC - navigate to the folder, and right click on the Music folder.
    Select Properties
    Click on the Sharing tab
    Click on Advanced Sharing
    Place a check on Share this folder
    Click on Permissions
    Select Everyone and place a check next to Full Control - in the Allow column
    Then navigate to any file within the Music folder and right click it and select Properties/Security tab to see that it has the permission set for everyone full control

    After you've done the above, add the folder to your Mesh and then check the permissions on a file or files when you get them synchronized to the other PC.
    -steve


    ~ Microsoft MVP Windows Live ~ Windows Live OneCare| Live Mesh|MS Security Essentials Forums Moderator ~
    • Marked as answer by kensm [msft] Monday, November 23, 2009 5:05 AM
    Tuesday, November 10, 2009 7:46 PM
    Moderator

All replies

  • The permissions for files that are synchronized via Live Mesh are retained from their origin, so if they were not public on the other PC or device, they will be restricted when synchronized to the PC you wish to share from. Despite the fact that the folder is "public" and the other users have permission to access that folder and its content, the individual files do not inherit the permissions from the parent folder.
    Right click on one of the files to see the permissions. You can periodically reset the permissions of the folder and contents to allow access, but every time they sync from a location that isn't shared, the permissions will again become restricted.
    There was some discussion about this some time back and we're hoping that they change Live Mesh to write the files in such a way as to have permissions of the destinaton, but we haven't heard if this will be the case.
    -steve
    ~ Microsoft MVP Windows Live ~ Windows Live OneCare| Live Mesh|MS Security Essentials Forums Moderator ~
    Monday, November 9, 2009 7:48 PM
    Moderator
  • So if I make sure that the files are always in a location that is shared across all PCs, it should work fine?

    How should I set the permissions? Homegroup?

    Thanks for your replay,

    -Philipp
    Monday, November 9, 2009 8:54 PM
  • If the original files are in a folder where all users have permissions and each file has those same permissions, they should be preserved.
    If all PCs are on Windows 7 and on the same network, then Homegroup is an easy way to set those permissions and sharing. However, you can also do this by sharing the source folders and setting permissions for those folders and files to grant everyone at least read rights - even if nobody will access those folders directly, but only the folder you are sharing on the laptop, you will still want to make sure that the folder on all devices is shared.
    -steve
    ~ Microsoft MVP Windows Live ~ Windows Live OneCare| Live Mesh|MS Security Essentials Forums Moderator ~
    Tuesday, November 10, 2009 1:04 PM
    Moderator
  • So now every Computer is in the HomeGroup and I deleted the files from every computer except for my main machine.

    On this computer, the files are in this folder: "C:\Users\Public\Music\"

    How can I make sure the folder and all the files in it have to correct permissions before readding this folder to sync on the other machines?

    -Philipp

    Edit: I also need read and write permissions for all users.
    Tuesday, November 10, 2009 6:48 PM
  • Two options:
    On the source PC
    Navigate to the Music folder in Windows Explorer and right click the Music folder
    Select Share With - Advanced Sharing Options
    This opens the Advanced sharing settings in the Network and Sharing Center
    Make sure that Turn on File and printer Sharing is selected
    and make sure that Turn on Sharing.... in the Public folder sharing section is also selected.
    Click Save Changes.

    or

    On the source PC - navigate to the folder, and right click on the Music folder.
    Select Properties
    Click on the Sharing tab
    Click on Advanced Sharing
    Place a check on Share this folder
    Click on Permissions
    Select Everyone and place a check next to Full Control - in the Allow column
    Then navigate to any file within the Music folder and right click it and select Properties/Security tab to see that it has the permission set for everyone full control

    After you've done the above, add the folder to your Mesh and then check the permissions on a file or files when you get them synchronized to the other PC.
    -steve


    ~ Microsoft MVP Windows Live ~ Windows Live OneCare| Live Mesh|MS Security Essentials Forums Moderator ~
    • Marked as answer by kensm [msft] Monday, November 23, 2009 5:05 AM
    Tuesday, November 10, 2009 7:46 PM
    Moderator