locked
CRM 2011 Front End Server Error - The Sandbox SDK Listener failed to start. RRS feed

  • Question

  • We have installed CRM 2011 with two front end servers and one back-end server. The back end server is hosting the Asynchronous and Sandbox Processing services and the Deployment Administration Server. The two front end servers are hosting the typical front end services (Web Application, Oranization Web, Discovery Web, and Help server). Even though the Sandbox Processing Service is only installed on the back end server, we're seeing the following error messages on both of our front end servers:

    Log Name:      Application
    Source:        MSCRMSandboxClient
    Date:          1/17/2012 2:49:01 AM
    Event ID:      20242
    Task Category: None
    Level:         Error
    Keywords:      Classic
    User:          N/A
    Computer:      Commented Out
    Description:
    The Sandbox SDK Listener failed to start.
     Source: w3wp.exe (380)
     Endpoint: net.tcp://localhost/CrmSandboxSdkListener-w3wp
     Error: System.ServiceModel.CommunicationException: The TransportManager failed to listen on the supplied URI using the NetTcpPortSharing service: failed to start the service (5). Refer to the Event Log for more details.


    As far as we know everything seems to be working fine. We're just trying to figure out why this error is being generated and how to fix it. Any ideas?
    • Edited by rrwolfe Thursday, January 19, 2012 2:20 PM
    Thursday, January 19, 2012 2:16 PM

Answers

  • i would check if its listining on port 808 check with netstat -a,

    if you don´t see the TCP 0.0.0.0:808 start a crmwebapplication,just browse contacts, check again port.

    are reports also working fine? or if not done yet, allow the inbound TCP port 808 Inbound Rules on the CRM application server, by default the Sandbox service are using the default port 808 to call back CRM server .

    http://msdn.microsoft.com/en-us/library/gg583972.aspx

     

     


    greetz dao
    • Edited by Daniel Ovadia Thursday, January 19, 2012 2:36 PM
    • Marked as answer by rrwolfe Friday, January 20, 2012 1:31 PM
    Thursday, January 19, 2012 2:32 PM

All replies

  • i would check if its listining on port 808 check with netstat -a,

    if you don´t see the TCP 0.0.0.0:808 start a crmwebapplication,just browse contacts, check again port.

    are reports also working fine? or if not done yet, allow the inbound TCP port 808 Inbound Rules on the CRM application server, by default the Sandbox service are using the default port 808 to call back CRM server .

    http://msdn.microsoft.com/en-us/library/gg583972.aspx

     

     


    greetz dao
    • Edited by Daniel Ovadia Thursday, January 19, 2012 2:36 PM
    • Marked as answer by rrwolfe Friday, January 20, 2012 1:31 PM
    Thursday, January 19, 2012 2:32 PM
  • Thanks for the response dao.

    The front end servers are not listening on TCP port 808, only our back end server is. I guess it would make sense that the front end servers are still trying to use this port to communicate to the sandbox service locally in order to find the redirect to the back end server. I will enable the Net. TCP Listener Adapter (currently disabled via policy since we thought it was only required on the back end server) and see if that fixes it. I'll let you know.

    Thursday, January 19, 2012 3:12 PM
  • Enabling the Net. TCP Port Sharing Service fixed the issue. Both the front end and back end servers are now listening on Port 808 and the error has not come back. Thanks for your help!
    Friday, January 20, 2012 1:31 PM