locked
Error on incomming call - HTTP Error 404.2 - Not Found RRS feed

  • Question

  • I've installed speech server 2007 on Windows Vista Ultimate. I get the following when processing an incomming call:

     

    Server Error in Application "Default Web Site/WelcomeToOcs"


    HTTP Error 404.2 - Not Found

    Description: The page you are requesting cannot be served because of the ISAPI and CGI Restriction list settings on the Web server.

    Error Code: 0x800704ec

    Notification: ExecuteRequestHandler

    Module: IsapiModule

    Requested URL: http://localhost:80/WelcomeToOcs/WelcomeToOcs.speax

    Physical Path: C:\Program Files\Microsoft Office Communications Server 2007 Speech Server\Applications\WelcomeToOcs\WelcomeToOcs.speax

    Logon User: PARLANCE\mlafleur

    Logon Method: Negotiate

    Handler: AboMapperCustom-73694

    Most likely causes:

    • No handler mapping for this request was found. A feature may have to be installed.
    • The Web service extension for the requested resource is not enabled on the server.
    • The mapping for the extension points to the incorrect location.
    • The extension was misspelled in the browser or the Web server.

    What you can try:

    • Install the feature that handles this request. For example, if you get this error for an .ASPX page, you may have to install ASP.NET via IIS setup.
    • Verify that the Web service extension requested is enabled on the server.
      1. Open the IIS Manager and navigate to the server level.
      2. In the Features view, double-click ISAPI and CGI Restrictions to verify that the Web service extension is set to Allowed.
      3. If the extension is not in the list, click Add in the Actions pane.
      4. In the Add ISAPI and CGI Restrictions dialog box, type the path of the .dll or .exe file in the ISAPI or CGI Path box, or click Browse to navigate to the location of the file.
      5. In the Description box, type a brief description of the restriction.
      6. (Optional) Check "Allow extension path to execute" to allow the restriction to run automatically. If you do not check this option, the restriction status is Not Allowed, which is the default. You can allow the restriction later by selecting it and clicking Allow on the Actions pane.
      7. Click OK.
      NOTE: Make sure that this Web service extension or CGI is needed for your Web server before adding it to the list.
    • Verify that the location of the extension is correct.
    • Verify that the URL for the extension is spelled correctly both in the browser and the Web server.
    • Create a tracing rule to track failed requests for this HTTP status code. For more information about creating a tracing rule for failed requests, click here.

    More Information... This error occurs when the necessary Web service extension is not enabled, the location or the name of the extension are misspelled or incorrectly entered.


    Server Version Information: Internet Information Services 7.0.

     

     

    I can't find anything anywhere about an ISAPI or CGI application for OCS 2007.

    Friday, October 26, 2007 2:32 AM

All replies

  • The Speech Server installer registers a handler for .speax.  It looks like this registration may have not succeeded.  Were there any errors reporting during Speech Server installation?  Did you install all of the pre-requisites detailed in the Release Notes[1] prior to installing Speech Server? 

     

    In particular, I'd like to draw your attention to this Known Issue given in the Release Notes:

     

    Problem:
    When the Speech Server installer is run on computers running Windows Vista, it will allow you to install Speech Server even if you have not enabled all of the IIS features listed in these Release Notes as prerequisites. As a result, Speech Server might not function as expected.
     
    Solution:  
    Resolve this problem by ensuring that you enable all required IIS features on Windows Vista listed in the section "To install IIS and MSMQ" of this document before you run the Speech Server installer.

     

    For personal assistance on this issue, I recommend that you contact our technical support department via the http://support.microsoft.com/gp/assistsupport web page or if you are in the US, you can call (800)936-5800 and ask for support on Speech Server.

    [1] http://www.microsoft.com/downloads/details.aspx?familyid=80610FA8-D978-4A16-83CA-F3C8C48A63EA&displaylang=en
    Friday, October 26, 2007 1:18 PM
  • I double-checked any all of the requirements were properly installed.

     

    Is there any documentation on the .speax handler that shows how to configure it manually? Or a setup option that will cause it to re-register it?

    Friday, October 26, 2007 2:06 PM
  • The easiest way would be to reinstall the server component of Speech Server.

     

    Friday, October 26, 2007 2:11 PM
  • I did a reinstall and I'm still getting the same results.

     

    Is there no manual method?

     

    Friday, October 26, 2007 3:06 PM
  • I've gone one step further now. I've uninstalled Speech Server AND IIS 7.0 and then reinstalled both.

     

    I'm still getting the 404.2 error.

     

    Very frustrating!

     

    Friday, October 26, 2007 11:09 PM
  • I'm sorry to hear that.  For personal assistance on this issue, please contact our technical support department via the http://support.microsoft.com/gp/assistsupport web page or if you are in the US, you can call (800)936-5800 and ask for support on Speech Server.

    Monday, October 29, 2007 11:01 AM
  • I called them. They don't know that OCS 2007 even exists! I spent an hour with them tring to find a group that would take my call.

     

    Who supports OCS? And if the Developers Edition isn't support, how do I buy one that is supported?

    Friday, November 2, 2007 6:37 PM
  • No, the OCS 2007 is a supported product. I apologize for the inconvinience. Please contact me offline at ramesa@microsoft.com so that I can help you to create a support incident.

     

    Thanks,

    Ramesh

     

    Monday, November 5, 2007 3:23 PM
  • I wanted to thank Ramesh publicly for his help off-line. I ended up reinstalling Vista to correct the problem but I cannot say Ramesh didn't try his best to solve it. It was very much appreciated.

     

    Thanks again,

    Marc

    Monday, November 12, 2007 5:23 PM
  • Anyone else ever run into this?

     

    It's back doing this again!

    Thursday, April 24, 2008 3:24 PM
  • Could you please check the following things?

    1. The application you process should go to "Speech Server" application pool by default. Could you see if it exists?

    2. The .net framework version of this application pool is v2.0.50727.

    3. The managed pipeline mode is classic not integrated.

    4. In IIS, Handler Mapping page, the executable path for .speax should be like this "C:\Windows\Microsoft.NET\Framework\v2.0.50727\aspnet_isapi.dll".

     

    I am using 32bit Vista Ultimate with OCS2007 speech server and didn't see the errors.

    Hope this will help.

    Friday, April 25, 2008 9:07 AM
  • This issue arises when you uninstall and reinstall Speech Server 2007 on a Windows Vista machine. In the most recent case this was done in order to rename my development machine. For some reason Speech Server 2007 fails to properly configure IIS during the reinstallation.

    I’ve been able to work around this problem by making some manual configuration changes to IIS. I’m not sure what the long term implications of my changes are or to the extent I’ve actually solved the problems. It could be that I’ll run into something else down the road.

    The workaround:

    1)      Open the “Handler Mappings” for each of the MSS applications.

    2)      Locate and open the “*.speax “ entry.

    3)      Click the “Request Restrictions…” checkbox.

    4)      Uncheck “Invoke handler only if request is mapped to” on the “Mapping” tab.

    5)      Select “All verbs” on the Verbs tab.

    6)      Click OK.

    7)      When asked if you want to “allow this ISAPI extension” select “Yes”.

    This changes the “Entry Type” of the handler from “Inherited” to “Local”. I’m not sure if it is the above changes or the fact that it is converting to Local which fixes the problem.

    Hopefully someone on the MSS team will be able to use this post to help them identify the root of the actual problem.

    Tuesday, April 29, 2008 1:54 PM
  •  

    I just spent the past two days struggling with the same issue on a Vista x64 machine.  In this case, the problem seems to be that the OCS Speech Server Admin Console sets the Handler Mapping for .speax to %windir%\Microsoft.NET\Framework64\v2.0.50727\\aspnet_isapi.dll.  If I remove the extra slash from the path, the application works.

    This appears to be a bug.  It did not happen when I first installed OCS on this machine but appears to have cropped up since I installed VS2008 and WCF on the machine.  I was aware of a compatibility problem between OCS Speech Server and VS2008 in development mode but we thought this would be ok because this machine is being used only to demo applications developed elsewhere.  We’ve tried uninstalling and reinstalling OCS Speech Server but the problem persists though it’s not a big deal now that we know how to work around it.

    Thursday, May 1, 2008 4:47 AM
  • I was reading this particular issue and found one article, which helps you to get rid of this problem.

    Here is the link  http://techslate.net/http-error-404-2-and-speech-server-2007/

    Thursday, June 13, 2013 11:10 AM