locked
Small, simple WCF web service works fine on dev machine but gives a 'xxx type is not defined' in staging environment RRS feed

  • Question

  • I've written a small WCF service in VB with a single method.  I've referenced it in my "parent" project as a web reference.  It runs fine on my development machine but I'm getting an error that 'xxx type is not defined'.  I've been beating my head against this wall for the past two days, but I can't for the life of me figure out what's going on.  I'm not sure what info would be valuable here but I sure would like to find someone who may have some ideas.  I've scoured the web trying to find solutions but nothing has helped.  Any help would be greatly appreciated!  I couldn't find a forum that seemed appropriate so my apologies if I've posted in the wrong forum.

    Mike

    Saturday, June 16, 2018 10:21 PM

All replies

  • Hi zendin,

    This forum discusses and asks questions about the Visual Basic programming language, since your issue is more related to WCF, I would suggest that you could post your issue on WPF forum for suitable support.

    https://social.msdn.microsoft.com/Forums/vstudio/en-US/home?forum=wcf

    Thanks for your understanding.

    Best regards,

    Zhanglong


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Tuesday, June 26, 2018 5:28 AM