locked
WSE3 and Certificates RRS feed

  • Question

  • I would like for my mashup to use WSE3 and certificates for security. I see how to upload a certificate. However where is it stored in the VM's certificate store so that I can point my policy and web.config files to it?

    Thanks!
    Monday, January 22, 2007 7:08 PM

All replies

  • We are working on putting together a tool to do this. Should be up on the site soon under developer tools.
    Monday, March 5, 2007 6:08 PM
  • The certificate upload utility is available on Sandbox. Go to "Developer Tools" from the left navigation menu.

     

    Thanks,

    B.

    Thursday, April 5, 2007 7:47 PM
  • Hi,

     

    When trying to use the credential mapping tool I get the following error:

     

    Server was unable to process request. ---> AddSecondaryCredentials failed : Details - Microsoft.ConnectedServices.Sdk.Messaging.SoapFaultException: UserManager.CreateUserMaps:UserID was missing or not in UPN format. Please use "user_name@upnSuffix" format at Microsoft.ConnectedServices.Sdk.Client.MessageSender.SendSync[TResponse](Message message, String defaultNamespace) at Microsoft.ConnectedServices.Sdk.Client.MessageSender.SendSync[TResponse](Message message) at Microsoft.ConnectedServicesSandbox.CertStoreManager.CertStoreService.AddCredential(AddCredentialRequest addCredentialRequest) in C:\Sandbox10\Sources\Test\CertStore\CertStoreManager\CertStoreService.cs:line 222

     

    Same error occurs when setting the UsernameToken or setting the X.509 certificate.

     

    Thank you

    Vikram

    Monday, April 16, 2007 12:30 PM
  • Hello vikram,

     

    I tried both the things & it is working for me. Can you tell me the exact step-by-step procedure you followed to upload the cert.

    Wednesday, April 18, 2007 7:32 PM
  • Hi,

     

    It is working fine now. But where does it get stored in the VM? What is the certificate store used?

     

    Thank you

    Vikram

    Sunday, April 22, 2007 4:51 PM
  • I believe when using the credential mapping utility the certificate gets stored in the current user store location and the personal store.
    Monday, April 23, 2007 9:26 AM
  • Hi,

     

    Even though I was successfully able to upload the certificate, I have no Idea as to where it gets stored.

     

    In my local machine I am using the BT provided Application Registration tool to get the .pfx file for my application and install the same in the current user store. Later I am using the WSE X.509 Certificate Tool to provide 'Read' permission for the IIS_WPG group.

     

    I suppose such a kind on functionality will not be achieved by merely uploading the certificate. How can I provide the 'Read' permission for the worker process group?

     

    Please guide me in this matter at the earliest.

     

    Thank you

    Vikram

     

     

    Friday, June 29, 2007 3:57 AM