none
Live Writer can't use blogtemplates

    Question

  • Problem: My Live Writer can't use blogtemplates from WordPress. The application downloads all data, I see all files (pictures, CSS, htm) in the folder, but it still shows only basic styles. You can see it on the picture.

    Everything worked fine few days ago. The problem appeared when I launched new blog on the same server. Writer downloaded the template, but didn't use it then.

    The other blog accounts I had in Writer worked still fine while I was worry with the new blog. But when I deleted these old accounts and set them up again, it happend the same like with the new one. I have no templates on all accounts.

    When I set up the same blog account on my colleague's computer, templates were correctly used. So the cause of the issue is anywhere on my PC. Could be any connection between this behaviour and Windows Internet Explorer 8 I installed last week?

    Does anybody know solution?

    Thank you,

    Marek

    EDIT: The same problem is described in Live Writer-Beta forum: http://social.microsoft.com/Forums/en-US/writerbeta/thread/9d82ed7c-11f8-4240-aa45-44c369071f8b
    Thursday, March 26, 2009 12:59 PM

All replies

  • Have you tried completely uninstalling WLW and re-installing it?
    Jason - Jason Slater Technology Blog - http://www.jasonslater.co.uk
    Wednesday, April 1, 2009 11:31 AM
  • Yes, five times :(
    Wednesday, April 1, 2009 11:33 AM
  • Those don't look like the default styles--looks like we are definitely picking up something. Our default style should have a black title and use Trebuchet font for everything.

    Do you see a difference when you toggle "View | Edit using theme"? What do you see when you switch to the preview style?

    Thanks...
    Wednesday, April 1, 2009 4:40 PM
    Owner
  • Hello,

    the picture above shows how it looks when I choose Edit using theme. When I deselect this option, it looks like this - with Trebuchet and pretty nice styles, but different from my website.
    Wednesday, April 1, 2009 7:28 PM
  • Thanks--at the bottom of the screen, where you see Edit | Preview | Source tabs, can you click on Preview and tell me if it looks accurate? Also do you mind sharing what the URL of your blog is? If you'd rather not disclose it on this public forum, you can e-mail me the URL at joe.cheng *AT* microsoft.com. Thanks!
    Wednesday, April 1, 2009 7:51 PM
    Owner
  • Thank you. If I choose Preview, it looks like on this picture.

    My blog has URL http://mareklutonsky.blog.zive.cz/, the article I used for pictures is here. The blog interface is in Czech language, but if you want, I can prepare you an account you could use for test. But as I wrote above, my colleague on the same blog can see all styles in Live Writer, he has no problems. So the failure is on my computer :(
    Wednesday, April 1, 2009 7:58 PM
  • Please zip and e-mail me the contents of the following folder. On Vista:

    %AppData%\Windows Live Writer\blogtemplates\

    On XP:

    %UserProfile%\Application Data\Windows Live Writer\blogtemplates\

    Hmmm, you may have to translate those directory names if you're running Czech operating system. Let me know if you need more help locating those directories.

    Sorry for the inconvenience...
    Wednesday, April 1, 2009 11:19 PM
    Owner
  • Thank you Joe, 

    I uploaded the ZIP file on Skydrive. I have two blogs on WordPress MU platform, so there are two subfolders inside. The HTM files look exactly like blog pages, there are all pictures and CSS files. But Writer can't use them to show article in right styles.
    Thursday, April 2, 2009 10:43 AM
  • Marekl, I think I know what this is. Can you try setting your "TEMP" and "TMP" user environment variables to a simple path, like C:\Temp?

    Here are instructions for how to set environment variables, in case you are not familiar with this process.
    http://support.microsoft.com/kb/310519

    Then, log off of your Windows session and log back on. Then restart Writer (you should not need to refresh your theme).

    Let me know if that helps. If so, this is a known bug that will be addressed in our next major release. Sorry for the inconvenience!!
    Thursday, April 2, 2009 5:16 PM
    Owner
  • Joe, there was no change of Writer behaviour after these steps unfortunately. 

    I set new simple paths for TEMP and TMP variables, logged off the Windows and then logged on. The change of variables works, new files appeared in C:\Temp folder. When I launched Writer, nothing happend, I saw the same styles again. I deleted the blogtemplates folder and refreshed the theme then. All files are back but Writer still doesn't see the correct style.

    I noticed perhaps interesting error message when i switch to Preview Tab in Writer. It is in Czech, so I don't translate it exactly to English. It says: "This page contains unspecified potential security risk. Do you want to continue?" This message appeared everytime I go to Preview, but only from the moment the styles stopped to work. 

    Thank you
    Thursday, April 2, 2009 7:57 PM
  • Nevím, jestli už nejdu s křížkem po funusu, ale problém je v české verzi windows.
    Adresář s názvem "Data Aplikací" WLW prostě nerozchodí.
    Popsal jsem to už tady http://www.vacu.cz/writerbugs.aspx, takže jenom opíšu:

    Problém: Writer nezobrazuje správně motiv v náhledu, ani při editaci se zapnutou volbou “Upravit pomocí motivu”

    Příčina: Kdo by si to pomyslel, ale viníkem je mistr Jan Hus a jeho diakritika v českém jazyce. Na americké programátory z Microsoftu se opravdu nemůžeme zlobit, jsou to šťastní lidé, protože si vystačí s prvními 128 znaky ascii tabulky :-)
    Problém se projeví pouze u uživatelů české verze Windows XP. Lehce naznačím, kde Hus programu Writer zavaří:

    • Writer stáhne motiv, soubor *.htm + *.css a obrázky, uloží ho podaresáře c:\Documents and Settings\[user]\Data aplikací\Windows Live Writer\blogtemplates\[guid].
    • vytvoří soubor, kam zapíše cestu k souborům motivu (css, obrázky…), soubor uloží v kódování UTF-8.
    • při následném použití k tomuto souboru přistupuje, jako by byl uložený v kódování CP1250 (windows čeština).

    No a to malé dlouhé měkké í ve slově “aplikací” způsobí, že Writer nenajde potřebné soubory (css a obrázky).

    Řešení: Po každé aktualizaci motivu v programu Writer opravit soubory s cestou k css a obrázkům.

    • aktualizovat motiv
    • přepnout se do správného (nejnovějšího) adresáře c:\Documents and Settings\[user]\Data aplikací\Windows Live Writer\blogtemplates\[guid]
    • dva nejnovější soubory *.path otevřít a uložit v kódování CP1250 (jeden je pro náhled, druhý pro režim “Upravit pomocí motivu”

    A všechno by mělo krásně fungovat.
    (to, který adresář pro motiv Writer používá, lze zjistit v registry, ale řídit se podle datumu modifikace je asi přece jen jednodušší a rychlejší)

    Chybu jsem vývojářům Writeru hlásil, ale nevím, jestli se touto prkotinou budou vůbec zabývat. Tvrdili že jo ;-)
    Ve Windows Vista by s tím neměl být problém, adresář “Data aplikací” už se jmenuje jinak (AppData).

    Monday, October 26, 2009 2:37 PM