locked
"See the records associated with this view" is not shown. RRS feed

  • Question

  • Hello,

    I'am faced with the following problem:

    On Account main form we've added a subgrid wich shows records of a custom entity for which we added an 1:n relationship to built in account entity.

    I added the related entity to the left side navigation in form editor. The relation is shown up in the Ribbon Bar of the entity but  the "See the records associated with this view" button on top of the subgrid is not shown.

    What might be the reason? Is there something missing?

    Any hint for that problem are welcome.

    Regards

    Rolf

    Tuesday, December 16, 2014 12:04 PM

All replies

  • In design view of the account form double click the grid. It will open grid properties page. Do the setting there.

    Regards Faisal

    Tuesday, December 16, 2014 12:08 PM
  • What option might I set in the grids property page. I don't see an option like "Show Button" or like that.

    We are using CRM 2013.

    Regards

    Rolf

    Tuesday, December 16, 2014 12:17 PM
  • You can select entity and its view on this page. Then their are additional options. You should set the option according to requirements.

    Regards Faisal

    Tuesday, December 16, 2014 12:26 PM
  • Hi Rolf,

    As Faisal said, go to the subgrid property and check that in the Data Source Section, you have 3 property to set

    1.Record : Only Related Records (*)

    2.Entity : <Your Related Entity Name>

    3.Default View : <View Name>

    So, Make sure that im the Record Property, you have selected "Only for Related Records" Option.

    Hope this will help you.

    Thanks !!!


    Make sure to "Vote as Helpful" and "Mark As Answer",if you get answer of your question.

    Friday, December 19, 2014 2:03 PM
  • Another thing to look for is check the permissions on the child record. The user should have read permission on child records.


    Regards Faisal

    Friday, December 19, 2014 2:22 PM
  • The reason you're not seeing this button appear is because you don't have the entity that the sub grid is showing in your Navigation of the Form.

    Take a look at this link and this should resolve the issue:
    http://community.dynamics.com/crm/b/jasonlattimersblog/archive/2013/10/29/context-sensitive-sub-grid-commands-in-crm-2013

    At the bottom of that post it discusses the 2 things that happen when you add the navigation in.  One of those is that you get this button.

    Good luck!

    Pete

    Thursday, January 21, 2016 1:13 AM