locked
CRM 4.0 Export to Excel limited to 10,000 records RRS feed

Answers

  • The text below describes an easy and save workaround:

     

    1) Create an advanced find view of the records you want to export to Excel for example: Active Contacts.

     

    2) Click Excel on the toolbar and select Dynamic Worksheet option

     

    3) Open the excel workbook and enable Data Connection

     

    4) On the excel workbook, right click and select 'Edit Query'

     

    5) If the pop-up window "The query cannot be edited by the Query Wizard", opens,click OK. Now you will see the Microsoft Query window.

     

    6) From the Microsoft Query toolbar, click View and select SQL. A new pop-up Windows showing the actual SQL statement appears.

     

    7) Remove the part of the query that states 'Top 10000' from the SQL statement and click OK to exit the SQL statement window

     

    8) From the Microsoft Query window toolbar, click File and select Return Data to Microsoft Office Excel

     

    9) Refresh your excel worksheet if auto-refresh is not enabled and you should see all data from the select CRM view now

    • Marked as answer by NC_Matthews Wednesday, June 13, 2012 2:01 PM
    Tuesday, June 12, 2012 1:23 PM

All replies

  • If you export as a dynamic worksheet, you can go into the Data tab -> Connections (select the connection) -> Properties -> Definition

    Then where you see Command Text- change "select top 10000" to another, larger number.


    Jason Lattimer

    Monday, June 11, 2012 7:19 PM
    Moderator
  • If it's a one time thing you could do it via the database?

    Connect to the MS_CRM DB and look for the filtered view of the entity where you want to export data from.

    Select all the rows and columns and copy/paste to excel

    Monday, June 11, 2012 8:08 PM
  • Did you reset IIS?

    Did you also try the registry key, I believe the registry key on that website for CRM 3 works just fine with CRM 4 as well. give it a try.

    you may need to increase the SQL timeouts, if still doesn't work you need to enable logging and find out what error you getting?


    Visit my blog for CRM material, improving performance, kerberos, IFD, development tips, etc. :) http://quantusdynamics.blogspot.com



    • Edited by nrodri Monday, June 11, 2012 10:36 PM
    Monday, June 11, 2012 10:33 PM
  • You are not clear on what you are describing. I do not see anything you are describing.


    Russ

    Tuesday, June 12, 2012 11:27 AM
  • What registry key are you referring to.  Your answer sounds like you are guessing.  Not enough details in your suggestion to help.

    Russ

    Tuesday, June 12, 2012 11:28 AM
  • The text below describes an easy and save workaround:

     

    1) Create an advanced find view of the records you want to export to Excel for example: Active Contacts.

     

    2) Click Excel on the toolbar and select Dynamic Worksheet option

     

    3) Open the excel workbook and enable Data Connection

     

    4) On the excel workbook, right click and select 'Edit Query'

     

    5) If the pop-up window "The query cannot be edited by the Query Wizard", opens,click OK. Now you will see the Microsoft Query window.

     

    6) From the Microsoft Query toolbar, click View and select SQL. A new pop-up Windows showing the actual SQL statement appears.

     

    7) Remove the part of the query that states 'Top 10000' from the SQL statement and click OK to exit the SQL statement window

     

    8) From the Microsoft Query window toolbar, click File and select Return Data to Microsoft Office Excel

     

    9) Refresh your excel worksheet if auto-refresh is not enabled and you should see all data from the select CRM view now

    • Marked as answer by NC_Matthews Wednesday, June 13, 2012 2:01 PM
    Tuesday, June 12, 2012 1:23 PM
  • Thank you for your clear and detail steps.   Very helpful


    Russ

    Wednesday, June 13, 2012 2:01 PM