locked
Prevent automatic creation of contacts RRS feed

  • Question

  • How can we prevent contacts from being created automatically in CRM2011?

    When we receive incoming e-mails to our “support” queue, contacts are created automatically if the e-mail address is not matched with one of our existing contacts. This is something we would like to avoid, and go back to the behavior used in CRM 4.0. When opening one of these automatically created contacts I can see that the Owner is the user "SYSTEM". This is probably because the Microsoft CRM Email Router service is run by the account Local System. Any suggestions would be gladly appreciated.

    Thanks!

    Tuesday, August 23, 2011 3:33 PM

Answers

All replies

  • Check the account you are using to login to your crm org from email router. If you are using your system administrator account then login with that credentials on web client and check personal options register email. Unmark the creation of contacts / leads.
    Carsten Groth http://carstengroth.wordpress.com
    Tuesday, August 23, 2011 4:12 PM
  • Thank you for your response. I am unsure where to verify the account being used. It could be one of these accounts:

    • E-mail Router Configuration Manager > Configuration Profiles > (row with direction incoming) > Modify > Access Credentials: User Specified: mydomain.local/administrator.
    • E-mail Router Configuration Manager > Deployments > (only one row to select) > Modify > Access Credentials: Local System Account
    • E-mail Router Configuration Manager > Users ... > Forward Mailboxes: mydomain.local\crm
    • Services > Microsoft CRM Email Router > Log On As: LocalSystem

    In Microsoft CRM I only have one of those accounts which is mydomain.local\administrator. Logging in as that user the following flag was already unchecked: File > Options > E-mail > Automatically create records in Microsoft Dynamics CRM.

    If the account being used is mydomain.local\crm, it should be easy to also create that user in CRM and uncheck the flag. But how do I uncheck the flag if the account being used is LocalSystem?

    Tuesday, August 23, 2011 7:04 PM
  • LocalSystem will not have a CRM User account to log in with.  Can you ensure that the mail is not going into another user's mailbox in addition to the queue.  CRM does not generally behave like this by default so the suspicion is that some user has the sync setting to create a Contact set in their options and that user's setting is actually creating the Contact record rather than the queue.

    Regards, Donna

    Saturday, August 27, 2011 7:22 PM
  • I'm in the exact same boat.  The Email Router is running as local system and the router is creating contacts owned by user "SYSTEM" which isn't a really a user listed in CRM.  How do I "login" to CRM as "SYSTEM" to set the personal options?

    Anders, did you ever get a resolution to this?

    Wednesday, February 29, 2012 5:12 PM
  • Can you go to system settings and go to the email tab and uncheck the option to Track Emails sent between CRM users as two activities.  Also,ensure ALL CRM users have the option, Automatically create records in CRM option unchecked under their personal options.  This means that if you have CRM admin users, CRM Mail user or other none 'End User' CRM user records, you need to log in as those users and ensure that box is unchecked and the record saved.  This option is 'on' by default.

    Please take those two steps and let's see if that resolves the issue.


    Regards, Donna

    Wednesday, February 29, 2012 6:43 PM
  • Donna, thanks for the update.  How do you recommend logging in as the special "SYSTEM" account seeing that no one ever knows the Local System password?
    Wednesday, February 29, 2012 7:15 PM
  • I am not making that recommendation. 

    The records you are seeing where the CreatedBy= System are records that were created by a system process.  We need to get to the root of the issue that is driving the system to create those records.  My recommendation is to take the steps I mentioned above and monitor the situation to see if records continue to be created once ALL changes are configured.  I encourage you to take a methodical approach when implementing the changes to ensure you don't miss something.


    Regards, Donna

    Wednesday, February 29, 2012 8:08 PM
  • To reiterate on Donna's point here, my system creates exactly the same extra records and is NOT using email router, just Outlook, so this is not an email router issue, it's a "by design" problem of a setting being on by default.

    The difference is that mine show's the user as the owner since the process creating it was in their context.

    I'm pretty sure once you get the option turned off for your users, you will stop seeing the issue of the records being created, and the "owner" will become a moot point.


    Hope this helps. Adam Vero, MCT

    Wednesday, February 29, 2012 11:00 PM
  • I turned off the "Track Emails sent between CRM users as two activities" option and unchecked every user's "automatically create create contacts" option.

    After sending an email to the queue's email address about a minute later the email router picked up the email and created it in the queue.  The From address is populated with a new contact record that has an owner of SYSTEM.  To reiterate, the email router is running as Local System and I believe that is why the owner of the newly created contact shows "SYSTEM".

    In CRM 4.0 it would instead have the email address listed in the From field if a contact couldn't automatically be matched.

    Friday, March 2, 2012 4:52 PM
  • I don't think any of us know how to stop a queue from creating a System generated email.  I'm making the assumption that no workflows are running that might be causing some unexepted behavior and that the the option to Track Emails sent between CRM users as two activities is turned off.

    You will need to enter a support ticket to see if there is a fix for your specific issue.  Please follow-up and let us know what you discover. 

    Thank you


    Regards, Donna


    Saturday, March 3, 2012 2:54 PM
  • Hi Corbett Merrill,

    I did not resolve this issue.

    I have ensured that all users have the “Automatically create records option” deselected. This was also verified by running the following TSQL query:

    -- If AutoCreateContactOnPromote=0 for all rows in the following query,
    -- all users have deselected the user setting option in
    -- File > Options > E-mail > 
    -- Automatically create records in Microsoft Dynamics CRM > Create
    
    select ub.FullName, us.AutoCreateContactOnPromote
    from UserSettingsBase us
    join dbo.SystemUserBase ub on ub.SystemUserId=us.SystemUserId

    We do not run any workflows that might interfere.

    I just made the change suggested by Donna to uncheck:
    Settings > Administration > System Settings > E-mail > Track e-mail sent between CRM users as two activites.
    Let hope this makes a difference! Otherwise, I still believe this problem might be related to the fact that some account mentioned above run as LocalSystem. However, I have not yet tried to change this.

    Have you found out anything more?

    Tuesday, March 6, 2012 12:11 PM
  • At this point I'm 99% sure that it is the email router (running as Local System) that is creating the email and contact.  Anders, how about this query?

    --Find all users that do not have an entry in the UserSettingsBase tableselect fullname from SystemUserBase where SystemUserId not in (select SystemUserId from UserSettingsBase)

    Tuesday, March 6, 2012 1:22 PM
  • The reason I doubt it is the router itself as I have the router running in several deployments and we do not see this behavior.  My suspicions lie with some unexpected behavior with the e-mail being routed to the queue but I could be wrong.  I doubt we will discover the root cause until a ticket is opened with Microsoft support.

    Regards, Donna

    Tuesday, March 6, 2012 1:32 PM
  • Donna, is your router running as Local System or as another account?  I will get a case opened since this is becoming a big deal.
    Tuesday, March 6, 2012 2:32 PM
  • I never setup the router to run as Local System.  I always set it up to run as the crm forward mailbox user.  If forward mailbox is not in use then I set it up to run as a crm admin user.  the local system login generally does not have sufficient priviledges so I don't recommend it.

    If you want to test the issue, change the logon from local system to a crm admin type user and monitor to see if Contacts are created.  Also, ensure you have "Track Emails sent between CRM users as two activities" unchecked in your system settings before running the test.


    Regards, Donna

    Tuesday, March 6, 2012 4:50 PM
  • After opening a case with MS, it turns out the only way to fix this issue is to set the global AutoCreateContactOnPromote option to False using the OrgDBOrgSettingsTool.  Thanks for the help.
    Tuesday, March 13, 2012 7:46 PM
  • Hi Adam,

    which option should be turned off?

    thanks you the reply


    If this post answers your question or was helpful, please click "Mark As Answer" on the post and "Mark as Helpful" Be wise

    Wednesday, March 14, 2012 11:17 AM
  • HI CorbettMerill,

    what is  OrgDBOrgSettingsTool and where do i find it?

    Thanks


    If this post answers your question or was helpful, please click "Mark As Answer" on the post and "Mark as Helpful" Be wise

    Wednesday, March 14, 2012 11:25 AM
  • The OrgDBOrgSettingsTool was a tool that was released in CRM 4.0 days as part of the Update Rollup packages (http://support.microsoft.com/kb/2479288).  As far as I know, the CRM 2011 version of it is only available directly from Microsoft.  I have a copy of it but I'm not sure if I'm supposed to distribute it.

    Wednesday, March 14, 2012 12:30 PM
  • Thursday, May 3, 2012 3:05 PM
    Answerer
  • I had a similar problem except I was using a user account from AD that is used specifically for the CRM Email Router. I logged into a computer as that user and unchecked the setting as suggested. I tested it and it now works as expected. Thanks to everyone who posted on this thread!

    Eric Hula - CRM Administrator

    Thursday, April 3, 2014 7:36 PM
  • Hi Donna

    I am also experiencing this issue so I made the setting changes reccommended on several users, monitored for a week and this appears to be the solution.  My question then is, does this setting exist in the registry somewhere?  if so, I can incorporate it into our startup script on our terminal server environment.  I just can't find where in the registry it would be.

    Any suggestions would be greatly appreciated.

    Stasia Sliwinski
    IT Support Specialist l County Materials Corp. l Marathon, WI ph: 715-443-6261 ext 292 l

    Wednesday, May 14, 2014 4:02 PM