locked
Unable to set up Remote Access RRS feed

  • Question

  • I am trying to establish Remote Access to my WHS. When running the Remote Access Repair Wizard, I get a green checkmark next to "Verifying that your remote Website is available locally"; I get a orange triangle with an exclamation point next to "Configuring your router using UPnP standards"; and a red X next to "Verifying that your remote Web site is available from the Internet."

    I have a Cisco-Linksys WRT160N Wireless-N Router that is connected via Cat6 to my WHS. The Router is configured as follows:
    On the BASIC SETUP page, I have DHCP Server Enabled. UPnP is also Enabled.
    On the APPLICATIONS & GAMING page on the Port Range Forwarding section, I have listed ports 80, 43, and 4125 and enabled forwarding to my WHS IP Address.

    What else to I need to do?

    I am a relative newbie to this, so please write in laymen's terms. Thanks, so much!!!

    AramB
    Macungie, PA
    Wednesday, November 4, 2009 1:01 AM

Answers

  • Okay, I enabled Single Port Forwarding on my router and forwarded port 8008 to 80 and 600 to 443. Now, I can can access the WHS webpage by typing this address: http://xxxxxxxxxx.homeserver.com:8008/home.  However, once I click on the LOGON button, I get an Internet Explorer cannot display the webpage message. However, the good news is that I can log on using the http://xxxxxxxxxx.homeserver.com:600/home

    Why the difference between the http and https pages? I figured since I could get to the initial home page, I should be able to get to the log-on page with either one.

    Aram B

    Sunday, November 8, 2009 12:53 AM
  • Aram,

    Looks like you found the solution on your own.

    Regarding the difference, the remote access site listens on both http and https ports because users will usually only type http. However, once you load the pages and click the login button, the server always redirects you to the https port in order to ensure that your username and password are sent encrypted over the network.

    When this redirect occurs, your web browser defaults to port 443 for https. Neither the server nor the browser have any way of knowing you configured port 600 instead of 443 on your router.  This is why you get the Internet Explorer error when you attempt to use the :8080 url.

    In the case where you specifically tell the browser to use :600, the server and browser both respect that instruction, and do not redirect you to port 443.

    Hope this helps
    - Adam
    • Marked as answer by AramB Tuesday, November 10, 2009 12:56 AM
    Monday, November 9, 2009 1:52 AM
    Moderator

All replies

  • I am trying to establish Remote Access to my WHS. When running the Remote Access Repair Wizard, I get a green checkmark next to "Verifying that your remote Website is available locally"; I get a orange triangle with an exclamation point next to "Configuring your router using UPnP standards"; and a red X next to "Verifying that your remote Web site is available from the Internet."

    I have a Cisco-Linksys WRT160N Wireless-N Router that is connected via Cat6 to my WHS. The Router is configured as follows:
    On the BASIC SETUP page, I have DHCP Server Enabled. UPnP is also Enabled.
    On the APPLICATIONS & GAMING page on the Port Range Forwarding section, I have listed ports 80, 43, and 4125 and enabled forwarding to my WHS IP Address.

    What else to I need to do?

    I am a relative newbie to this, so please write in laymen's terms. Thanks, so much!!!

    AramB
    Macungie, PA

    It sounds to me like your router isn't completely uPnP compatible.  You could try completely disabling uPnP on your router, then forward it yourself (which it sounds like you already have done that part).
    Wednesday, November 4, 2009 1:24 AM
    Moderator
  • I tried disabling the uPNP along with the other settings I had above and that didn't work either. Would using a static IP address make a difference? If so, how do I set that up?

    AramB
    Wednesday, November 4, 2009 1:27 AM
  • Also, I just want to clarify that i can access the WHS from within the network by either typing in the http://servername.homeserver.com or https://servername.homerserver.com and also by typing in the local IP address of my server. It is only when I try to remote access in that I cannot make it work. The Window Home Server Settings page says Remote Access Not available. 

    If my ISP is blocking ports 80, 443 and 4125, what are my options?

    AramB
    Wednesday, November 4, 2009 1:52 AM
  • If my ISP is blocking ports 80, 443 and 4125, what are my options?


    depends from which ports are not blocked. You can configure port relay from any incoming port of your router to the appropriate port on your WHS. Only for accessing the console remotely it will not work, since port 4125 is hard coded.
    Did you try different remote locations? Eventually share the name of your homeserver.com domain with a friend to have him check the reachability, since some corporate firewalls or proxy servers may also be configured to block such stuff or the homeserver.com domain itself.
    Best greetings from Germany
    Olaf
    Wednesday, November 4, 2009 8:34 AM
    Moderator
  • Aram, who is your ISP?
    I'm not on the WHS team, I just post a lot. :)
    Wednesday, November 4, 2009 3:47 PM
    Moderator
  • But if Aram can access the WHS with the homeserver.com name from within his network, this means, that his ISP should not be the problem, since that name is usually coming in via resolution of an external IP address already (at least this is if no manual changes have been made).
    So I think, it is the remote locations network, which matters.
    Best greetings from Germany
    Olaf
    Wednesday, November 4, 2009 4:05 PM
    Moderator
  • Okay.... good news/bad news!

    I was using the downloaded demo with Service Pack 2. Today I received my "official" OEM copy of WHS Service Pack 1. I installed it on the server system as well as re-installing WHS Connector on all my computers. It re-configured my router and I now have remote access to WHS.

    Although I CAN access my shared folders, I CANNOT get Remote Access to any of the computers that are currently connected in the network.

    My desktop computer is running XP Professional and under status it say "Connection disabled" (yes, Remote Access is enabled on this PC).
    My two laptops which are connected run Vista Home Basic and Windows 7 Home Premium. Both of these have "Not supported on this operating system" under status.

    How do I get "Connection disabled" on my desktop to allow me to remotely access it? Are their plans to support the Windows 7 Home Premium OS in future releases?

    Also, will my WHS OS automatically update to the newer Service Packs, or, is their something I need to do to initiate this?

    Thanks,

    AramB
    • Marked as answer by AramB Thursday, November 5, 2009 4:33 AM
    • Unmarked as answer by AramB Thursday, November 5, 2009 1:25 PM
    Thursday, November 5, 2009 3:28 AM
  • Okay... I re-booted the computer and some things seem to be working better. I have upgraded to Power Pack 2 by clicking the Update Now button in the console. 

    With regards to access within the LAN. I can access my remote console and desktop from any computer, wired or wireless, that is in the house.

    When I go to a different location (work) and try to access my http://servername.homeserver.com site, I get the Internet Explorer cannot display the webpage message. Is this because my ISP is blocking ports, or, should I be running WHS Connector on my computer at work in order to get the webpage to come up?

    My service provider is Service Electric Cable (Allentown, PA).

    Thanks,

    AramB
    Thursday, November 5, 2009 4:16 AM
  • ...
    When I go to a different location (work) and try to access my http://servername.homeserver.com site, I get the Internet Explorer cannot display the webpage message.
    ...
    This is probably because your employer is blocking your access. Try from e.g. the public library or Starbucks.
    I'm not on the WHS team, I just post a lot. :)
    Thursday, November 5, 2009 4:32 PM
    Moderator
  • Thanks, Ken. I thought that might be it too, but I cannot connect through by Blackberry either... just keep getting an unable to connect error as if the web address is incorrect.

    Would you be willing to "ping" my server web address? I will provide it to you off-list.

    AramB
    Thursday, November 5, 2009 5:29 PM
  • Also, is their a way to check if my cable modem is in "pass-through" mode? It is a Motorola Surboard (5101?). Not sure how to make any changes to it.

    AramB
    Thursday, November 5, 2009 5:35 PM
  • Thanks, Ken. I thought that might be it too, but I cannot connect through by Blackberry either... just keep getting an unable to connect error as if the web address is incorrect.

    Would you be willing to "ping" my server web address? I will provide it to you off-list.

    AramB
    Sure. Email's in my profile; don't forget to remove the antispam measure (otherwise it drops into a spam trap and automatically gets reported back to your mail administrator).

    For the cable modem, you'll need to consult the Motorola support site and/or your cable company. But a "quick and dirty" test is to see what IP address a site such as Shields Up! reports, and compare it to the IP address your router reports as it's WAN interface address. If they differ, your cable modem is not in passthrough mode.

    I'm not on the WHS team, I just post a lot. :)
    Thursday, November 5, 2009 8:30 PM
    Moderator
  • You should run that test using Shields Up! from your home, if you didn't already. When you run the test, it reports the IP address it finds at the top of the page. That will be the ip address that is being mapped back to your vanity URL. As for how to determine the external or WAN ip address for your router, it will be visible in your router's configuration pages somewhere. Exactly where should be stated in your router's manual.

    Note: if your router's WAN ip address is the same one that Shields Up! reports, and Shields Up! reports STEALTH for ports 80, 443, and 4125, then your ISP is blocking those ports. Unfortunately this is outside of the control of Windows Home Server, and it really indicates that running an externally-accessible server on your internet connection is a violation of your ISP's Acceptable Use Policy. You can attempt to negotiate with your ISP to have these ports opened, but often this will only be possible if you buy a (significantly more expensive) business connection instead of a residential connection.

    I'm not on the WHS team, I just post a lot. :)
    Friday, November 6, 2009 5:25 PM
    Moderator
  • Okay, I enabled Single Port Forwarding on my router and forwarded port 8008 to 80 and 600 to 443. Now, I can can access the WHS webpage by typing this address: http://xxxxxxxxxx.homeserver.com:8008/home.  However, once I click on the LOGON button, I get an Internet Explorer cannot display the webpage message. However, the good news is that I can log on using the http://xxxxxxxxxx.homeserver.com:600/home

    Why the difference between the http and https pages? I figured since I could get to the initial home page, I should be able to get to the log-on page with either one.

    Aram B

    Sunday, November 8, 2009 12:53 AM
  • Aram,

    Looks like you found the solution on your own.

    Regarding the difference, the remote access site listens on both http and https ports because users will usually only type http. However, once you load the pages and click the login button, the server always redirects you to the https port in order to ensure that your username and password are sent encrypted over the network.

    When this redirect occurs, your web browser defaults to port 443 for https. Neither the server nor the browser have any way of knowing you configured port 600 instead of 443 on your router.  This is why you get the Internet Explorer error when you attempt to use the :8080 url.

    In the case where you specifically tell the browser to use :600, the server and browser both respect that instruction, and do not redirect you to port 443.

    Hope this helps
    - Adam
    • Marked as answer by AramB Tuesday, November 10, 2009 12:56 AM
    Monday, November 9, 2009 1:52 AM
    Moderator
  • Thanks, everyone for helping with this.
    Tuesday, November 10, 2009 12:56 AM
  • Just one more question along this subject. Can someone tell me if my router is in pass-through mode based on the information below:

    Information from Router:

    Internet IP Address: aa.bb.cc.231
    Default Gateway: aa.bb.cc.1

    Information from Shields Up!

    Internet IP Address: aa.bb.cc.231

    Thanks!

    AramB
    Wednesday, November 11, 2009 12:03 AM