locked
Local ftp to WHS - no remote access RRS feed

  • Question

  • Hi

     

    What i would like to do is use an ftp client to copy a lot of data to whs - probably to a non pool drive then copy over local on whs directly into the shares

     

    As using Vista the file copy is just pants and i want to save a bit of time

     

    Looks like turning on iis ftp either does not work or a bad idea from reading these forums

     

    any ideas or anybody sorted this out??

    Monday, January 21, 2008 8:04 PM

Answers

  • OP is asking for FTP access. I guess he/she is aware of moving data using an external disk. This is also not convenient if the WHS is headless and buried somewhere in a closet. Setting up FTP is also pretty easy:

     

    To install the FTP service (From WHS helpfiles) login to WHS using RDP or KVM, then:

    1. From the Start menu, click Control Panel.
    2. Double-click Add or Remove Programs.
    3. From the left pane, click Add/Remove Windows Components.
    4. From the Components list, click Application Server, and then click Details.
    5. From the Subcomponents of Application Server list, click Internet Information Services (IIS), and then click Details.
    6. From the Subcomponents of Internet Information Services (IIS) list, select the File Transfer Protocol (FTP) Service check box.
    7. Click OK.
    8. Click Next. You might be prompted for the Windows Server 2003 family CD or the network install path.
    9. Click Finish.

    NOTES:

    a. At "8." you may need to point to X:\SVR_2003\i386 where X is DVD drive (or local copy of  i386 folder)

    b. You have to allow the FTP SERVICE in the WHS firewall, open windows firewall settings, ADVANCED tab, Select Local Area Connection, Settings, Allow FTP server

    c. Properly configure access rights to ftp folders in IIS and also set NTFS folder access rights accordingly

    d. Only allow access from computers on local network (Directory security, All computer access denied except, use add button to allow computers on your local subnet (enter ip-address / netmask) from DHCP server (router) for example 192.168.1.1 and 255.255.255.0

    e. Allow FTP in client firewall (port 21, unless you configured another port for FTP access in IIS)

    Tuesday, January 22, 2008 12:29 AM
    Moderator

All replies

  • If you are going to use a non pool drive, then why not connect that up to your computer, copy the data to it, then connect it back to your WHS as a non pool drive and move the data to the revelvant shares?

     

    Andrew

     

    Monday, January 21, 2008 10:11 PM
    Moderator
  • OP is asking for FTP access. I guess he/she is aware of moving data using an external disk. This is also not convenient if the WHS is headless and buried somewhere in a closet. Setting up FTP is also pretty easy:

     

    To install the FTP service (From WHS helpfiles) login to WHS using RDP or KVM, then:

    1. From the Start menu, click Control Panel.
    2. Double-click Add or Remove Programs.
    3. From the left pane, click Add/Remove Windows Components.
    4. From the Components list, click Application Server, and then click Details.
    5. From the Subcomponents of Application Server list, click Internet Information Services (IIS), and then click Details.
    6. From the Subcomponents of Internet Information Services (IIS) list, select the File Transfer Protocol (FTP) Service check box.
    7. Click OK.
    8. Click Next. You might be prompted for the Windows Server 2003 family CD or the network install path.
    9. Click Finish.

    NOTES:

    a. At "8." you may need to point to X:\SVR_2003\i386 where X is DVD drive (or local copy of  i386 folder)

    b. You have to allow the FTP SERVICE in the WHS firewall, open windows firewall settings, ADVANCED tab, Select Local Area Connection, Settings, Allow FTP server

    c. Properly configure access rights to ftp folders in IIS and also set NTFS folder access rights accordingly

    d. Only allow access from computers on local network (Directory security, All computer access denied except, use add button to allow computers on your local subnet (enter ip-address / netmask) from DHCP server (router) for example 192.168.1.1 and 255.255.255.0

    e. Allow FTP in client firewall (port 21, unless you configured another port for FTP access in IIS)

    Tuesday, January 22, 2008 12:29 AM
    Moderator
  • brubber

    thanks for the reply

    i will give it a try

    it is headless and i am looking to use syncbackse to help with the transfer of data - trying to bypass the slow vista copy problem

    must read those help files more closely


    Wednesday, January 23, 2008 7:52 PM
  • This works great just testing upload speeds


    Wednesday, January 23, 2008 9:51 PM
  •  Spider10 wrote:
    This works great just testing upload speeds


    Good to hear you got it working!
    Wednesday, January 23, 2008 10:04 PM
    Moderator