locked
no CRMappPool RRS feed

  • Question

  • I just ran an installation of crm 4.0.  I did get the warning below but no errors.  There is no CRMAppPool in the IIS.  (2003 server)

    I created the SPN on the service account myself and designated that service account in the installation wizard.

    Warning| Check ServiceAccountsValidator : Warning: Verify Domain User account SPN for the Microsoft Dynamics CRM ASP.NET Application Pool account.


    IIS 6 -- I also see that there is no Microsoft CRM in the web Service Extensions
    • Edited by mardukes Wednesday, October 5, 2011 7:43 PM more
    Wednesday, October 5, 2011 7:41 PM

All replies

  • The installation log will show the all the activity during the installation.

    Notice your warning.  It looks like the installation account needs more rights.

    Or it could be that the AD has issues.

    Out of the box, the CRM install looks to contact the PDC in the forest.  At one client this was impossible, so we had to tweek the registry to ignore that attempt.

    Choosing the "Installation account" is important.   I would suggest for now to just use network service for the app pool account and attempt to give a domain account kerberos authentication rights on the app pool later.

    It seems you need a dev environment and you need to get it up fast.

    Create an OU for the Dev environment and follow the white paper deployment instructions from the Microsoft download site.

    http://www.microsoft.com/download/en/details.aspx?id=3621

     


    Curtis J Spanburgh
    • Marked as answer by mardukes Saturday, October 8, 2011 3:09 PM
    • Unmarked as answer by mardukes Friday, October 14, 2011 6:06 PM
    Friday, October 7, 2011 6:48 PM
    Moderator
  • CustomerSource suggested, among other things, a reinstall of IIS.  I tried it and had to reregister .NET 2.0, but then it worked.  At first I had a vague recollection of someone saying the OU couldn't be nested and ours was within an Applications OU, but clearly that wasn't the issue.  Last I looked it was happily redeploying to my dev copy of the organization database.

    thanks

    • Marked as answer by mardukes Saturday, October 8, 2011 3:09 PM
    • Unmarked as answer by mardukes Friday, October 14, 2011 6:06 PM
    Saturday, October 8, 2011 3:09 PM
  • Great. It's amazing how many times I've had to run a repair on .net as well.    I don't like to blame it all the time but it has been a problem often.

    So your off and running.

    Great.

     


    Curtis J Spanburgh
    Saturday, October 8, 2011 4:29 PM
    Moderator
  • The problem has not resolved.  I can't even repair .net.  The uninstaller refuses and the installer won't run without an uninstall.
    Friday, October 14, 2011 6:08 PM
  • Ok, there must be .net errors in you logs.

    So you have any services that would be using the .net platform shut down, correct?

    You have run a repair and you get an error?

    In there logs, What do you see there?

     

     


    Curtis J Spanburgh
    Friday, October 14, 2011 6:37 PM
    Moderator
  • What services use .net?  CustomerSource finally decided to try creating CRMAppPool manually and see if that would be adopted by the installer as its own.  Apparently it was as the installer completed and the web site properties shows it.

    But to answer your question, I get no error from .net installer.  It just says to uninstall first.  And I get no error from the uninstaller.  It just refuses to uninstall as other things are dependent on it.

    Monday, October 17, 2011 3:37 PM