locked
Cisco Router 2861 and OCS integration RRS feed

  • Question

  •  

    Hi All,

     

    I am doing a integration of cisco router 2821 with OCS. The setup is like, we have two locations and both are connected to each other using MPLS links on cisco routers.

     

    Cisco Routers connect to local PBX  at each location. PBX has 5 digit dialing plan. So when user at location A dials 50001 cisco VG Router routes the call to location 2 pbx.

     

    Now i want to have OCS at location-1 speak to cisco router over SIP and the users from both the locations should be able to dial to OC clients and recieve calls from OC clients using 5 digit extension number.

     

    Can some one share the configuration of their cisco router for similar setup. I have installed the mediation server and setup location profiles, numbering patterns, phone usage etc. on the OCS side.

     

    The OCS side is ready with the config. Can some one share the Cisco side configuration for similar setup.

     

    Thanks in advance.

     

    Regds

     

    AP

    Tuesday, March 4, 2008 6:12 PM

All replies

  • Hello,

     

    Your Cisco gateway is not a supported gateway, so I am not sure that you are able to connect it to OCS directly.

    These Cisco Gateways are currently supported.

    You might need to add another Gateway that is supported

    Cisco

    2851 Integrated Services Router

    Direct SIP Connectivity via Gateway**

    IOS 12.4(11)XJ

    Basic Gateway

    Cisco

    Cisco Interoperability Documents

    2800 Series

    Cisco

    3845 Integrated Services Router

    Direct SIP Connectivity via Gateway**

    IOS 12.4(11)XJ

    Basic Gateway

    Cisco

    Cisco Interoperability Documents

    3800 Series

     

    Check the complete list:

    http://technet.microsoft.com/en-us/office/bb735838.aspx

     

    Johan

     

    Sunday, March 9, 2008 11:14 PM
  •  

    Hi Johan,

     

    Thanks for your reply. I have used the above mentioned link only to do the cisco side configuration. and the mentioned document says that the router model i am using is supported.

     

    I feel it is not the router h/w but the router IOS (s/w which makes a diff).

     

    Here is the excerpts from the above paper.

     

    This Application Notes uses the C3825 IOS-voice-gateway, however other Cisco voice gateways are also an option to use since the voice

    gateway implementation does not depend on the platform. Here is a list of Cisco Products capable of voice gateway functionality: Care

    must be taken when selecting a voice gateway platform depending of the capacity required for the intended deployments

    Cisco 1861 Integrated Services Router

    Cisco 2800 Series Integrated Services Routers

    Cisco 3600 Series Routers

    Cisco 3800 Series Integrated Services Routers

    Cisco AS5350XM Universal Gateway

    Cisco AS5400XM Universal Gateway

     

    Thanks for your reply again.

     

    Regards

    Pankaj

    Monday, March 10, 2008 7:35 AM
  • Hi Pankaj,

     

    I need a little more info. How are the PBX connected to the Cisco routers via IP or T1/E1 etc. Are you using your IP transport to trunk between your locations for your PBX's. If you are what transport type are you using to do it H323 or SIP. These questions are important but in the end you will need to enable IP-IP GW configuration on your routers to enable SIP-SIP or SIP-H323 communications. At the moment you will only be doing TDM to IP based transport which doesnt require IP-IP GW enabled. This may also need a change in your IOS as well to enable this function. If you post your voice specific router config I can help with changing it to suit your new setup if you need it.

     

    Cheers

    Chris

     

     

     

    Wednesday, March 12, 2008 6:13 PM
  • Hi Chris,

     

    Thanks for the reply. Currently the PBX is connected to router with E1. And i am not doing any IP-IP GW at this moment , but will need to do as second phase.

     

    Here is my setup:

     

    Exiting VoiP Network:

     

    Analog Phone >PBX > E1 Link with QSIG >Router1 > <******MPLS Link between loc-1 and Loc -2*******> Router 2 > E1 link with QSIG to PBX > PBX 2 > Analog Phone.

     

    We want to integrate Mediation server at location 1 with Router 1 and allow OC users to call analog phones at location 1 and location2.

     

    Please correct me if i am wrong, i do not think  i need H.323-SIP or SIP-SIP gw fetaure cause from location 1 to location 2 calls are routed over IP transport. Which is not SIP or H.323.

     

    Here is my router config for voicae at location 1:

     

    Thx

     

    Regards

    AP

     

    voice translation-rule 11

     rule 1 /^\+/ //

    !

    voice translation-rule 12

     rule 1 /^\.*/ /+/

    !

    !

    voice translation-profile from-ocs

     translate calling 11

     translate called 11

    !

    voice translation-profile to-ocs

     translate calling 12

     translate called 12

     

    dial-peer voice 10001 voip

     translation-profile incoming from-ocs

     translation-profile outgoing to-ocs

     destination-pattern 10001

     session protocol sipv2

     session target ipv4:192.168.6.100

     session transport tcp

     dtmf-relay rtp-nte

     codec g711ulaw

     no vad

     

     

     

    Thursday, March 13, 2008 6:16 AM
  • Hi AP,

     

    I understand your setup a little better now. I think you will have an issue with Qsig as using this setup I have to assume you are doing network emulation on the E1 ports to allow the Qsig signaling to be transported across your network which would be fine if OCS understood Qsig but it doesn't. So you may have to change a few things to get this to work.

     

    This is a document I found that talks about connecting an avaya to CME. I know this is different to your setup but it follows the same line of thinking you are going to have to take with terminiating the Qsig signaling on the router to allow the dial peers to be able to pass calls to OCS. Passing signaling to the other router to terminate calls on the other pbx may mean that you have to terminate Qsig signaling and pass it as h323 or SIP to pass it over yuo WAN to the other router. I am not 100% sure that is required but its an idea you may have to look into.

     

    http://www.cisco.com/en/US/docs/voice_ip_comm/cucme/pbx/interop/notes/571081nt.pdf

     

    Here are some highlights for you. These commands help terminate the Qsig and enable the router to allow connections to either a SIP or H323 dial peers. Also I have pasted the E1 configuration some of which you may not require as this is for an Avaya 8500. You will also need dial peers to go with this for OCS and your PBX connections that you seem to have a solid grasp of. :

     

    voice service pots

    supplementary-service qsig call-forward

    !

    voice service voip

    qsig decode

    allow-connections h323 to h323

    allow-connections h323 to sip

    allow-connections sip to h323

    allow-connections sip to sip

    h323

    !

    !

    controller E1 0/0/1

    clock source line primary

    pri-group timeslots 1-31

    !

    !

    interface Serial0/0/1:15

    no ip address

    encapsulation hdlc

    isdn switch-type primary-qsig

    isdn overlap-receiving

    isdn incoming-voice voice

    isdn bchan-number-order ascending

    no cdp enable

    !

     

    Also if you have access to TAC, I would open a tac case to have a Cisco engineer do a double check of your configuration. Testing this in a lab somewhere would be strongly advised as it may take a little while to nail down every setting on the routers.I hope this helps good luck and let me know how you go.

    Cheers

    Chris

    Thursday, March 13, 2008 7:30 PM
  •  

    Hi Chris,

     

    Thanks for your detailed reply . I will make these changes and will let you know the feeback.

     

    Thanks

     

    Regards

    Pankaj

     

    Monday, March 17, 2008 7:07 AM
  • Hi Pankaj,

     

    Did you resolve the issue as I have similar issue and not resolve yet.

     

    many thanks,

     

    Maurice

     

    Thursday, May 8, 2008 5:36 AM
  • Hi Maurice,

     

    If you want to expand on your issues I can try and help.

     

    Cheers

    Chris

     

    Thursday, May 8, 2008 4:00 PM
  • Hello Chris,

     

    Apologies for delayed response, i was involved in some other stuff. Hence this config took back seat.

     

    Here is the update:

     

    Good News:

     

    At location-1 i am able to dial from OC to PBX phone (location-1) and users can talk with no problems.

     

    Bad News:

     

    But when location-1 user dials location-2 PBX phone, the call rings at the location-2 pbx phone. But as your user picks up the call, the user gets the following error:

     

    "Cannot accept this type of Call". Also i am not able to enter the following commands on the router:

     

     

    voice service pots

    supplementary-service qsig call-forward

    !

    voice service voip

    qsig decode

     

    But without entering these comamnds i am able to call from location-1 OC users to Location-1 PBX phone. Any help is appreciated.

     

    Also, do these commands require any special type of IOS.

     

    Cheers

    AP

    Tuesday, May 13, 2008 3:04 PM
  •  

    Hi AP,

     

    Try what I have below. This was taken from a CME document but is should still work in your case without the telephony service features (CME stuff) enabled. The ip-ip gw feature set fo the version below should work also. Let me know if this doesn,t help and I will have another look for you.

     

    Cheers

    Chris

     

    Cisco IOS Software, 2800 Software (C2800NM-IPVOICE-M), Version 12.4(4)XC4

    http://www.cisco.com/en/US/docs/voice_ip_comm/cucme/pbx/interop/notes/555871nt.pdf
    Tuesday, May 13, 2008 4:25 PM
  • Hi,

     

    In this scenario where call goes through multiple routers, we noticed the following codec's are in use

     

     

    G 711 Codec is being used from OC to Voice router,  G729 is being used between routers and on the remote site, G711 is used to forward the call to PBX.

     

    What i dont understand is, when the normal voice traffic works without any issues in this scenario, why OC Clients are failing to provide voice in this scenario where multiple codec's are in use.

     

    To make this work, i am not comfortable to change the codec’s from G729 to G711 between the routers as i was told that G711 does not support voice compression.

     

    Is there any other work around to fix this issue?

     

    Thanks in advance

     

    Sunday, May 18, 2008 2:37 PM
  • Hi Sanjay,

     

    Great question. While OCS only supports G711, ISR (cisco router) configured correctly can support multiple codecs. Have a look at the article below talking about IP-IP GW support for transcoding in box to support multiple codecs.

     

     

    http://www.cisco.com/en/US/docs/ios/12_4t/12_4t15/it_unitr.html

     

    Cheers

    Chris

    Sunday, May 18, 2008 3:36 PM
  • Hi Chris,

     

    Thanks for the quick response. I will request my network folks to have a look at this and get back to you

     

    Regards,

    Sanjay

     

    Monday, May 19, 2008 3:36 AM
  • Hi Chris,

     

    Thanks for pointing to the Trans coding paper. I have replicated the same in a lab.

     

    Here is the setup:

     

    OC >  OCS 2007 FE > OCS Med Server >Med Router > Wan Link > PSTN Router > FXS card > Analog Phone

     

    1)Med Router(172.16.0.105) Connected to Mediation Server over IP.

    2) PSTN Router(172.16.0.104) connected to MEd Router over IP and on FXS port a phone is connected.

     

    Here is the outcome:

     

    1) without any transcoding if i used G.711 codec between routers (end to end ). the outgoing call from OC to Analog phone is successful (no issues).

     

    2) If i change the codec to g.729 for the dial peers between routers only. The call fails. I get a call "can not be completed message on OC."

     

    3) If i enabled transcoding on both the routers. Still the issue remains the same.I get a call "can not be completed message on OC."

     

    Attached is the configuration of my lab:

     

    MED Router :

    Current configuration : 1920 bytes
    !
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    service password-encryption
    !
    hostname srst2800router
    !
    boot-start-marker
    boot-end-marker
    !
    enable secret 5 $1$2BKK$7WdLXphrlaLvckozNIoL1/
    !
    no aaa new-model
    !
    resource policy
    !
    no network-clock-participate wic 0
    ip subnet-zero
    !
    !
    ip cef
    !
    !
    !
    voice-card 0
     no dspfarm
     dsp services dspfarm
    !
    !
    !
    voice service voip
     allow-connections h323 to sip
     allow-connections sip to h323
     allow-connections sip to sip
     h323
     sip
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    voice translation-rule 1
     rule 1 /1/ /+1/
    !
    !
    voice translation-profile voip
     translate called 1
    !
    !
    !
    !
    !
    !
    !
    !
    interface FastEthernet0/0
     ip address 172.16.0.105 255.255.0.0
     duplex auto
     speed auto
    !
    interface FastEthernet0/1
     no ip address
     shutdown
     duplex auto
     speed auto
    !
    interface Serial0/0/0
     no ip address
     shutdown
     clock rate 2016000
     dce-terminal-timing-enable
    !
    interface Serial0/0/1
     no ip address
     shutdown
     clock rate 2016000
     dce-terminal-timing-enable
    !
    interface Serial0/0/2
     no ip address
     shutdown
     clock rate 2016000
     dce-terminal-timing-enable
    !
    interface Serial0/0/3
     no ip address
     shutdown
     clock rate 2016000
     dce-terminal-timing-enable
    !
    ip classless
    !
    !
    no ip http server
    no ip http secure-server
    !
    !
    !
    !
    control-plane
    !
    !
    !
    voice-port 0/3/0
    !
    voice-port 0/3/1
    !
    !
    !
    !
    dspfarm profile 1 transcode
     codec g711ulaw
     codec g711alaw
     codec g729ar8
     codec g729abr8
     codec gsmfr
     codec g729r8
     maximum sessions 2
     associate application SCCP
    !
    !
    dial-peer voice 1 voip
     destination-pattern 1...
     session protocol sipv2
     session target ipv4:172.16.0.163
     session transport tcp
     codec g711ulaw
    !
    dial-peer voice 2 voip
     destination-pattern 5...
     session protocol sipv2
     session target ipv4:172.16.0.104
     session transport tcp
     codec g711ulaw
    !
    !
    !
    line con 0
    line aux 0
    line vty 0 4
     password 7 110A1016141D2B1C173A27
     login
    !
    scheduler allocate 20000 1000
    !
    end

     

     

    PSTN Router:

     

    Current configuration : 2075 bytes
    !
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    service password-encryption
    !
    hostname 3800Router
    !
    boot-start-marker
    boot-end-marker
    !
    ! card type command needed for slot/vwic-slot 0/0
    enable secret 5 $1$9J41$Tb1spvdZ9AAAhONwe5ZWM/
    !
    no aaa new-model
    !
    !
    ip cef
    !
    !
    multilink bundle-name authenticated
    !
    voice-card 0
     no dspfarm
     dsp services dspfarm
    !
    !
    !
    !
    voice service voip
     allow-connections h323 to h323
     allow-connections h323 to sip
     allow-connections sip to sip
     h323
     sip
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    voice translation-profile voip
     translate called 1
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    interface GigabitEthernet0/0
     ip address 172.16.0.104 255.255.0.0
     duplex auto
     speed auto
     media-type rj45
    !
    interface GigabitEthernet0/1
     no ip address
     shutdown
     duplex auto
     speed auto
     media-type rj45
    !
    interface Serial1/0
     no ip address
     shutdown
     serial restart-delay 0
    !
    interface Serial1/1
     no ip address
     shutdown
     serial restart-delay 0
    !
    interface Serial1/2
     no ip address
     shutdown
     serial restart-delay 0
    !
    interface Serial1/3
     no ip address
     shutdown
     serial restart-delay 0
    !
    !
    !
    no ip http server
    no ip http secure-server
    !
    !
    !
    !
    control-plane
    !
    !
    !
    voice-port 0/1/0
     signal groundStart
     input gain 1
     cptone IN
     timeouts initial 30
     timeouts interdigit 15
     timeouts ringing 120
    !
    voice-port 0/1/1
     ring number 4
    !
    voice-port 0/2/0
     signal groundStart
     input gain 1
     cptone IN
     timeouts initial 30
     timeouts interdigit 15
     timeouts ringing 120
    !
    voice-port 0/2/1
    !
    !
    !
    !
    dspfarm profile 1 transcode
     codec g711ulaw
     codec g711alaw
     codec g729ar8
     codec g729abr8
     codec g729r8
     maximum sessions 2
     associate application SCCP
    !
    !
    dial-peer voice 113 voip
     destination-pattern 1...
     session protocol sipv2
     session target ipv4:172.16.0.105
     session transport tcp
     codec g711ulaw
    !
    dial-peer voice 111 pots
     destination-pattern 5555
     port 0/2/0
    !
    dial-peer voice 112 pots
     destination-pattern 5556
     port 0/2/1
    !
    !
    !
    line con 0
    line aux 0
    line vty 0 4
     password 7 00071A1507542B161C3140
     login
    !
    scheduler allocate 20000 1000
    !
    end

     

    Any pointers/help is appreciated.

     

    Regards

    AP

     

     

     

    Tuesday, May 27, 2008 10:04 AM
  •  

    Hi AP,

     

    You will need to add some code similar to what I have here and also I am assuming you have DSP resources on the router available.

     

    Of course you will have to cahnge it to suit your exact config but you will certainly need it to do transcoding to G729 at the OCS med router. So you will go OCS(G711)----med router (G711-G729)-------PSTN router(G729-G711). I am not totally sure what the configuration on your PSTN router will look like it may or may not be the same config required as the med router. you may have to look up cisco docs for what the config should be for transcoding to the PSTN. Hopefullythis should help you on your way though.

     

    !
    
    sccp local GigabitEthernet0/0
    
    sccp ccm 10.10.10.2 identifier 1 
    
    sccp
    
    !
    
    sccp ccm group 1
    
     associate ccm 1 priority 1
    
     associate profile 10 register MTPNEWONE
    !
    
    telephony-service       -------------------------> Only Required for InBox
     sdspfarm units 1
    
     sdspfarm transcode sessions 128
    
     sdspfarm tag 1 MTPNEWONE
    
     ip source-address 10.10.10.2 port 2000
    
     max-conferences 8 gain -6
    
     transfer-system full-consult
    
    !
    
    Tuesday, May 27, 2008 6:00 PM