locked
AD- intermittent Issue - AD user not able to login even on assigning Client Users role - Need Permanent fix please.. RRS feed

  • Question

  • We’ve been experiencing problems connecting to AD from our web application since July 7<sup>th</sup>. this is critical time for the business users.

    In our application’s log we see multiple occurrences of the following error:

    2020-07-12 21:29:43,156 [115] INFO  AppLog - GetUserInfoStatic :chekale

    2020-07-12 21:29:43,156 [115] ERROR AppLog - SearchFiles():Unknown error (0x80005000)   at System.DirectoryServices.DirectoryEntry.Bind(Boolean throwIfFail)

    2020-07-12 21:32:04,930 [73] INFO  AppLog - GetUserInfoStatic :celedfe

    2020-07-12 21:32:04,930 [20] ERROR AppLog - BusinessUnit():Unknown error (0x80005000)

    2020-07-12 21:32:04,930 [73] ERROR AppLog - ProcessName():Unknown error (0x80005000)

    A quick search for the error code returned:

    It's not unknown, 0x80005000 means that "The specified directory service attribute or value does not exist". It will sometimes occur under a heavy load, when the global catalog server may fail to authenticate a client by using Kerberos.”

    There were no changes on the application side, it is impacting multiple users.

    Could you please look into this issue and advise? Your prompt response is greatly appreciated.

    Additional Details:-

    The below error is intermittent, a user is not being authenticated against AD so the exception is thrown.

    2020-07-13 07:58:19,024 [95] INFO  AppLog - GetUserInfoStatic :chekale

    2020-07-13 07:58:19,086 [95] ERROR AppLog - SearchFiles():Creating an instance of the COM component with CLSID {080D0D78-F421-11D0-A36E-00C04FB950DC} from the IClassFactory failed due to the following error: 800401e4 Invalid syntax (Exception from HRESULT: 0x800401E4 (MK_E_SYNTAX)).   at System.DirectoryServices.AccountManagement.ADStoreCtx.GetGroupsMemberOfAZ(Principal p)

       at System.DirectoryServices.AccountManagement.UserPrincipal.GetAuthorizationGroupsHelper()

    Solution1 Tried:-

    We try to  fix this by going to Advanced Settings of the IIS App pool of your application and setting "Load User Profile" option to True. - Still monitoring on this issue..

    Solution2 Tried:- App pool rest works always and again issue re-occured.

    What would be the right solution to fix the issue?

    Appreciate your help.


    • Edited by JamalBasha Tuesday, July 14, 2020 7:07 PM
    • Moved by CoolDadTx Wednesday, July 15, 2020 3:00 PM ASP.NET related
    Tuesday, July 14, 2020 7:04 PM

All replies

  • Hi JamalBasha,

    Thank you for positng here.

    Since this question is about web application, I suggest that you ask this question in the ASP.Net forum.

    Best Regards,

    Timon


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Wednesday, July 15, 2020 3:20 AM