Increasing the e-mail activity attachment size limit to more than 8Mb RRS feed

  • Question

  • Hi,

    I am just wondering if there is a way to increase the maximum size an attachment can be for e-mail activities from 8Mb to say, 10Mb?

    At the moment I have e-mails sitting in my inbox that are slightly over 8Mb, but they cannot be tracked because the maximum size limit for file attachments is 8Mb.  Is there any way to increase that limit?


    Wednesday, August 18, 2010 8:19 PM


All replies

  • Wednesday, August 18, 2010 9:09 PM
  • Thanks Jerry,

    I've actually tried those suggestions but did not have any luck.  I would get an error saying that the Outlook client cannot communicate with the server and would not track the e-mails from Outlook to CRM.  I've also tried to get some low level details through tracing but that didn't reveal much either.  However this seems to be happening with the Outlook client toolbar only though.  Through the front end web interface, I can create an e-mail activity and attach files that are larger than 8Mbs within CRM.

    So I was wondering if there are any other ways to accomplish the same task as I would prefer to track the original emails from the mailbox into CRM.

    Wednesday, August 18, 2010 9:33 PM
  • We have used that on a number of systems and it always worked. I am wondering therefore if you don't have something else going on affecting the situation?
    Jerry http://www.crminnovation.com
    Wednesday, August 18, 2010 10:36 PM
  • I am not sure.  Basically what I did was I have sent to myself a number of emails that are greater than 8Mbs, but below 10Mb.  I get a generic error from a popup window:

    "There is a problem communicating with the Microsoft Dynamics CRM server.  The server might be unavailable.  Try this action again.  If the problem continues, check the Microsoft Dynamics CRM Community for solutions or contact your organization's Microsoft Dynamics CRM Administrator.  Finally, you can contact Microsoft Support."

    When looking at the event viewer, this is what I got:

    Event Type: Error
    Event Source: MSCRMAddin
    Event Category: None
    Event ID: 5983
    User:  N/A
    An error occurred while promoting a Microsoft CRM e-mail message.  Restart Microsoft Outlook and try again. HR=0x80004005. Context=. Function=CMailItemHelper::HrPromoteMailItemInCrm. Line=1338.

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

    I have tried this on two different environments and they are behaving the same way.


    Thursday, August 19, 2010 5:02 PM
  • Hi SL,

    you need change the value in CRM database in this case.

    Read http://eastoceantechnical.blogspot.com/2008/09/maximum-upload-file-size-in-crm-titan.html

    FYI, this is unsupported customization,thx


    Toong Yang

    Friday, August 20, 2010 3:33 AM
  • Thanks Toong for your suggestion.

    I have just checked the value in the database and it is already set to the correct value.  I think this is related to the value that was set in CRM settings area.

    I have also heard that this could be related to the machine.config restriction from .NET.  Would that be the reason for this error?

    Friday, August 20, 2010 6:39 PM