locked
CRM For Outlook connection RRS feed

  • Question

  • Hello,

    In our organisation we are using CRM online and recently we installed CRM for Outlook.
    Now everything worked fine until today.

    Most of the users cannot connect anymore to CRM Online with Outlook. When Outlook starts, a pop-up displays and asks for the users credentials. When they give their credentials, a new pop-up displays that says: "Cannot connect to Microsoft Dynamics CRM server because we cannot authenticate your credentials."

    But we still can use CRM in internet explorer, with the same credentials..

    Hope that someone can help me :)

    Thanks.

    Thursday, September 12, 2013 10:10 AM

Answers

  • Problem solved, it had something to do with the ADFS that wasn't working correct anymore for outlook. Thanks for the replys

    Thursday, September 19, 2013 1:27 PM

All replies

  • Hi,

    Most of the connection problems to between Outlook and CRM is due to these issues:

    1- The date and time difference between server and client, which could occur due to daylight changes in recent days.

    2- The insufficient privileges to connect to CRM, which could occur due to change in security roles.

    3- Updating CRM to a rollup which is incompatible with outlook's current version.

    However, there are lots of other reasons that could occur. Give a try to above mentioned solutions, if did not work, then provide more details on the error details. You could check the CRM trace logs to see if the error has logs on the server. Also check the event viewer to see if there are error logs on the client.



    My Weblog | My Website

    Thursday, September 12, 2013 11:23 AM
    Moderator
  • Hi, thanks for your reply.

    The time is correct, so that isn't the problem.
    In CRM and on my PC i have system admin roles, so i think that also can't be the problem?
    I've take a look to the logfile of CRM (clientconfig.log).
    I see lots of 'Acces is denied', for example:

    Error| Error connecting to URL: https://dev.crm.dynamics.com/XRMServices/2011/Discovery.svc Exception: System.ServiceModel.Security.SecurityAccessDeniedException: Access is denied.

    (it are all the some errors, but to different url's)

    Yesterday it worked perfect for everybody, but today , different people cant sign in (In outlook version). CRM in the browser still works fine.

     

     

    Thursday, September 12, 2013 11:47 AM
  • I will suggest you:

    1.On  the client machine, please make sure the date/time and time zone is accurate. Time difference no more than 1 minute.

    2.Do a test on one workstation, try to reconfigure Outlook. If your crm is like https://xxx.crm.dynamics.com, type in https://disco.crm.dynamics.com for O365 CRM, type in https://dev.crm.dynamics.com for CTP CRM.

    3.If still not work, try to reinstall Outlook client and upgrade to Rollup 14

     ==How to fully uninstall CRM Outlook client==
    - Removed CRM form the Program and Features.
    - Delete Microsoft Dynamics CRM folder from C:\program files.
    - Deleted MSCRM folder from C:\Users\Your username\AppData\local\Microsoft\MSCRM
    - Performed similar step for C:\Users\Your username\AppData\local\Microsoft\MSCRM and deleted MSCRM folder if it exist.
    - Go to Run, type in regedit and press enter.
    - Click on HKEY_CURRENT_USER>>Software>>Microsoft>>MSCRM. Delete all MSCRM related folder.
    - Click on HKEY_LOCAL_MACHINE>>Software>>Microsoft>>MSCRM. Delete all MSCRM related folder.
    - Click on HKEY_USER>>Software>>Microsoft>>MSCRM. Delete all MSCRM related folder.

    Wilson

    Friday, September 13, 2013 6:54 AM
  • Problem solved, it had something to do with the ADFS that wasn't working correct anymore for outlook. Thanks for the replys

    Thursday, September 19, 2013 1:27 PM