none
Issue with Port Forwarding and UPnP with Linksys WRT330N Router RRS feed

  • Question

  • I just upgraded to a Linksys WRT330N router and port forwarding/UPnp no longer works with windows home server.  I verified that UPnP works via the microsoft test site, and i have forwarded ports 80, 443, and 4125 to the static IP address of the server.  When i try to configure the router, the last three verification tests fail (accepting web site connections, accepting remote access connections, verifying network configuration). 

    All of this worked with my old router. Does anyone have any idea how to fix this?

    Monday, September 3, 2007 11:14 PM

All replies

  • Hi,

    Did you reset the router and reboot the whs after you update the router?

    Sometimes this can clean the dns and make it work.

    I have another suggestion, but let see if this simple issue solve the issue.

    My best.
    Monday, September 3, 2007 11:43 PM
  • Thanks very much, but unfortunately, that didn't solve the problem.  I'm hoping your other suggestion might help.  I do appreciate your time.

    Thanks,

    -H

    Tuesday, September 4, 2007 10:53 PM
  • Hi,

    Since you forward the 3 ports need it, then turn off the uPnP in your router, see if that can help, becouse normally, you eiather have use uPnP or forwards the ports, both, will not work.

    Login to your router, and disable the uPnP option.

    My best.
    Tuesday, September 4, 2007 11:58 PM
  • I did try that too and it still fails.  Any other suggestions?  Again, thanks for your time.

    -H

    Wednesday, September 5, 2007 1:37 AM
  • Hi,

    NP here, sooner or later I hpe we will solve this issue, either by me or others whom will step to help here, so no worry at all, ok, I need to make sure I understand the issue so far:

    1 - You said you "upgrade" is that mean the firmware or the hardware (new linksys router model)?
    if new model, can you see if newer firmware to upload and try.
    2 - When I said restart, I mean, to hardrest, that mean, unplug the ac cord and plug it again (best as well re unplug the cable network from the router and the whs server).

    Ok, for start, we need to test from the start, as you said before, upnp was working before the upgrade.

    Let disable the ports forwards and enable the uPnP back, and do this test here:

    Test Site

    If it pass, then test the site again.

    If not, we disble the uPnP again and do the ports forwards, and look in your router setting to disable the DHCP, and try again.

    Let me know how it goes.

    I thin it firmware that need to be update or roll back to the working firmware.

    I remember some topic have same issue, but could not find it with search Sad

    My best.
    Wednesday, September 5, 2007 2:21 AM
  •  HowardZ wrote:

    I did try that too and it still fails.  Any other suggestions?  Again, thanks for your time.

    -H

     

     

    The best approach is to start over.

     

    Try these steps

    On WHS

     

    • Turn of Websites
    • Unconfigure Router
    • Unconfigure Domain

     

    Next

     

    1. Reset Router to Factory Default
    2. Shut down all PC and WHS

     

     

    Next

    1. Reboot 1 PC 
    2. Configure  Router for Internet access and verify that you can connect to the internet
    3. Reboot WHS
    4. Verify access to WHS from Client
    5. Reboot all other PC and verify connection to internet and WHS

    Next

     

    Foward  PORTS  80,443,4125 to WHS (you indicated Static IP on WHS)

     

    Turn on Websites

     

    Configure Domain

     

     

    Good Luck

     

     

     

     

    Wednesday, September 5, 2007 2:29 AM
  • Hi,

    Good point there ROUZA, but I think what he need based on your suggestion:

    1 - Keep the setting for the 3 ports forwards in the router as it is.
    2 - Disable UpnP in the router.
    3 - Unplug the ac cord of the router (hard reset).
    4 - Connect to the WHS console - settings - remote access - domain and reset (unconfiuger the domain), then restart the server.
    5 - Connect to the WHS console, the settings - remote access - domain and configer it again.

    Then all set, credit to
    ROUZA tho.

    My best.
    Wednesday, September 5, 2007 2:52 PM
  •  

    i too have been having problems with remote capabilities. i have a Netgear WGT624 and it seems like each time the server resets, it looses all it's UPnP capabilities. I then went to just forward the 3 ports mentioned above and, it worked like magic. I am plaing on keeping it this way with the forwarded ports to the server but is it a bad thing to leave UPnP tunred on as well.

     

    thnx

    Wednesday, September 5, 2007 5:37 PM
  •  

    I also have issue with the router. 

     

    Is anyone using the D-Link DGL-4300 Gaming router?

     

    The issue:

     

    One time i can access my WHS from outside, then next i cant.  i have uPNP enabled but when i try to have WHS setup the uPNP it only gives me the first 3 green checkmarks the rest are red.  I have tried doing the port forwarding and that doesnt work either.  i have also setup DyndDNS to be able to access the WHS from outside, and i have a dynamically assigned ip from my provider.  Even DynDns doesnt work all the time. Not sure where to go from here.

     

    I think the issue is with the router, but i dont feel like replacing another router just to get the ports to forward correctly or uPNP to work.

     

    if in fact it is the router, does anyone have a list of routers that will function properly, or do any of you have suggestions on a router that does work uPNP.

     

    Thanks

    Thursday, September 6, 2007 2:33 PM
  • When you have issues accessing WHS from outside your LAN, do you get a particular error message? And at what point do you have problems? Is it the initial connection, or later in the process?

    FWIW, I've never had a problem accessing my WHS from off my premises, except when there was a corporate firewall policy in place that blocked me.
    Thursday, September 6, 2007 3:01 PM
    Moderator
  •  

    Ken,

     

    I click the link.  xxxxlivenode.com

     

    and i get the lovely blank page, no error message except page cannot be displayed.

     

    It seems to be the router, for whatever reason the settings change and then the port forwarding no longer works,

    until i go back in to the WHS settings and click configure again.  This happens daily, if i dont login to WHS in the morning and check to see if it is working i cant access my home server webpage.

     

     

    Thursday, September 6, 2007 3:10 PM
  • i got a Beta Firmware form Linksys and now i can use udp ports

    if any wants the Firmware e-mail me @ donovan_220@hotmail.com
    Friday, October 5, 2007 10:05 PM
  • We seem to have lost Howard in this thread, do you still have a problem H?

     

    Is the firewall enabled on the router (I hope you have a firewall operating!!!) If so do you need to define the firewall rules separately as I had to on mine. Without that the traffic cannot get in to be forwarded.

     

    Wednesday, October 10, 2007 11:45 PM
  • I realize that I'm digging up an old thread but I've tried the steps in this thread to no avail and looking for some help.

    My Setup: Running WHS sp3 behind a Linksys WRT330N router.  I've configured my domain name and when I turn on Remote Access, hit Details button and Refresh i get a message that says my "domain name is configured and working correctly".  Seems good so far.  I have forwarded ports 443, 4125 and 80 to my WHS and turned UPnP off (when I try to auto configure my WHS for remote access it reports that UPnP is not supported by my router).  I've restarted both my WHS and router. 

    Problem: When I try to click the HTTPs link for my remote access a tab opens in IE8, it says it is trying to connect to the website but it never does.  All I get is a blank tab. 

    Request: Help.  What more can I do/test to get remote access working?  Thanks.

    Friday, April 2, 2010 10:49 AM
  • You need to access your server from outside of you private network.  Try accessing your website from a friends house, cell phone or web cafe.

    When you try to access your server from inside the network using the public IP/domain you are actually redirected to your router as that is the public facing network device on your private network.


    --
    Friday, April 2, 2010 12:09 PM
  • If you want to access your server from inside you network then you can use http://servername/   replaceing the servername with the name of your server and not the Fully Qualified Domain name (i.e. server.homeserver.com)  or you can get to your server using http://192.168.1.10/ or whatever IP your server is on.
    --
    Friday, April 2, 2010 12:12 PM
  • Al, thank you very much.  That was exactly my problem...accessing from within my LAN.  Easy access from outside my LAN.
    Friday, April 2, 2010 3:21 PM