locked
How to fix warning "You are attempting to open a file of type System file (.dll)" RRS feed

  • Question


  • I got carried away with deleting what I thought was multiple files yesterday and today I getting that warning above on Eclipse.

    I was trying to view the system editor in eclipse. I'm thinking my file must be incorrect but I'm not sure which one I am supposed to be using. Currently I am using glew32.dll - [amd64/le]  under Binaries                                                               

     I'm doing a project for class where the outcome should show a triangle but nothing is appearing. So my question is is there another way I can view this outcome or another file I can use?

    Sunday, April 5, 2020 4:54 PM

All replies

  • It's unclear how you got this, was it from C# code? was it from Eclipse editor e.g. file open, if from using Eclipse then the message is coming from Windows and Eclipse is not for editing binary files.  I use Eclipse for text based files such as Cold Fusion .cfm files, .js and .css.

    Please remember to mark the replies as answers if they help and unmarked them if they provide no help, this will help others who are looking for solutions to the same or similar problem. Contact via my Twitter (Karen Payne) or Facebook (Karen Payne) via my MSDN profile but will not answer coding question on either.

    NuGet BaseConnectionLibrary for database connections.

    StackOverFlow
    profile for Karen Payne on Stack Exchange

    Sunday, April 5, 2020 5:04 PM
  • Yes my Eclipse compiler is set up through binaries. So before I would click under binaries then right click the glew32.dll then scroll to open with system editor. Then a separate screen pops up with the visual. but now instead I get the error. So I know its that binary that is wrong I'm just not sure what's supposed to be there.
    Sunday, April 5, 2020 7:49 PM
  • Yes my Eclipse compiler is set up through binaries. So before I would click under binaries then right click the glew32.dll then scroll to open with system editor. Then a separate screen pops up with the visual. but now instead I get the error. So I know its that binary that is wrong I'm just not sure what's supposed to be there.

    Since this is not a C# issue please use the following forum.

    https://www.eclipse.org/forums/


    Please remember to mark the replies as answers if they help and unmarked them if they provide no help, this will help others who are looking for solutions to the same or similar problem. Contact via my Twitter (Karen Payne) or Facebook (Karen Payne) via my MSDN profile but will not answer coding question on either.

    NuGet BaseConnectionLibrary for database connections.

    StackOverFlow
    profile for Karen Payne on Stack Exchange

    Sunday, April 5, 2020 10:03 PM