locked
Navigation bar not working for an entity(contact) RRS feed

  • Question

  • I am working on a project to upgrade CRM 4 to CRM 15. I did that on our test environment for now. Everything is working fine Except the navigation links on the horizontal navigation bar for our main entity (contact) is not working. When I click on a navigation link for a contact record it does not display anything and stays on contact form. The navigation bar is working fine for all other entities, they are not just working for contact. I checked the mappings for contact with other entities and they are correct. 

    Can anyone help me with this?


    Monday, March 16, 2015 3:47 PM

All replies

  • Hi Montek,

    Use XRM tool box and Check the url it is taking when u click on navigation.

    XRM Toolbox is here. Download this and Go to Sitemap editor and see the issue. If you still dont get the answer, Create a trial CRM and compare it. You should get it.

    Happy coding...!


    Sreeni Pavalla

    Tuesday, March 17, 2015 8:58 AM
  • Thanks Sreeni for the reply. 

    I tired the tool. I can see the sitemap and it displays all the entities and the ares they belong to. 

    My issue is with all the related navigation links to Contact entities are visible but when I click on it, nothing happens. It does not take me to the related entity. Example: When I click on Audit History for a record in Contact, it stays on the record and does not goes to related entity. This is only happening for Contact entity. 

    Any help would be greatly appreciated. 

    Monday, March 23, 2015 3:20 PM