locked
Error when uploading and viewing Attachments in MS CRM 4.0 RRS feed

  • Question

  • We have a problem with CRM 4 Rollup 6 on SBS Server 2008, IIS 7, SQL 2008.  Whenever anyone accesses CRM either via outlook or web(ie 8) and tries attaching files or viewing file attachments from the notes area of any CRM entity they receive a standard 'An error has ocurred...' message.  On reviewing the details in the application event log on the server the error points to a missing field on the deployment table in the CRM config database  ... the actual error is as follows 'Error 1309 - Column 'BlockedAttachmentsForDownload' does not exist on Table 'Deployment'.  I have seen the article that indicates how to populate this field with values (http://support.microsoft.com/default.aspx/kb/974597) but I do not know why the field is missing in the first place, I have even tried creating the field by guessing at the parameters (varchar 256) but the CRM client is convinced that the field does not exist. Any suggestions? 
    SJM09
    Friday, September 25, 2009 10:08 PM

Answers

  • I would try a reinstall--not as painful as it sounds.  remove CRM and reinstall, pointing to your existing environment.  This should fix any missing files.
    • Marked as answer by Jim Glass Jr Thursday, October 8, 2009 2:54 PM
    Thursday, October 8, 2009 1:37 PM
    Moderator

All replies

  • Can't answer the why it's not there question, but a thought on how you might be able to fix it.

    Whenever I see a strange issue like a missing file or something like that I like to look at an environment that is working correctly and see what the missing setting should be.  Do you have a test environment or a copy of the crm demo virtual that you could look at to see what the correct value should be?
    Sunday, September 27, 2009 1:04 AM
    Moderator
  • Unfortunately I've checked already :( I have a 32 bit rollup 6 environment which works fine and where the field 'BlockAttachmentsForDownload' does not exist. I have also checked on a 64 bit rollup 4 environment which works fine without an error and where the field 'BlockedAttachmentsForDownload' field also does not exist, unfortunately I can't apply rollup 6 to this environment to see if the problem occurs and I am increasingly beginning to suspect that rollup 6 for 64 bit servers may be causing the problem.  If anyone has the same environment as me I would be grateful if you could let me know if the field exists within your table structure what type and size it is.


    SJM09
    Sunday, September 27, 2009 7:34 PM
  • I would try a reinstall--not as painful as it sounds.  remove CRM and reinstall, pointing to your existing environment.  This should fix any missing files.
    • Marked as answer by Jim Glass Jr Thursday, October 8, 2009 2:54 PM
    Thursday, October 8, 2009 1:37 PM
    Moderator
  • Thanks Joel,  I did manage to resolve this in the end.  The database name had brackets in it and it was this that was causing problems with CRM as CRM does not support any non alphanumeric dashes in the organisation name and would convert then to underscores during processing.  The uninstallation wizard needs to examine the BuildVersion table but if the brackets were replaced with underscores the table with this database schema will not be found.  So what we did to resolve the issue was re-imported the organisation with the new name and removed the existing one.

     


    SJM09
    Thursday, October 8, 2009 4:04 PM
  • I'm getting an Unexpected error when I try to attach files in CRM.  This did not happen when we were on Rollup 5, but it does now that we are on Rollup 7.  We have to stay on Rollup 7 in order for our Quick Campaigns to work.  I enable tracing and this is the error we get:

    Column 'BlockedAttachmentsForDownload' does not exist on Table 'Deployment'

    Our database does not have any spaces or brackets so that is not the issue.  Any ideas?
    Friday, January 22, 2010 5:46 PM
  • We're getting the same error with CRM 4 update 8. At first we tried updating with Rollup 10, then Rollup 13, but it still doesn't work. Reinstalling doesn't fix the issue and is a lame answer - I've been working with Microsoft for a god-blessed MONTH to install CRM on a new server since the old server died and all these issues popped up. I've likely installed CRM 10-20 times with various failures, all documented by our kind and wise Microsoft support engineers.
    Tuesday, December 28, 2010 3:48 PM
  • any resolution to this????
    Regards, Bill
    Friday, January 21, 2011 9:39 PM
  • any resolution to this????
    Regards, Bill
    Friday, January 21, 2011 9:39 PM
  • Very odd solution for us....  we uninstalled UR13.  Then reapplied UR13.  All is well.
    Regards, Bill
    Wednesday, January 26, 2011 2:23 PM
  • I uninstalled all Roll-Ups down to and including Rollup 6 ... then reinstalled Rollup 6.. Boom, I can view attachments now.  I then installed the latest rollup (21 at this point, in May 2012). Still able to view attachments, all is good.

    Not a very good error message though, as the "Deployment" table still does not have a column named "BlockedAttachmentsForDownload", but the process works now.

    Friday, May 11, 2012 2:23 PM