none
UI interface in HPC clusters RRS feed

  • Question

  • I need to write a program with parallel computation of 2 computers, 8 core each, with an MFC application (can't accept Win32 Console application) using Visual Studio 2008. Thread 0 of the program is used to display a dialog window for accepting user to input an integer, all the threads will perform the calculation then, the result of the calculation with be displayed again by thread 0 operation using the command AfxMessageBox.

    When I run the program using a single computer, under Visual Studio environment, by setting 'C:\Program Files\Microsoft HPC Pack 2008 SDK\Bin\mpiexec.exe' in 'Command' and "$(TargetPath)" in Command Arguments of 'Debugging' Screen Inside Project Properties screen, I managed to see the dialog and result output on the pc.

    Then I setup the cluster by using Microsoft HPC Pack 2008 R2, with a computer named 'HEADNODE' and the other named 'NODE1'. I copied the executable of the program above into both node. Using HPC 2008 R2 Cluster Manager, confirming that both nodes are on-line, I submit the job by running the executable into both nodes. No dialog display can be seen on the computer that's submitting the job and operation can't be followed.

    I used Task manager to view the tasks and can see that the threads can be started successfully in both the pcs of the HEADNODE and NODE1. I think the program just on-hold and waiting for my input in the 'dialog window'.

    In the above situation for 2 PC running, how can I modify my program such that the dialog window can be displayed on the computer that's running thread 0?

    Thanks a lot for your help.

    Regards, Simon


    Thursday, February 4, 2016 4:11 AM

Answers

  • Hi Simon,

      In order for you to see the dialog, you need to submit job with HPC_ATTACHTOSESSION so that the job will running in existing active session. You can check here for details: https://technet.microsoft.com/en-us/library/gg315415(v=ws.10).aspx

    • Proposed as answer by Qiufang Friday, February 5, 2016 1:52 AM
    • Marked as answer by Simon Tong Monday, March 21, 2016 2:17 AM
    Friday, February 5, 2016 1:52 AM
  • Hi, Simon,

    You create the job under the same administrator account, and whether the "run as user" of the job is still the same administrator account? ("Run as user" means when you submit job, it will pop up to let you input the credential to running job, from HpcJobManager, you can add the column "Run As User" to show)

    • Marked as answer by Simon Tong Tuesday, March 22, 2016 2:21 AM
    Tuesday, March 22, 2016 1:36 AM

All replies

  • Hi Simon,

      In order for you to see the dialog, you need to submit job with HPC_ATTACHTOSESSION so that the job will running in existing active session. You can check here for details: https://technet.microsoft.com/en-us/library/gg315415(v=ws.10).aspx

    • Proposed as answer by Qiufang Friday, February 5, 2016 1:52 AM
    • Marked as answer by Simon Tong Monday, March 21, 2016 2:17 AM
    Friday, February 5, 2016 1:52 AM
  • Dear Qiufang,

    Thanks for your information as I can managed to see the Dialog Window, running under a cluster of 2 pcs in my first testing.

    It's strange, however, that I tried to the run the job again in HPC Manager, under the same cluster configuration, the job failed and reports 'Error from node: NODE01: Unable to connect to remote desktop session'.

    This message occurred before and I managed to solve it by setting 'Allow connections from computers running any version of Remote Desktop (less secure)' under 'Remote' of 'System Properties' of HEADNODE. However, in this time, both NODE01 and HEADNODE gets this settings but problem still occurred.

    Suspecting it's a firewall problem, I have turned off Firewall for all of 'Domain Profile', 'Private Profile' and 'Public Profile'. Under the Tab of Inbound Rules in 'Windows Firewall with Advanved Security', the name 'Remote Desktop (TCP-In) for Domain Profile is also enabled.

    I also tried to perform 'Remote Desktop Connection' at NODE01 to connect to HEADNODE and it can be done.

    Could you provide me some idea in solving this problem?

    Thanks.

    Regards, Simon

    Friday, March 18, 2016 9:51 AM
  • Hi Simon,

      1. Which environment variable did you use in your job? HPC_ATTACHTOSESSION or HPC_ATTACHTOCONSOLE ? What value are you using? True or Try?

      2. Did you log on the machine first with the same user account as your job? If not, your job will fail.


    Qiufang Shi

    Monday, March 21, 2016 1:52 AM
  • Dear Qiufang Shi,

    I am using HPC_ATTACHTOSESSION, value is set to True.

    I log on the machine using adminstrator account and then create the job also under adminstrator account. Strange that it fails running.

    Appreciate for your further ideas on this.

    Thanks a lot

    Regards, Simon

    Monday, March 21, 2016 10:08 AM
  • Hi, Simon,

    You create the job under the same administrator account, and whether the "run as user" of the job is still the same administrator account? ("Run as user" means when you submit job, it will pop up to let you input the credential to running job, from HpcJobManager, you can add the column "Run As User" to show)

    • Marked as answer by Simon Tong Tuesday, March 22, 2016 2:21 AM
    Tuesday, March 22, 2016 1:36 AM
  • Dear Yongjun Tian,

    After adding the 'run as user' column, I found that both Owner and Run as User column shows the same user (TREND\Administrator), but it still fails. By the way, there's isn't a pop up to let me input the credential (user/password) when I submit the job.

    I remembered that I have changed the password of both the Administrator account of both HEADNODE and NODE01, is it related? Just wonder if this problem can be solved by showing the pop up and let me input the Adminstrator password again.

    Thanks.

    Regards, Simon

    Wednesday, March 23, 2016 2:26 AM
  • Dear all,

    I entered 'Options' manual and pressed 'Clear Cached Job Credentials'. When I submit the job again, a pop up appears to let me to enter the TREND\Administrator password of the HEADNODE. I resubmit the job but still

    Error from NODE01: Unable to connect to remote desktop session is reported.

    I have entered user/password of NODE01, is it related?

    Thanks.

    Regards, Simon

    Wednesday, March 23, 2016 2:34 AM
  • Last mail should read

    'I haven't re-entered the user/password of Administrator account of NODE01, is it related?'

    Thanks.

    Regards, Simon

    Wednesday, March 23, 2016 2:36 AM
  • Hi, Simon,

    "Trend\Administrator" is the domain user, right? if it is the domain user, you don't need change the password on both HEADNODE and NODE01.

    and "Trend\Administrator" is also added as HPC user, what is the role for "Trend\Administrator",  HPC administator or user?

    Wednesday, March 23, 2016 2:37 AM
  • Hi, all.

    Finally, I managed to run the job successfully by entering node management at the HEADNODE, select 'NODE01' at large window, right click and then select Remote Desktop and re-entered the credentials. On the other hand, I enter node management at NODE01, select HEADNODE and re-entered the credentials.

    Thanks.

    Regards, Simon 

    Wednesday, March 23, 2016 2:47 AM
  • Hi, Simon,

    Great to know you solve the issue, so the original Remote desktop session still use the old password to login, right? then you change the password?

    Wednesday, March 23, 2016 2:50 AM
  • Hi, Yongjun Tian,

    Yes, should be so.

    Wednesday, March 23, 2016 5:41 AM