Problem (bug?) with SQLite for Windows runtime RRS feed

  • Question

  • Hello,

    I've got an SQLite database file (.db) which is created by a video game. I've installed the SQLite for Windows runtime component.

    Via the data connection wizard, I connect to the db file. The db tables are well listed, I choose them all and click Next. After a long while (db file is pretty huge), error:

    The object reference is not set to an instance of an object.

    No tables are added.

    I've tried to only add the few first tables and it worked ! Then I added the tables one by one and, with few tables, I got some errors like this:

    SELECT statement absent or incomplete.
    Impossible to analyse the request string.

    Error in the SELECT* statement: expression nearby ','.
    FROM statement absent.
    Impossible to analyse the request string.

    After adding a couple of table more, I got the error:

    An exception occured during the generation of the property of the data source generator.

    And in the error list of VS, this error appears:

    Error of the personnal tool: Code generation failure. Impossible to convert the input xml file to a Dataset. The content model becomes ambiguous when element 'http://tempuri.org/DataSet1.xsdolicy_FreeUnitClasses' is defined several times.

    Did someone experienced problems with SQLite for Windows runtime tool ?

    • Moved by Caillen Wednesday, August 6, 2014 2:50 AM
    Tuesday, August 5, 2014 10:28 AM


  • Hi friend,

    SQLite is the third-party software. Your post is out of our support. I would suggest you to go SQLite Support for better support.

    Have a nice day!


    • Edited by Kristin Xie Wednesday, August 6, 2014 2:46 AM
    • Proposed as answer by Just Karl Wednesday, August 6, 2014 2:20 PM
    • Marked as answer by Just Karl Saturday, August 23, 2014 6:17 PM
    Wednesday, August 6, 2014 2:45 AM