locked
Slow loading views RRS feed

  • Question

  • I have a few computers experiencing slow loading views. The computers exceed all CRM 4.0 requirements and the network is 1gb/s. All of our computers, both the problematic and normal are running windows XP SP3 and are completely up to date with windows update. We only have 6-7 users connected at once.

    Any suggestions?

    Thanks

    Scott Coates
    Technical Specialist
    North America Traffic Inc.
    Tuesday, June 16, 2009 3:38 PM

Answers

All replies

  • Have you customized the view? If the search criteria cross entities, you will need build index.
    Also take a look the Performance whitepaper.

    Cheers,
    Jim


    Jim Wang - MVP Dynamics CRM - http://jianwang.blogspot.com , http://mscrm.cn
    Tuesday, June 16, 2009 4:24 PM
    Moderator
  • To keep a level of performance in CRM 4.0, it is highly recommended to drive 1 time a day the stat update in Microsoft SQL 2005 and more, especially if a large number of registration are changed or when you import a Many item via DMM (Data Migration Manager).

    Expect the update stat during the night.

    SQL stat update is made when not occupied, but with the addition of some plugin, the CRM roll of permanent jobs, which has the effect that SQL can not do its update stat.

    Another thing for performance

    Following the installation of rollup3 Microsoft Dynamics CRM 4.0 workflow containing some email service stopped working and impossible to publish, more open view of the contact takes about 45 seconds to open with a contact about 45000 contact.

    solution:

    Go change the CRM web.config, add the following lines at the end of the section <authorizedTypes>

    <authorizedType Assembly="mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" Namespace="System" TypeName="Void" Authorized="True"/>
     
    <authorizedType Assembly="mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" Namespace="System.Globalization" TypeName="CultureInfo" Authorized="True"/>

    make an iisreset
    Open CRM and test
    Tuesday, June 16, 2009 6:53 PM
  • You might also want to check any anti-virus software running as that can interfere with performance.  CRM should be added as an excluded site so the virus scan ignores the page loads.  Also, ensure users have IE settings to use cached pages for viewing rather than render the web page everytime a page is visited and that the cache size is set to a low number.  I think you will find several of these suggestions in the whitepaper that Jim referenced.
    Best Regards, Donna
    Tuesday, June 16, 2009 8:54 PM
  • Thanks for the help, I have made some changes and it has sped it up, but there is still some lag, about 10-15 seconds. I have adjusted IE settings and check the AV settings. My CRM is running on Server 2008 32 bit. Is there white papers for this? As it is different then server 2003.


    Thanks

    Scott Coates
    Technical Specialist
    North America Traffic Inc.
    Wednesday, June 17, 2009 2:22 PM
  • Scott,

    What have you done to improve it? 10-15 seconds response time still not ideal.

    Are you using SQL server 2008? If so, there are something you can do!
    Improving Microsoft Dynamics CRM Performance and Securing Data with Microsoft SQL Server 2008

    Cheers,
    Jim
    Jim Wang - MVP Dynamics CRM - http://jianwang.blogspot.com , http://mscrm.cn
    Wednesday, June 17, 2009 2:42 PM
    Moderator
  • My Setup is as follows
    CRM Server - Windows 2008 Standard (32 bit)
    Main Server is SBS 2003 Premium running SQL 2005, exchange, DNS etc.
    The CRM database is just over 3GB
    We are also running Infor Visual on the main server.
    We have 11 client computers on our network
    5-7 clients are connected to CRM at any given time.
    Most connect using IE, including the ones having the loading problems
    I have done

    "solution:

    Go change the CRM web.config, add the following lines at the end of the section <authorizedTypes>

    <authorizedType Assembly="mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" Namespace="System" TypeName="Void" Authorized="True"/>
     
    <authorizedType Assembly="mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" Namespace="System.Globalization" TypeName="CultureInfo" Authorized="True"/>

    make an iisreset"

    and

    "
     

    1.    In the Internet Options dialog box, under Temporary Internet Files, select the Automatically check for newer versions of pages check box, under Amount of disk space to use, specify a value from 200 to 300 megabytes of disk space for temporary Internet files, and then c lick OK."

     

    That cut the load time in half.

    Wednesday, June 17, 2009 3:13 PM