none
windows live writer 2010 editor: impossibly and insufferably slow

    Question

  • sorry if this is duplicated, but i've spent days of time searching forums and google and i have never found a solution to this problem. i find random posts starting in 2007 or 2008 saying that the problem exists, is well known, and is being looked into, but to date i have never found a solution. i will say that the 2009 version of windows live writer was slow at times, but for the most part it was totally usable. i prefer most (but not all) of the new ui changes in 2010 so i am forcing myself to try to suffer through the slow downs, but this morning it has become unbearable... to a point that i am considering rolling back (again) to 2009.

    i have an older box, a p4 (ht! lol, shh), running windows 7 32-bit. it provides decent speeds for almost everything i do. 2gb of memory and a decent (also old) nvidia 7900 gt video card. this computer flies with office applications, etc., and windows live essentials 2009 was acceptable --- so i don't suspect the pc.

    is there anything i can do? i have themes off while editing, but i can't think of anything else that could be causing this.

    this morning i made a 30x3 table and started typing "sales". it took 2 minutes to complete. no images, nothing else on the page. just the spinning win7 donut.

    edit: i am disabling all possible options now including spell checker and will report back soon.

    in case microsoft is listening: customizable options for the ribbon please, including the ability to forcefully dock "open", "recent", "new page" and "new post".

    :(

    Monday, January 17, 2011 3:00 PM

All replies

  • after disabling all text auto-correction and spell checking options and all settings i could find that might impede performance... it made no difference at all. it's still terribly slow.

    any help would be appreciated!

    Monday, January 17, 2011 8:03 PM
  • I’m also trying to find a solution, without result. For me, the extreme slowdown happen after adding a table. I’ve also disabled theme-editing and real-time spelling, but nothing….2-5 seconds per character. Bigger the table…bigger the lag, try a nested table, uff. I’ am using WLW 2011 and it run fine if I don’t use tables. The problem occurs in both my works machines: Version: WLW 2011 – Build 15.4.3502.922 Notebook: Turion x2/4 GB/W7 64x Version: WLW 2011 – 15.4.3508.1109 PC: Phenom II/3Gb/W7 -84x Hope someone have a solution, in this moment I’m searching for alternatives for wlw despite I like it, I need to use tables for this project.
    Thursday, February 03, 2011 3:35 PM