locked
international dialing from the US RRS feed

  • Question

  • We've had employees complain that certain international numbers do not connect when dialed from the US on our OCS infrastructure (Cisco 2811 connected to a mediation server to OCS servers).  I called our provider today and did a few test calls. 

    For the number that does not work, he said that he saw where we were sending the 011 to dial international (which I understand because I set up the translation rule to do that), but we were also marking the call as "national" so they were adding another 011 to the call - thus ending up with 011011-rest-of-number.  This number happened to be in Brazil.

    For another number which actually works (Mexico), I dialed from communicator and he said that we were marking the call as "international" and also sending the 011 which caused things to work.

    My question is why would a certain number be marked as national and another be marked as international by our equipment when we only have 1 gateway and 1 dial-peer with only an incoming and outgong profile?  I have not configured anything around national or international.  I've played with the translation rules to see if I can convert the number plan or number type, but that doesn't seem to help.

    Here is some of our config:

    dial-peer voice 100 voip
     description To/From OCS2007
     translation-profile incoming OCSIncomingCalls
     translation-profile outgoing OCSOutgoingCalls
     preference 4
     destination-pattern ....
     session protocol sipv2
     session target ipv4:10.10.0.18
     session transport tcp
     incoming called-number .
     dtmf-relay rtp-nte
     codec g711ulaw
     no vad
    !

    voice translation-profile OCSOutgoingCalls
     translate called 104


    voice translation-rule 104
     rule 1 /^\+1765\(.......\)/ /\1/
     rule 2 /^1765\(.......\)/ /\1/
     rule 3 /^\+1\(..........\)/ /1\1/
     rule 4 /^\+011\(.+\)/ /011\1/ type any national
     rule 5 /^\(.......\)/ /\1/


    Rule 4 was just  rule 4 /^\+011\(.+\)/ /011\1/ until I added the "type any national" but as I said that didn't do what I thought it would do.

    Would the medation server or OCS server be marking certain numbers as "National" or "international"?  We only have 1 location profile and 1 phone usage and the "default policy" so I can't imagine why OCS would be doing this.

    Any thoughts?
    Wednesday, February 18, 2009 7:55 PM

Answers

  • My best guess is you set all outbound calls to unknown. If setting to International the Service provider may require the 011 be stripped which you can do in one of you translation profile rules but with what you explaned could get confusing, depending on the SP calls to mexico may not need to be set to international to work which is why a call to Brazil works and a call to Mexico fails.
    . My best advice is to set all calls to unknown through the ISDN interface if you are using one and for the translation rule set type and plan to unknown. This link may help, I know it talks about ISDN but its still a similar situation.

    https://supportwiki.cisco.com/ViewWiki/index.php/User_has_difficulty_getting_ISDN_equipment_to_make_a_connection_dialing_international_calls_due_to_a_call_type_mismatch

    Hope this helps

    Cheers
    Chris
    Chris http://voipnorm.blogspot.com/
    • Marked as answer by Jared2958 Thursday, February 19, 2009 7:51 PM
    Thursday, February 19, 2009 4:50 PM

All replies

  • My best guess is you set all outbound calls to unknown. If setting to International the Service provider may require the 011 be stripped which you can do in one of you translation profile rules but with what you explaned could get confusing, depending on the SP calls to mexico may not need to be set to international to work which is why a call to Brazil works and a call to Mexico fails.
    . My best advice is to set all calls to unknown through the ISDN interface if you are using one and for the translation rule set type and plan to unknown. This link may help, I know it talks about ISDN but its still a similar situation.

    https://supportwiki.cisco.com/ViewWiki/index.php/User_has_difficulty_getting_ISDN_equipment_to_make_a_connection_dialing_international_calls_due_to_a_call_type_mismatch

    Hope this helps

    Cheers
    Chris
    Chris http://voipnorm.blogspot.com/
    • Marked as answer by Jared2958 Thursday, February 19, 2009 7:51 PM
    Thursday, February 19, 2009 4:50 PM
  • Thanks!  I think that might have fixed it.  Will continue to do some testing, but both numbers work now where only 1 did before.

    I added the following line to our serial interface.


    interface Serial0/1/0:23
     no ip address
     encapsulation hdlc
     isdn switch-type primary-ni
     isdn incoming-voice voice
     isdn map address .* plan unknown type unknown
     isdn bchan-number-order ascending
     no cdp enable
    !
    Thursday, February 19, 2009 7:51 PM