none
running synctoy in windows 7, does not work with task scheduler

    Question

  • Hi!

    I am running Windows 7 and I would like to backup my files on a network drive.  I downloaded syncToy 2.1 and it works fine manually, but now I am trying to schedule it through the task scheduler.  I looked on several forums and was able to input the command to run successfully (running synctoycmd.exe), but when it runs it opens a cmd terminal and then closes it before I can read what it said. I look in the files I told it to back up and nothing has changed, it did not work.

    I appended the suffix -R, then I tried -R "documentsbackup" (the backup name in synctoy), but all have the same result.

    The history page just says it ran successfully and is not helpful.

    Please help! I looked everywhere, no one else seems to have this problem. I don't know what to do, because I can't see the error output. If anyone knows how to fix this or at least get it to where I can read what it says, I would really appreciate it!

    Thanks!

    Monday, January 17, 2011 4:05 PM

All replies

  • Is your problem that SyncToy is not being executed by the windows task scheduler, or that you cannot see history of the sync actions that occured?

    You can view the SyncToy log by opening SyncToy, and click on File->View log, or in Windows 7 you can find the SyncToy log file inside of C:\Users\<username>\AppData\Local\Microsoft\SyncToy\2.0.  You can check out the file SyncToyLog.txt to confirm that your task is not being executed.   

     


    Maria del Mar Alvarez Rohena Microsoft Sync Framework
    Thursday, February 03, 2011 1:53 AM
  • Maria,

     

    I think  terdfurguson is saying that SyncToy  can NOT be scheduled with the Task Scheduler in WIndows 7. It does not work.

    We have the same intention to use Scheduler with Sync Toy 2.1  Can you help us?

    Thanks

    Thursday, February 10, 2011 8:28 PM
  • I have sort of the same subject. For some reason I get an "Inavlid option" and then it says "-R is now available". When I click OK then it finishes up and everything seems to be updated on both sides. I don't understand why I get "Invalid option". The only argument that I have is -R because I wanted everything to update. I am using Windows 7.

    TIA.

    Luis

    Thursday, February 17, 2011 8:40 AM
  • I am having the exact same problem described by terdferguson.  Although the cmd prompt flashes, no action is recorded in the Sync Toy log.

    Friday, February 25, 2011 5:42 AM
  • I had the same problem but I fixed it by typing -R with a space before the hyphen but not after the R.
    • Proposed as answer by ItLifeLiving Friday, March 25, 2011 5:34 PM
    • Unproposed as answer by ItLifeLiving Friday, March 25, 2011 5:34 PM
    Saturday, March 05, 2011 5:04 PM
  • I have the same problem, but in my case the Task Scheduler shows me a (0x1) in the status column, I interpret that as a Return 1 (error) so I don't know what to do to get it to work.
    Tuesday, June 14, 2011 6:53 PM
  • I'm having the same issue on a brand new HP XPS8300 with Win7x64.  My backup drive is not a true NAS but connected to my wireless router's USB port.  Kicking off the folder pairs manually works without issues, but the scheduled task is not working.

     

    I get the same error message: "The ability to execute folder pairs from the commandline (-R option) is now available from SyncToyCmd.exe."

     

    The synchronization doesn't run, as the log shows:

    SYNC: 06/19/2011 08:16:51:970: -------------------------------------------------------------------------
    SYNC: 06/19/2011 08:16:52:001: Starting SyncToy, version 2.1.0.0, built 10/19/2009 3:04:38 AM.

     

    What's interesting is that I've scheduled all folder pairs to run at 5:00 a.m. each Sunday morning, yet there's nothing in the log at 5:00 a.m.

     

    MSFT, care to chime in here?  Is there any additional information you'd like us to provide?

    Sunday, June 19, 2011 2:35 PM
  • The documentation can be a little confusing about the use of the -R option because the usage examples all show a space after the R but there's a follow-on sentence that says:

        NOTE: There can be no space between the -R parameter and the MyFolderPair name.

    Also, I see nothing about have to put the folder-pair name in quotes.

    So, try using the following as your command:

       SyncToyCmd -Rdocumentsbackup

    Works for me ;-)

    Hope this helps.

     

    Monday, June 20, 2011 10:08 AM
  • Since I'm running all folder pairs there is not MyFolderPair name after the -R switch.  I thought that was the purpose of the switch - to run all folder pairs.

     

    Friday, July 08, 2011 1:11 PM
  • I have been runing 64bit SyncToy as a scheduled task for quite a while, with no problems at all.

    In the scheduled task Action step, my values are:

    Action --Start a program

    Program/script:  "C:\Program Files\SyncToy 2.1\SyncToyCmd.exe"

    Add arguements: -R

     

    Chuck

    Monday, July 18, 2011 12:25 AM
  • Chuck

    I am at wits end.  I cannot get synctoy 2.1 (64bit) to execute in win7.  I have the same info plugged in as you when I cretaed a new task in task scheduler. 

    Action --Start a program

    Program/script: "C:\Program Files\SyncToy 2.1\SyncToyCmd.exe"

    Add arguements: -R

    WTF.  Help.  This is so frustrating. 

    Friday, October 28, 2011 8:09 PM
  • Hi,

    I had the same problem scheduling synctoy 2.1 on windows 2008 server x64 in a local domain. I get the task working using "create basic task" instead "create task". I think the error was related to domain users permission.

    Hope this helps.

    Claudio

    • Proposed as answer by Steve_J_S Tuesday, November 01, 2011 10:43 AM
    • Unproposed as answer by Steve_J_S Tuesday, November 01, 2011 10:43 AM
    Sunday, October 30, 2011 9:12 AM
  • SyncToy works great using an automated batch file in Task Scheduler to automate backups during the night.

     

    To do this:

    1) First create a batch file with notepad - save with a memorable name and a file extension .bat

    Here is a copy of my Backup.bat

    cd "c:\program files\synctoy 2.1"
    Synctoycmd.exe -r PhotoEcho
    Synctoycmd.exe -r MusicEcho
    Synctoycmd.exe -r FilmsEcho
    Synctoycmd.exe -r SoftwareEcho
    Synctoycmd.exe -r WebSitesEcho

    I have had trouble with running "All Folder Pairs" as the large size of the job seems to break SyncToy, but using the above batch file it runs fine on each Share which are a max of 250MB.

    If you have spaces in your folder pair names then you will need parenthesis around them to get them to work correctly in the batch file - e.g. "photo echo"

    2) Next test the batch file by running it.

    3) Add the batch file to "task scheduler" to run automatically at a convenient time. Mine runs at 01:30 in the morning twice a week.

    4) Wait until it has run then check the log file (Open Synctoy and click "File" then "View Log") from this you should be able to see exactly what has happened.

     

    Steve

     

    Tuesday, November 01, 2011 11:03 AM
  • This one has been driving me nuts for months too - I finally got it work right on Win 7 x64 by creating Basic Task in Task Scheduler 

    Program/script:  "C:\Program Files\SyncToy 2.1\SyncToyCmd.exe"

    Add arguments:  -R (***WITH A LEADING SPACE IN FRONT OF THE -R IN THE ARGUMENTS WINDOW***)

    Syncs all folder pairs like a champ now.  Did not work when putting the -R argument in the program/script line after the closing quotation mark regardless of spaces.



    • Edited by Mike_EGS Wednesday, November 02, 2011 3:20 PM
    • Proposed as answer by Andrea_O Wednesday, November 02, 2011 4:05 PM
    Wednesday, November 02, 2011 3:19 PM
  • You solve my problem! Thanks a lot!

    Wednesday, November 02, 2011 4:06 PM
  • This is actually a good idea to solve the problem, but I'd like Sync Toy runs the backup all by itself, as it should be.

    Anyway thanks a lot it really works!

    Wednesday, November 02, 2011 4:14 PM
  • Now this is bizarre. I have another PC (brand new Dell Latitude E6520 laptop) running Win 7 x64 SP1 with all patches updates, same OS as the PC I got it working on... and it won't work despite using the same solution above.  I have tried all combinations of solutions proposed here & elsewhere on the web:

    attempt 1: add -R in the program script line after "C:\Program Files\SyncToy 2.1\SyncToyCmd.exe" - with and without a leading space

    attempt 2: add -R with leading space in the argument field

    attempt 3: add -Rbackup in the program script line after "C:\Program Files\SyncToy 2.1\SyncToyCmd.exe" - with and without a leading space (my folder pair name in SyncToy is backup)

    attempt 4: add -Rbackup with leading space in the argument field

    attempt 5: create a batch file with synctoycmd.exe -R - which works fine when executed by simply running it, or from a command prompt, but fails in Task Scheduler.

     

    Nothing works.  I am stumped.

     

    Friday, November 04, 2011 7:00 PM
  • Hi all,

     

    I found out that Synctoy seems to have a perculiar behaviour that could be the reason for all this error. It seems like Sync Toy when ran in Task scheduler is unable to recognize the network drive

     

    First, I cleared the log in Synctoy ("file\view log" click clear)

    next I run the task in task scheduler. it says completed with 0x01

    I open the log in Synctoy and found that it cannot recognize any of my Network drive.

    however if I were to run SyncToy directly from the command line, it works as it is.

    Putting the command into a cmd (batch file) doesnt solve the problem. (Again, executing the batch file from the command prompt will work, but running the batch using task scheduler will result in the same error as before (my source or target network drive not found)

     

    can some one please check if we have a patch update or something can be done with the task scheduler ?


    • Edited by joeyttk2001 Friday, November 11, 2011 10:50 AM
    • Proposed as answer by joeyttk2001 Friday, November 11, 2011 11:01 AM
    • Unproposed as answer by joeyttk2001 Friday, November 11, 2011 11:01 AM
    • Proposed as answer by Nicolas Dore Monday, January 16, 2012 6:11 AM
    Friday, November 11, 2011 10:49 AM
  • However, I found that if you face similiar problem with regards to synctoy not recognizing your network drive (when ran using task scheduler), it may also be a permission problem.

     

    I managed to work around it if I configure the task (in task scheduler) to run only when user is log on.

    In which case, as long as the logon user (aka the author) has access to the network, my sync toy task will run properly.

    • Proposed as answer by joeyttk2001 Friday, November 11, 2011 11:03 AM
    Friday, November 11, 2011 11:03 AM
  • To schedule it through the task scheduler you need, for example, this: C:\Program Files\SyncToy 2.1\SyncToyCmd.exe -R "NAS-P5KE"

    NAS-P5KE = the name of the folder pair

    Monday, November 14, 2011 3:09 AM
  • I too cannot get synctoy to work but it does not work via command line nor scheduler.  I get a folder pair not found error.  Now when i switch the account i created during the win7 64bit install it works fine.  Some sort of permissions problem?  I can run it just fine from the GUI however.

     


    • Edited by jimkiler Friday, December 09, 2011 2:53 AM
    Friday, December 09, 2011 2:52 AM
  • I keep on getting this message when I set this up in schedular.

     

    I am using w7 64 bit sysnctoy 2.0. Anybody has any valid solution............

     

    Saturday, December 10, 2011 4:41 AM
  • This one has been driving me nuts for months too - I finally got it work right on Win 7 x64 by creating Basic Task in Task Scheduler 

    Program/script:  "C:\Program Files\SyncToy 2.1\SyncToyCmd.exe"

    Add arguments:  -R (***WITH A LEADING SPACE IN FRONT OF THE -R IN THE ARGUMENTS WINDOW***)

    Syncs all folder pairs like a champ now.  Did not work when putting the -R argument in the program/script line after the closing quotation mark regardless of spaces.



    What is "LEADING SPACE" ??
    Monday, December 12, 2011 11:09 AM
  • I'm running Windows 7 Premium 64bit. I've been dicking around with this for two days and finally got it to work.

    I was getting the same symptoms with the (0x1) code and the DOS window rapidly appearing and disappearing.

    When you create a pair, it generates a hidden SyncToy_<------>.dat file in the right folder if you are running Echo. If that file is missing or more than one (possible) it won't run in task Scheduler.

    Enable hidden files in Folder Options and check for this file. If there is more than one, delete both and regenerate the pair. Also regenerate the pair if it's missing.

    If you are running a utility program deleting the files in your right folder (may case), add the file to your softwares' filter.

    Hope this helps someone.

     

     

     

     

     

    Thursday, December 29, 2011 12:39 AM
  • When I put the leading space in front of the -R in the add arguments, the task scheduler remove the leading space.

    How do you put the leading space without it being trimmed by task scheduler???

    Sunday, January 08, 2012 3:13 PM
  • Had similar issue with Synctoy where task scheduler was reporting (0x1) in a batch or with the program with or without the leading space before the argument. Running the task only when user logged in fixed the issue

     

    Oh and if you want the task to run without a user logged in, just just the UNC path \\Server\Share instead of the network drive in SyncToy

    Monday, January 16, 2012 6:14 AM
  • Try this solution, it worked for me.

    If you've already created a task, delete it.  Create a new BASIC Task and follow the steps that SyncToy gives to create the task. At the end DO NOT check the box that says, "Open Properties dialog for this task when I click Finish".  Now try and run the task by clicking on the "Run" option in the Action menu on the right pane of Task Scheduler or schedule it a few minutes in the future so you can test to see if it works.  It should work.

    Now if you go into the task and try and edit anything and it asks you to ENTER YOUR CREDENTIALS, the task will FAIL.  As long as the task is created WITHOUT it asking you to enter your credentials the task will run.

    I haven't gotten into why this is happening but as soon as I find out (or if anyone knows), please post it here.

    • Proposed as answer by louisb323 Monday, January 16, 2012 10:22 PM
    Monday, January 16, 2012 9:46 PM
  • Hi,

    My case is even stranger than those reported. I'm running win7 ultimate (sp1). Scheduled suncing is implemented successfully, but I keep getting this puzzling error message:

    "The ability to execute folder pairs from the commandline (-R option) is now available from SyncToyCmd.exe."

    So, my questions is: how do you get rid of the erronous message?

     

     

    Friday, January 20, 2012 11:35 AM
  • I was getting the (0x1) message in the "Last Run Result" box also.

    In trying to follow Mike_EGS advice about inputting the Leading Space I discovered that if you tried to put it in the "Add arguments (optional) box, it wasn't apparent that it was being added.  But if you added the option to the Program/script,

    example:  "C:\Program Files\SyncToy 2.1\SyncToyCmd.exe" -R "Lenovo_BACKUP"

    let the task scheduler complain that it appears that arguments are being included..... , say "yes" to let it resolve, then you can see the leading space in the arguments box.

     

    This removed my (0x1) error msg and started to show results.

     

    Also while I can find the log file in the directory structure as mentioned in these posts, I'm perplexed as to why when I go >File >View Log ...the log file window comes up blank.

     

    Hope this helps.

    Sunday, January 22, 2012 2:41 PM
  • We obviously have a combination of issues going on here, but my problem was not caused by either the space before the -R nor the use of the UNC vs Mapped Drive letter.  My problem was resolved by selecting the "Run Only if User Logged On" option in Task Scheduler.

     

    Wednesday, February 01, 2012 4:20 PM
  • You have to use c:\program files\Synctoycmd.exe

    To run when logged off, create the task as a user with administrater privledges.
    Use UNC paths instead of drive letters
    Use quotes for the path
    For Example: 

    Rght side = "\\server1\c$\mystuff"
    Left Side = "\\server2\d$\mystuff"

    This way it will run when you are logged of of the compter, or if someone else is logged in.



    • Edited by RickkeeC Saturday, August 18, 2012 11:54 PM
    • Proposed as answer by 409industries Tuesday, April 02, 2013 5:00 PM
    Saturday, August 18, 2012 11:51 PM
  • I had the same problem... Make sure there is a single space in front of the dash....     Copy everything inside the quotes...     " -R"  

    That worked for me!

    Try that first without using the particular names. If it works then you can move on and add your folder name in Quotes after the, should look like this " -R"sample folder"" (note the double quotes, thats just so you know what to type in. 
    Tuesday, September 25, 2012 5:28 PM
  • I have set this up on Server 2008 R2 which is pretty similar to Windows 7 Task Scheduler. RickkeeC's answer is pretty close to the solution that i found.

    SyncToy was failing because it did not recognize / could not access the mapped drive that i had for my "Left Side" folder. So, indeed UNC file paths were the way to go, however i could use a local directory on the machine that is hosting the scheduled task. I used the following, and got my scheduled synctoy process to run successfully.

    Left Side: \\SERVER1\C$\directory

    Right Side: C:\Share

    It did not make a difference using spaces before the -R argument, etc. Just be sure to check the log in SyncToy for errors (Files > View Log). It clearly said "cannot access drive Z:\" When i had it mapped, even though the domain account i was using has full access to everything.

    I also had the options enabled under the task properties:

    "Run whether user is logged on or not"

    "Run with highest privileges"

    Hope this helps!


    Tuesday, April 02, 2013 5:00 PM
  • I had this problem using Windows 7 64-bit. I changed the folder name to the network share name (\\Server\Share\) and it worked.
    Friday, November 01, 2013 9:49 AM
  • Thanks Andrea_O

    you give me breath. its works wonderful. Thanks a TON....


    Jags

    Thursday, December 19, 2013 11:42 AM
  • Hi,

    I had the same problem but found that deleting the task and simply making a new one with a space in front of the -R solved the problem.  I tried editing the old task but that didn't help

    Hope this helps

    Friday, January 03, 2014 8:52 AM
  • I did the same and worked perfect!. Mapped Network Drives are not recognized apparently. :-)
    Tuesday, February 25, 2014 12:10 AM