locked
CRM 4.0 Router and Exchange 2007 Timeout RRS feed

  • Question

  • Hi all -

     

    We have a new CRM 4 install setup to use the Email Router for mail.  We can't seem to get the incoming mail to work.  For our profile we've tried:

    • Specific User - The only Admin account with access to send/receive as another user. 
    • User Specified - And we configured the users in the CRM client.
    • System Account

    The error is always the same,

     

    Event Type: Error
    Event Source: MSCRMEmail
    Event Category: None
    Event ID: 0
    Date:  4/25/2008
    Time:  9:47:17 AM
    User:  N/A
    Computer: UNIDYNAMICS01
    Description:
    #26090 - An error occurred while opening mailbox
    xxx@xxx.com. System.Net.WebException: The operation has timed out
       at System.Net.HttpWebRequest.GetRequestStream()
       at Microsoft.Crm.Tools.Email.Providers.HttpDavRequest.SubmitXmlCommand(HttpWebRequest httpWebRequest, String body)
       at Microsoft.Crm.Tools.Email.Providers.HttpDavRequest.RetrieveInboxUri()
       at Microsoft.Crm.Tools.Email.Providers.ExchangePollingMailboxProvider.OpenMailbox()
       at Microsoft.Crm.Tools.Email.Providers.CrmPollingMailboxProvider.Run()

     

    Any ideas?

     

    Thanks in advance,

    Bob

     

     

    Friday, April 25, 2008 1:55 PM

Answers

  • We found the solution.  In Exchange 2007, there are two servers, front-end and backup.  When the router asks for the URL to Exchange, we had entered the Outlook Web Access address.  This was WRONG! 

     

    What the router really wants is the address of the mailbox server.   Now our CRM router works fine.

     

    Bob

     

    Monday, April 28, 2008 2:17 PM

All replies