locked
SyncToy 2.0 - SyncToyCmd doesnt work with SMB targets RRS feed

  • Question

  • I've seen this posted before, but there hasnt been any resolutions.

    I have my folder pairs set up where the source folder is on my local machine and my target folder is on a Windows Home Server.  I target the home server via SMB - for example \\Server\UserFolder\Backups.  This sync's fine from the UI.  However, whenever I run SyncToyCmd -R from a cmd shell (and of course the task scheduler), I get

    c:\Program Files\SyncToy 2.0>synctoycmd -r
    SyncToyCmd has detected that the folder pair Music has not been synchronized yet
    . Please run SyncToy.exe to complete the initial synchronization.

    Note that I also get the same running synctoycmd -r Music.

    I have found that if I map a network drive to my WHS and do not use SMB, then synctoycmd works fine.

    Is this a bug in synctoy or can I configure something different to make it work the way I desire with SMB?  I would rather not map a network drive and want to run this using the task scheduler.

    Thanks,
    EG
    Sunday, May 17, 2009 4:31 PM

All replies

  • Hi EG

    This setup you mention should work with synctoycmd -R.  On what operating system are you running?  (XP/Vista/Windows7/etc)  For what architecture?  (x86/x64). 

    Can you check the SyncToy log (on Windows Vista: %LOCALAPPDATA%\Microsoft\SyncToy\2.0\SyncToyLog.log, on Windows XP: "%USERPROFILE%\Local Settings\Application Data\Microsoft\SyncToy\2.0\SyncToyLog.log") and send me the information for your SMB session.

    It will look something like this

    SYNC: 05/29/2009 18:57:45:145: SyncToy run of SMBTest2 (f:\left\, \\machine\folder) completed at 5/29/2009 6:57:45 PM.
    SyncToy action was 'Synchronize'.
    SyncToy options were:
    	Active for run all
    	All files included
    	No files excluded
    	Do not check file contents
    	Include read-only files
    	Include hidden files
    	Include system files
    	Backup older files (send to Recycle Bin)
    	All subfolders included
    SyncToy run took 00:00:01:201.
    Copied 1,986,796 bytes in 35 files in 00:00:01:201.
    Bytes per second 1,654,263.8, files per second 29.1.
    

    Maria del Mar Alvarez Rohena Microsoft Sync Framework
    Saturday, May 30, 2009 2:06 AM
  • Hi Maria - thanks for the reply.

    My left folder is on Vista Ultimate x86 and my right folder is on Window Home Server 2008.  Here is the bottom 2 sessions from my log.  The top one was run successfully from the UI (and is a partial log from a "run all folder pairings" and the bottom one was run via the cmd and failed.  Let me know if I can provide you with any further information.  I'm anxious to fix this.  Note that if switched my folder pairing to making the right side a mapped drive (say X: instead of \\SERVER) then the cmd line will succeed.

    SYNC: 05/29/2009 16:33:32:629: SyncToy run of EG (partial) (C:\Users\EG\, \\SERVER\Users\EG\Backups\Synced\EG\) completed at 5/29/2009 4:33:32 PM.
    SyncToy action was 'Echo'.
    SyncToy options were:
     Active for run all
     All files included
     Files excluded: ntuser.*
     Do not check file contents
     Include read-only files
     Include hidden files
     Do not include system files
     Backup older files (send to Recycle Bin)
     Some subfolders included
    SyncToy run took 00:03:17:451.
    Copied 1,273,512,068 bytes in 19 files in 00:03:17:451.
    Bytes per second 6,449,738.7, files per second 0.1.
    Avoided copying 12,255,391,714 bytes in 34,608 files that did not require action.
    Saved approximately 00:31:40:138 by not copying all files.

    SYNC: 05/29/2009 20:22:39:691: -------------------------------------------------------------------------
    SYNC: 05/29/2009 20:22:39:691: Starting SyncToyCmd, version 2.0.100.0, built 8/12/2008 2:07:12 PM.
    SYNC: 05/29/2009 20:22:39:847: *** SyncToyCmd has detected that the folder pair Music has not been synchronized yet. Please run SyncToy.exe to complete the initial synchronization.
    SYNC: 05/29/2009 20:22:39:862: *** SyncToyCmd has detected that the folder pair Videos has not been synchronized yet. Please run SyncToy.exe to complete the initial synchronization.
    SYNC: 05/29/2009 20:22:39:893: *** SyncToyCmd has detected that the folder pair Pictures has not been synchronized yet. Please run SyncToy.exe to complete the initial synchronization.
    SYNC: 05/29/2009 20:22:39:925: *** SyncToyCmd has detected that the folder pair Audio Content has not been synchronized yet. Please run SyncToy.exe to complete the initial synchronization.
    SYNC: 05/29/2009 20:22:39:956: *** SyncToyCmd has detected that the folder pair EG (partial) has not been synchronized yet. Please run SyncToy.exe to complete the initial synchronization.

    Saturday, May 30, 2009 3:31 AM
  • Maria - Any other thoughts on this?
    Monday, June 15, 2009 4:14 AM
  • I received the same error message.  For me, deleting the folder pair and re-creating them did the trick.
    Wednesday, June 16, 2010 4:27 AM
  • Thanks, kenmanblue! Delete, then re-create folder pair works for me too.
    Monday, August 8, 2011 7:43 AM