locked
Remote Access error in WHS occurs from LAN but not from Internet RRS feed

  • Question

  • Hi,

    <<Caveat: novice to both WHS and this forum … please redirect if necessary>>

    My config is: dsl Modem (Actiontec GT107) --> Tomato wireless router (running on Linksys WRT54GS hardware) -- WHS.  Its set up fine and servicing my network computers fine (backup, file sharing, etc). Its remote access I have one glitch with. Remote Access is actually working -- I can get to it as long as I'm NOT on my local LAN.  So from an offsite location, can get to the WHS landing page and log-in. However, the top of remote access page says "not available" when I run Details it says it can't verify my web site is acceessable from the internet. I'd like to be able to see it locally so I can start working on the landing page, etc. without having to go to a Starbucks ... from reading on this, it sounds like it is some kind of weird loopback error.... Can you help? Where do I start ?

    Details:

    ·     The DSL modem has a static IP issued by my ISP and I'm port forwarding 443 and 4125 from the modem --> router --> WHS (NOT forwarding port 80 here as I'm using that for another web server)

    ·     DSL modem  is not running DHCP or a firewall but is running NAT

    ·     The router has a static IP address that the modem routes to statically.  The router does DHCP for both wired and wireless downstream clients, NAT on (thus I’m 2x NATTed – which considering my given name, I’m perfectly fine with J ), firewall on

    ·     WHS – has statically assigned IP address on the router submask (all clients can see him, works flawlessly here). Router has port forwarding set up sending 443, 4125 to WHS.

    ·     I don’t have remote config. Enabled on either the modem  or router to confuse issues.  Only get to them through the LAN.   

    ·     Error reads: “Local web server or firewall issue may have occurred …” I have screen grabs of remote access and Details within the WHS console but can't figure out how to attach to this thread.

    What I’ve tried:

    ·          Locating the WHS on the LAN of the modem rather than the router – error persisted.

    ·          On the Tomato router trying toggling the NAT loopback option (under Firewall) from default forward only, to all and disabled.  Made no difference.

    ·          Have gone through all options on WHS console – queried support websites.

    ·          Looked at the underlying W2K3 box on which WHS is running… remote admin is NOT enabled but not sure that won’t just muddle the waters further.

    ·          Ran Shield Up! Query – all ports shut down except 443 and 4125.

    What I haven’t tried:

    ·          Creating DMZ anywhere – do want to go there – too risky for home server.

    ·          Using the Application Forwarding feature of the Actiontec modem – seems like expanding the capabilities of simple port forwarding and again, want to keep this as tight as possible

    Any thoughts ?

    -- Nat

     

    Friday, October 22, 2010 7:36 AM

All replies

  • This is fairly common behavior; many consumer routers (and some "business" routers) can't handle a loopback connection properly.

    If you can't reach your server using e.g. http://myserver.homeserver.com, try http://myserver instead. Substitute your own vanity URL in the first case, and your own server name in the second case. You will see a certificate error; this is also normal, as the SSL certificate you have is for your vanity URL, and doesn't know anything about your server's internal hostname.


    I'm not on the WHS team, I just post a lot. :)
    Friday, October 22, 2010 12:26 PM
    Moderator
  • Hi Ken,

    Not sure I'm following this.  Let's say the Windows Live Custome Domain is reddingo.homeserver.com. And I'm ONLY gettng to this through secure login -- so its going to be https://.  Anyway, I tried:

     http://reddingo and https://reddingo.com

    http://reddingo.homeserver and https://reddingo.homeserver.com

    Not sure what you mean by "substitute your own vanity URL in the first, and your own server name in the second case."

    These typically brought up a search engine or "IE cannot display wep page" ...

    Thanks,

     

    -- Nat

    Friday, October 22, 2010 8:32 PM
  • **Sorry to raise an old post, but thanks Ken**

    I couldn't connect to my home server through http://server.homeserver.com or http://server  however I could connect by using my public Ip address as http://publicaddress which narrowed it down to be a dns issue. After further research i noticed that the dns server was not set correctly in the Static Feild. All working well now!

    Thanks again

    -Michael

    Wednesday, January 5, 2011 1:57 AM
  • Michael

    I have the same issue - where is the Static Field for the DNS issue and how do you set it?

    Monday, February 21, 2011 2:36 AM
  • Hi  Michael,

    The DNS settings are local to the network settings, depending what OS you are running, its normally a matter of setting an IP range in the windows network LAN.

    **old issue so im sure this has been resolved**

    Friday, May 6, 2011 12:34 AM