locked
Noob Questions Regarding Hosted OCS RRS feed

  • Question

  • I am considering deploying OCS in small offices that currently use a major hosted Exchange provider where that provider also provides hosted OCS. I bought one phone to test OCS before we try to do an entire office.

    I have Office Communicator enabled for one account and I have the PC client working.
    I have an LG Nortel (Tanjay) phone with R1 firmware 1.0.522.101 (1.23).
    I have done a hard reset on the phone
    I have not been able to get the phone connected to the OCS server.

    Questions
    Is this even possible?
    Any particular firewall settings needed on linksys or cisco gear?
    Will I need an OCS update the firmware? Can the firmware be updated via USB once I get to firmware 3.5.6907.0 ?
    Will I obtain the certificates from the hosted provider?
    When will I need a Multipoint control unt?

    Any advice would be appreciated.
    Thursday, June 11, 2009 4:58 AM

All replies

  • Is this even possible?
    YES

    Any particular firewall settings needed on linksys or cisco gear?
    Uses same ports as Communicator

    Will I need an OCS update the firmware? Can the firmware be updated via USB once I get to firmware 3.5.6907.0 ?
    It should be able to connect => Check with provider
    Tanjay must be updated to correctly work with OCS 2007 R2 => Check with provider for version of OCS
    Cannot update via USB needs OCS Update server => Check with provider


    Will I obtain the certificates from the hosted provider?
    Normally they should use public certificates => Check Provider

    When will I need a Multipoint control unt?
    Part of OCS and is used in conferencing scenario's
    - Belgian Unified Communications Community : http://www.pro-exchange.be -
    Thursday, June 11, 2009 9:42 AM
  • hmm... still no luck. This hosted exchange provider is one of the better ones and they haven't setup a Tanjay phone before.

    When they give out communicator software they ship a reg file to update the software client registry with a server name which is...

    pool1.(domain_name).(provider_name).net

    but on the Tanjay there isn't a way to specify an authentication server from the simple sign-in space where you only get...

    Sign-in address: me@mycompany.com
    Domain\User name: (domain_name)\(user_name)
    Password: mypassword

    I am pretty sure that the domain and user name are right. I assume that the Tanjay phone uses the 'mycompany.com' info to try and find the authentication server through something like a DNS lookup. I think this is the problem. Any other ideas? I have not played with the public certificates yet. The actual login error messages are...

    Signing in...
    Connecting to the Office Communications Server

    and eventually...

    Signing in...
    Cannot connect to the server. Retrying. If the problem persists, contact your system administrator.

    Thursday, June 11, 2009 3:28 PM
  • That is not supported for Tanjay
    Need to use DNS for Autoconfiguration

    A DNS SRV (service location) record for _sip._tls.<domain>, over port 443 where <domain> is the name of your organization's SIP domain. This SRV record must point to the A record of the Access Edge Server

    It looks like they are not using an EDGE Server...
    Are you sure they know what they are doing?


    - Belgian Unified Communications Community : http://www.pro-exchange.be -
    Thursday, June 11, 2009 3:34 PM
  • Are you sure they know what they are doing?

    Since I don't know what I am doing it is hard to tell. (grin)

    I have tried nslookup for some derivitives of my server, _sip._tcp, _sip._tls, _ldap._tcp
    I always get the result non-extent domain message

    I did add a contact to the communicator client though. I noticed that the contact's phone numbers appeared but were grayed out, so there are no softphone cababilities from OCS communicator on my computer even though the microphone, webcam and speakers are configured in communicator. Looks like I have version 2.0.6362 which I think is pre R2.

    Is it possible to get communicator working with OCS Server that has no Access Edge Server defined? Would this cause the above problem?

    • Edited by Krash_ Friday, June 12, 2009 2:01 PM
    Friday, June 12, 2009 1:03 AM
  • If you don't have any softphone capabilities in Communicator then you will never be able to login to the Phone because it requires Enterprise Voice Configured on the system/account
    (Microsoft BPOS also do not provide Enterprise Voice)

    Version 3.5.xxxx is Communicator R2

    What does the REGFILE have as server values?
    If the port says 443 it uses an EDGE if it says 5061 it does not use an EDGE
    - Belgian Unified Communications Community : http://www.pro-exchange.be -
    Friday, June 12, 2009 10:30 AM
  • If you don't have any softphone capabilities in Communicator then you will never be able to login to the Phone because it requires Enterprise Voice Configured on the system/account (Microsoft BPOS also do not provide Enterprise Voice)
    Probably the account does not have entreprise voice. The provider is an email provider does not have any other voice services. If that is the case is there a way to host the OCS remotely at this provider but still point to DNS SRV for SIP to a second hosted service providing Enterprise Voice to get the phones working?

    What does the REGFILE have as server values?
    If the port says 443 it uses an EDGE if it says 5061 it does not use an EDGE
    The regfile is posted below except for the actual domain and hosted provider name. Unless the transport entry identifies the port as well as the protocol, the reg entry doesn't show the port. I don't know whether 00000004 is the entry for TCP or TLS...

    Windows Registry Editor Version 5.00
    [HKEY_CURRENT_USER\Software\Microsoft\Shared\UcClient]
    "ConfigurationMode"=dword:00000001
    "Transport"=dword:00000004
    "ServerAddressInternal"="pool1.(domain_name).(provider_name).net"
    "ServerAddressExternal"="pool1.(domain_name).(provider_name).net"
    [HKEY_CURRENT_USER\Software\Policies\Microsoft\Communicator]
    "EnableURL"=dword:00000001

    Friday, June 12, 2009 2:01 PM