none
Can't install HPC client. .NET framework error

    Question

  • I'm trying to install the 2008 R2 HPC client on a Windows 7 x64 domain client. The installer starts, then fails with a message saying that .NET Framework 3.5 SP1 or later is required, and the installer exits. I've made sure that .NET Framework 3.5.1 is installed from Control Panel/Programs and Features/ Turn Windows features on or off, and I've also run the .NET verification tool which validates the installation of 3.5.1 ok.

    Am I missing something here? I've installed the client on other Win7 x64 clients without problem, but this is very odd.

    Friday, September 23, 2011 12:40 PM

Answers

  • Well, whatever the interactive install does, it failed every time, no matter what I tried. .NET Framework is definately installed and verified ok.

    In the end, I did manage to get it installed, but had to use the /quiet install switch, which obviously bypasses the pre-requisite checks. Works fine once it did install, so obviously .NET was working ok. This workaround might be useful to somebody.

    • Marked as answer by tman24 Monday, September 26, 2011 9:06 AM
    Monday, September 26, 2011 9:06 AM

All replies

  • Well, whatever the interactive install does, it failed every time, no matter what I tried. .NET Framework is definately installed and verified ok.

    In the end, I did manage to get it installed, but had to use the /quiet install switch, which obviously bypasses the pre-requisite checks. Works fine once it did install, so obviously .NET was working ok. This workaround might be useful to somebody.

    • Marked as answer by tman24 Monday, September 26, 2011 9:06 AM
    Monday, September 26, 2011 9:06 AM
  • Hi tman24,

    Could you provide us with the version number that was giving you trouble?

    Thanks,
    --Brian

    Monday, September 26, 2011 1:15 PM