program "ends" computer is still running, stored video inop RRS feed

  • Question

  • hello,I just started using hyperlapse, I have a TON of gopro videos to transform from unuseable to great with this. On my first set, I have loaded onto both my home desktop [overclocked i5 @4.1Ghz, 8Gb ram and SSD] and once i sorted a graphics card driver OPEN GL error, now my result is the same as my laptop [ASUS R500V i7 @3.5Ghz, 8Gb Ram] what happens is, I start the encoding, it runs for a while, and at some point, [ I speculate the end] hyperlapse just ends, dissapears, and is gone. if I open the destination folder, there is a converted video with the proper name for being post hyperlapse, and when i try to play that with ANY software i can find, everyone does the same one of two things, either wont play, or says this is unplayable. I am lost as to what to do to help this. I am using the latest version of the program released as of today. I would really like to get this going. the video clip is about 20 minutes long.

    the only thing i can imaging that hyperlapse doesnt like, is that the video clips are broken up into 26:04 minute sections. for some reason my gopro records them this way. for what it is worth, when i transferred the video to the computer for hyperlapse, i did not use gopro importer, i just put the card into a reader, and copied it to the folder i wanted.

    Please help! thank you for your time and patience.

    Thursday, July 30, 2015 10:40 PM

All replies

  • Have you enabled the hardware video encoder option? It's in the "gear" menu on the upper right. You can try toggling that option and see what happens.  It sounds like your graphics card driver is up-to-date, but that's a good thing to check as well. 

    Also, does it fail in both Advanced and Standard modes?

    Friday, July 31, 2015 4:48 PM
  • Thank you for your response!

    Yes I have tried both with and without the video encoder option.

    I have not tried the "standard" mode, because the video comparisons I have seen, I need the advanced mode. [my video is of mountain biking rides and stunts]

    from what i have gathered on my use, it seems to be that at some point, in the last half of the video [ video is 24minutes long] the system memory usage goes up, and floats between 94-99% used up. I got a new warning that paraphrased as, Windows stopped this program because of low memory.

    I am now trying the latest update! lets see what happens.

    also, if i was to upgrade to windows 10, does this program run on 10?

    Saturday, August 1, 2015 1:14 AM
  • First the easy question: Hyperlapse Pro runs fine on Windows 10.  Just make sure your drivers are all up-to-date.  All Windows 10 issues we've encountered were traced back to buggy drivers.

    Second, it does appear you're running into a low memory situation, which is odd because a 24 minute video should work fine with 8GB of memory.  As a test, try trimming one of the videos to about half length and see if that goes through.  Also make sure you're not running any other high-memory applications at the same time.  The new version of Hyperlapse does not change the memory usage much, so I don't expect that to help much.

    Sunday, August 2, 2015 8:17 PM
  • I'm having the same issue with the latest version of Hyperlapse 1.2 on Windows 10.  I have a i5 3 GHz quad core with 8gb of ram and I have the latest Intel video drivers.  I'm also converting GoPro 3+ Silver videos in 1080p in Advanced mode.  If my videos are under 10 minutes they'll encode, but if they're over 10 minutes I get either an out of memory warning or the hyperlapse application just closes on its own and leaves behind a corrupt incomplete video file.  Looking in the Event logs every time I see a memory exhaustion error.  This particular one I shutdown nearly everything and it went up till 7gb before crashing.  I've had the User Hardware option on every time, I'm going to try it without it now.

    - <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
    - <System>
      <Provider Name="Microsoft-Windows-Resource-Exhaustion-Detector" Guid="{9988748E-C2E8-4054-85F6-0C3E1CAD2470}" /> 
      <TimeCreated SystemTime="2015-08-06T21:47:28.398165400Z" /> 
      <Correlation ActivityID="{F9170AD6-16FF-438E-9695-675C4294D3EF}" /> 
      <Execution ProcessID="984" ThreadID="4248" /> 
      <Security UserID="S-1-5-18" /> 
    - <UserData>
    - <MemoryExhaustionInfo xmlns="http://www.microsoft.com/Windows/Resource/Exhaustion/Detector/Events">
    - <SystemInfo>
    - <ProcessInfo>
    - <Process_1>
    - <Process_2>
    - <Process_3>
    - <Process_4>
    - <Process_5>
      <Name /> 
    - <Process_6>
      <Name /> 
    - <PagedPoolInfo>
    - <Tag_1>
    - <Tag_2>
    - <Tag_3>
    - <NonPagedPoolInfo>
    - <Tag_1>
    - <Tag_2>
    - <Tag_3>
    - <ExhaustionEventInfo>

    Sunday, August 9, 2015 2:00 AM
  • I took and unchecked the "Use Hardware" checkbox in the settings menu and I was able to complete the same video but instead of consuming 7+gb of memory it capped out at 4gb of usage.  However I noticed around the 10 minute mark the memory consumption doubled from 1.5gb to 3gb in a matter of seconds.  

    So I started the same file over again and took screen caps of the Resource Monitor while it was running every 10%.  What I discovered is that hyperlapse does not create a file in the output folder location until it hits 10 minutes of content which for me was the 60% mark as noted below.  Then I had a 45mb file drop into the output folder, hyperlapse sat at 60% longer than it normally does between % values, and then it gained about 1.5gb of memory in about 10 seconds.  When I have a file over 20 minutes in length it does this twice causing an even larger jump in memory.  If you turn use hardware back on it consumes memory at an even faster rate which exhausts my 8gb system even faster making it never finish.

    Hyperlapse memory spike when saving to drive

    Sunday, August 9, 2015 7:36 PM
  • Thanks everyone for all the detective work.  This looks like a memory leak, and we're investigating further.  I'll post an update when we have more information.
    Sunday, August 9, 2015 10:57 PM
  • Thank you all for responding!

    I have not upgraded to 10 [both my computers refuse to offer the "get 10" and I have tried to add the updates for it with no avail]

    I have been having the same issues as others who chimed in, I am glad they documented what I was seeing myself.

    I have successfully encoded every video I want in "standard" mode, but the results are so much worse than Advanced mode.

    I would really, really like advanced mode to work, after seeing its results, I know its the way to go.

    I do notice standard mode processes WAY faster on my desktop, than Advanced mode. I expect there to be a difference, but I am seeing the same 24 minute video complete standard encoding in well under an hour, and Advanced takes 4-5 hours? is that normal?

    both versions of the encoding I see one common in the encoding speed, begins fast, and slows down as it progresses.

    during Standard I do see memory consumption increase as it progresses, but it stops at 94% whereas advanced would routinley be at 98-99% memory usage.

    I am anxious for the updates concerning the memory leak!

    does anybody have a clue as to what the cost of this software will be when its published for sale? I want to be ready.

    Saturday, August 15, 2015 9:21 PM