none
Reported as spam? Windows 10 Enterprise 1809 - Roaming profile issue RRS feed

  • Question

  • Hello,

    We are experiencing a rather troubling issue with our Windows 10 1809 Enterprise setup. Our school environment consists of 5000+ users.

     

    When a user with a roaming profile logs in, the following files are being created:

    C:\Users\%USERNAME%\AppData\Local\ConnectedDevicesPlatform\L.%USERNAME%\ActivitiesCache.db

    C:\Users\%USERNAME%\AppData\Local\ConnectedDevicesPlatform\L.%USERNAME%\ActivitiesCache.db-shm

    C:\Users\%USERNAME%\AppData\Local\ConnectedDevicesPlatform\L.%USERNAME%\ActivitiesCache.db-wal

     

    We have set a policy which deletes every roaming profile at logoff.

    Computer Configuration/Administrative Templates/System/User Profiles - Delete cached copies of roaming profiles (Enabled)

     

    Now, when a user logs off, the profile folder “C:\Users\%USERNAME%” cannot be deleted. The whole profile is empty, except for the three files above. These files are still locked when you logoff apparently.

     

    When the same user logs on again it creates a new profile folder named “%USERNAME.Domain%” and as that one doesn’t delete as well it creates “%USERNAME.Domain.000%” and then “%USERNAME.Domain.000.001%” etc...

    After a while it will pile up with hundreds of unnecessary folders and certain things won’t work properly because it looks at the %USERNAME% profile folder which isn’t in use at that moment.

     

    What i’ve tried already:

    -          You can delete the folder manually after logoff, so apparently the locking of the files is still ongoing when the policy tries to delete the folder, but unlocks after the user is logged off.

    -          I’ve tried to force unlocking the files which works, i made a PowerShell script  which unlocks these files with Sysinternals Handle.exe and when you logoff the folder is removed properly. Unfortunately i can’t use this, because Handle.exe needs te be run with Admin privileges and as this is a school with thousands of students and employees, this is not an option.

    -          The problem definitely resides within the Windows 10 1809 version, because with Windows 10 1803 the problem does not occur.

    -          The files are part of a feature called Timeline, which is part of the Connected Devices Platform. I’ve tried disabling it via Registry, but with no succes.

    -          In GPO, I’ve set the “Computer Configuration/Administrative Templates/System/OS Policies”

    o   Allow Clipboard History (Disabled)

    o   Allow Clipboard of synchronization across devices (Disabled)

    o   Allow publishing of User Activities (Disabled)

    o   Allow upload of User Activities (Disabled)

    o   Enables Activity Feed (Disabled)

    -          I’ve googled my **** off, but nobody seems to have this problem, which i find pretty baffling to be honest. As it is such an apparent issue.

    Please unspam this, as this is a real question.

    Friday, April 5, 2019 10:00 AM

Answers