locked
Response.redirect not working on IE when it is live but works fine on local. RRS feed

  • Question

  •  Response.Redirect("http://myurl/php/test.php?username=" + LoginHelper.userName + "&password=" + LoginHelper.password);

    Hi All,

    I am trying to redirect the user to different website with username and password. I am using the code above and passing user name and password as parameters.

    This works fine on IE when i run the code on my local machine.

    But when I push the code live this does not work, and user is not able to login.

    It is working fine for other browsers.

    Can someone please help, i am trying to wrap my head around this.

    Any help would be much appreciated. Thanks in advance.

    • Moved by Kristin Xie Wednesday, April 22, 2015 3:03 AM
    Monday, April 20, 2015 9:10 PM

Answers

All replies

  • This is a problem specific to ASP.NET 4.0.  I would either recommend upgrading to .NET 4.5 if possible, otherwise I believe you might have to create a custom browser definition. There is a bug in .Net 4.0 for browser detection.
    Monday, April 20, 2015 11:22 PM
  • I have to upgrade the application or server to 4.5 ?

    Since this works fine when i run it on local host on my machine.

    I am using VS2010.

    Tuesday, April 21, 2015 3:40 PM
  • Please post questions related to ASP.NET in the ASP.NET forums (http://forums.asp.net ).
    • Proposed as answer by Kristin Xie Wednesday, April 22, 2015 3:03 AM
    • Marked as answer by Just Karl Tuesday, April 28, 2015 10:27 PM
    Tuesday, April 21, 2015 5:25 PM