locked
Windows Home Server connector install failing. RRS feed

  • Question

  • I am installing the windows home server on a eeepc 64bit machine. This is the 5th install on my network and I have an identical machine that the connector installed correctly on. the install hangs at the Connecting this computer to the network step. I have left the machine over night and it still does not complete. when I try to connect to the computer from WHS it does not reconise it unless I rerun the install at which time I have backed it up but it hangs again.

    How do I remove the install so that I can reinstall as it does not appear in the uninstall programs list.

    Monday, April 25, 2011 10:09 PM

All replies

  • So here's something I did to get this to work:

    I noticed in my event log on my WHS PC, there were a bunch of errors for 
    Application: wmiprvse.exe
    Framework Version: v4.0.30319
    Description: The application requested process termination through System.Environment.FailFast(string message).
    Message: Unexpected exception thrown from the provider:
    Microsoft.WindowsServerSolutions.MediaStreaming.MediaStreamingProviderNotAvailableException: Connecting to the Media Streaming Provider timed out. ---> System.TimeoutException: Timeout occurred waiting for connection to complete.

    I noticed that this happened EXACTLY during the time that my home server connector install was going on.  I had previously disabled the Windows Media Player Network Sharing Service  Windows Server Media Streaming and Homegroup Service as WHS does an absolutely terrible job of sharing 120+GB of music over DLNA.  I ended up using a service called Asset UPNP instead.  Anyway, I re-enabled these services and the install worked this time.  Maybe this isn't your issue, but this is what I did.

    tl;dr, check your server event log and see if there's anything weird going on during the install time on your client PC and see if there's something there that is error'ing out.

    Sunday, November 11, 2012 12:55 AM