none
Visual Studio 2017 - Codelens not working with Application Insights RRS feed

  • Question

  • I am using VS2017 and set up a free Azure Application Insights account and connected it to my application and all that is working fine and data is being collected, I modified my .NetCore site to throw an exception when so i could try out CodeLens  with Application Insights but it does not seam to be working.

    On the Application Insights Configuration Page in vs2017 under the section 'CodeLens and Diagnostic Tools are reading telemetry from' is says 'You need to be signed in to read telemetry'. But as far as i can tell i could be signed in so i am not sure how to get this working.

    Any help would be great.

    Thanks

    Friday, March 23, 2018 7:16 PM

All replies

  • Hi,

    Welcome to MSDN forum.

    After installing Azure Application Insights in your application, the telemetry appears in Visual Studio CodeLens - the notes at the top of each function where you're used to seeing useful information such as the number of places the function is referenced or the last person who edited it.

    You can add Application Insights for your project, select Project > Add Application Insights Telemetry... (Alternatively you can right-click Connected Services > Add Connected Service.)

    https://docs.microsoft.com/en-us/azure/application-insights/app-insights-asp-net-core

    If you still have problems about it, please provide some screenshots about the problem, you can upload them to https://onedrive.live.com/ and share the link here.

    Best regards,

    Joyce


    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Monday, March 26, 2018 9:51 AM
  • here is a link to screen shots

    Screen Shots

    Monday, March 26, 2018 3:41 PM
  • Hi,

    Thank you for the update.

    I test with a Azure account and everything works well.

    It seems there is some problem with your Azure account, In your browser, check that you have access to the Azure portal. Open Settings and see if there is any restriction. If it still isn't working, follow the manual procedure to add a resource in the portal and then add the SDK to your project.

    https://docs.microsoft.com/en-us/azure/application-insights/app-insights-asp-net-troubleshoot-no-data#q02

    Best regards,

    Joyce


    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Wednesday, March 28, 2018 2:21 AM
  • ya, that did not help.

    and i assume you mean portal settings... they only thing i see there is location, and color, etc...

    I still cannot get CodeLens to work, but data does still get sent to azure. (i have tried this on a 4.x app and a netcore app)

    do you know of any other resources I could use to help me with this issue.

    Thursday, March 29, 2018 4:09 PM
  • Hi,

    Thank you for the update.

    check this:

    https://docs.microsoft.com/en-us/azure/application-insights/app-insights-visual-studio-codelens

    If the issue persists, it is recommend to open a new thread in Microsoft Azure forum to discuss the problem. In there, you can get more professional support about Azure. Thank you for understanding.

    Best regards,

    Joyce


    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Friday, March 30, 2018 10:00 AM
  • Hi skihard_12345,

    I suggest you post this issue to the Application Insights forum:

    https://social.msdn.microsoft.com/Forums/vstudio/en-US/home?forum=ApplicationInsights

    Best Regards,

    Jack


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Wednesday, April 4, 2018 6:14 AM