none
cannot run Connect-AzureRmAccount RRS feed

  • Question

  • Hi,

    Beginner in powershell and azure.  I used to be able to run Connect-AzureRmAccount. in the last couple of days I realized that there is a new module (AZ).  I installed it and thought that was why Connect-AzureRmAccount does not work.  So I ran "Get-InstalledModule -Name Az -AllVersions" and then I ran "Install-Module -Name AzureRM -AllowClobber -Force", thought being, i dont want the AZ thing, just want the old thing.  Now when I run Connect-AzureRmAccount, i get the below error.

    Connect-AzureRmAccount : Method 'get_SerializationSettings' in type
    'Microsoft.Azure.Management.Internal.Resources.ResourceManagementClient' from assembly
    'Microsoft.Azure.Commands.ResourceManager.Common, Version=4.0.0.0, Culture=neutral, PublicKeyToken='
    does not have an implementation.
    At line:1 char:1
    + Connect-AzureRmAccount
    + ~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : NotSpecified: (:) [Connect-AzureRmAccount], TypeLoadException
        + FullyQualifiedErrorId : System.TypeLoadException,Microsoft.Azure.Commands.Profile.ConnectAzureRmAccountCommand

    BTW, my eventual goal is to run script to prepare existing vnett for managed instance

    https://docs.microsoft.com/en-us/azure/sql-database/sql-database-managed-instance-configure-vnet-subnet

    cheers

    • Moved by litdev Sunday, February 17, 2019 1:00 AM
    Saturday, February 16, 2019 11:03 PM

Answers

All replies