locked
First Record is not getting Synced to the Server RRS feed

  • Question

  • Hi All,

    I am using Sync Framework to transfer records from a mobile device (SQL CE) to Sql Server 2005.

    Scenario:
    I have to Sync records from 4 tables from my device to the server whenever the user completes the transaction. This is done using a Thread in the background.

    Problem:
    The Problem we have is that whenever we create a new database in the mobile and sync the records, the first record in all the four tables is not getting synced. 
    I looked into the database also and it shows __SysChangeTxBsn and __SysInsertTxBsn as null for the first record.

    after the first record all the other records are getting synced and the insertTxBSN and changeTxBsn are changing.

    Can anyone help in this or let me know how to recitfy this id.

    Thanks in advance.

    Regards
    Biju
    • Moved by Hengzhe Li Friday, April 22, 2011 3:32 AM (From:SyncFx - Microsoft Sync Framework Database Providers [ReadOnly])
    Thursday, April 2, 2009 12:36 PM

Answers

  • is the "first record' not being sync-ed to the SqlServer or to the SQLCe Client ?

    somemore info would be usefule, would you hook you to the events (on server provider and clientprovider, hook to the changesSelected, ApplyingChanges ) to see if the record got selected and applied ?

    thanks
    Yunwen


    This posting is provided "AS IS" with no warranties, and confers no rights.
    Thursday, April 2, 2009 7:51 PM
    Moderator

All replies

  • is the "first record' not being sync-ed to the SqlServer or to the SQLCe Client ?

    somemore info would be usefule, would you hook you to the events (on server provider and clientprovider, hook to the changesSelected, ApplyingChanges ) to see if the record got selected and applied ?

    thanks
    Yunwen


    This posting is provided "AS IS" with no warranties, and confers no rights.
    Thursday, April 2, 2009 7:51 PM
    Moderator
  • Hi Yunwen,

    Thanks for the reply.
    The First Record from the device to the SQL Server is not happening.

    after the first record all other records are getting synced into the server. The First record is not at all synced.
    as you have mentioned i will try to hook the changes selected event in the device and let you know.

    Regards
    Biju
    Friday, April 3, 2009 5:14 AM