locked
Facebook inline Translation RRS feed

  • Question

  • I previously had the inline translator in Facebook but it is no longer showing on my page.

    I have tried to find out why the translate link has gone but cant find the answer.

    I set up another facebook account to check if it was my laptop but it works so it must be to do with my facebook settings.

    I have not changed anything and cannot see where to check on the inline translations.

    Any help please

    Monday, December 10, 2012 10:30 AM

All replies

  • What browser are you using? The appearance of the translate link depends on whether Facebook accurately detect that you have a different language from the post. We have no control over this algorithm.

    Perhaps trying a different browser might help?

    Tuesday, December 11, 2012 2:51 PM
  • Thanks for the suggestion.

    I have tried opening my facebook account using different browsers, chrome and internet explorer. Also on different laptops.

    Strange because it must be to do with the settings on my actual facebook account but there is nowhere on a personal page where you can change translation settings. The new test facebook account I set up shows all the translations so it must be something to do with the settings on my acutal page. I havent made any changes and the only possible thing - well two are

    when i select the text and right click - select translate with Bing it comes up with different languages? not in but I tried resetting preferences but they did not stay

    also i do have facebook mobile on my blackberry - could this have had an affect on my account settings??

    Really confused - other people are saying online that their translation link has gone (facebook/facebook page) but no answer has been given to resolve the problem.

    Any help most appreciated - really getting frustrated with not being able to solve this problem - I also forgot to say I am in the UAE but the problem only occured a few weeks ago and has previously worked here.

    Tuesday, December 11, 2012 3:29 PM
  • Just compared the two facebook pages and in the account with the problem. Why do I have the option to translate using bing by right clicking the arabic text? Pop up window comes up or you can go to the bing website (which is all in arabic) In the new account it just shows the translate link?

    I tried to upload a screenshot showing this but couldnt.

    Tuesday, December 11, 2012 3:58 PM
  • Hi Abudhabi2012,

    the right-click translate option is a feature of Internet Explorer. It will be there regardless of your Facebook profile.

    Facebook's "See Translation" link appears if the particular post is in a different language than the language you have listed in your Facebook profile, or Facebook has otherwise determined that you understand that language. Only your profile matters, not the poster's profile.

    Let us know if this helps,
    Chris Wendt
    Microsoft Translator

    Sunday, December 23, 2012 10:20 PM
  • In your Facebook profile, have you specified that you understand the target language? For example, if you specify that you speak Japanese in your personal profile, Facebook will not give you the translate link for Japanese posts, regardless of your browser language.
    Monday, December 24, 2012 8:23 AM
  • Hi Chris

    I didnt make any changes to my profile so am not sure why I lost the translation link.

    I have checked my profile and language set to English but I cant see where else language preferences may be changed.

    The only thing that refers to the language (Arabic) which I want to translate (as many of my friends Arabic) is in current location.

    Really confused as it was there and is working in the other FB account I set up.

    Any ideas of how or where I check whether I have somehow said I know Arabic would be really helpful.

    Many Thanks

    Saturday, December 29, 2012 2:34 PM
  • Hi Laurence

    Thanks for the suggestion.

    I havent specified in my profile Arabic language. The only mention is in my current location....

    Any other suggestion most welcome...

    Saturday, December 29, 2012 2:36 PM
  • Try this:

    On Facebook, click your name on the top right to see your profile.

    Click the 'About' link.

    This should lead you to a page that looks like

    facebook.com/<your name>/info

    So, for example, mine is:

    http://www.facebook.com/laurence.moroney/info

    Find the 'Basic Info' section, and click 'Edit'.

    If 'Arabic' is listed as a language that you understand -- remove it.

    When you tell facebook that you understand Arabic, it doesn't give you the option to translate from Arabic, because you have told them you already understand it.

    If that fails, I am not sure what else to try, and I'd recommend you contact Facebook support.

    Thursday, January 3, 2013 10:37 AM