locked
HD light flashing briefly once per second non-stop RRS feed

  • Question

  • Hey all,

    I'm pretty excited about getting WHS up and running.  I bought a custom-built PC to spec for it, and was ready to try it out.  Unfortunately, I found that my version of WHS started to grind more and more on the drives the more I loaded the system down with files.  It got to a point the drive was continuously grinding, regardless of any access remotely.  I thought it just might be indexing the drives, so I left it alone for quite a while (several days), but it didn't seem to slow down.

    I transferred my data off (the performance was pretty bad by now), and thought I'd try a clean install to see if that would fix the issue.  So, I formatted the drives and re-installed from scratch.  Now, with no files on the hard drive and a 100% clean install (including all patches), I'm still seeing a problem with the drive access.  The HDD light flickers on once per second briefly, non-stop (I left it alone for a few days again).

    There's nothing really fancy about the system.  It's an Intel-based system and motherboard, with two 2-terrabyte drives, and 2GB of RAM.  Plenty of horsepower for this, from what I've read.  I'm worried that this behavior will shorten the drive lifetime at worst, or cause performance issues at best.

    I'm fairly technically adept (I'm a computer programmer, actually), but I'm not terribly familiar with server adminstration.  I peeked into the machine using remote desktop once it was running, and checked out the performance logs, but wasn't quite sure what to look for.

    I'm wondering if anyone knows what's going on, or has any clues as to the best approach for diagnosing this?  I'd be happy to provide any specifics about the hardware or any pertinant logs, if that would help.  Thanks much! 
    Wednesday, July 8, 2009 3:08 AM

Answers

  • Ok, I guess I'll post what I found out just for posterity's sake, so hopefully someone else can find the answer quicker than I did.

    For the record, it appears it's not normal for WHS to hit the hard drive once per second for eternity.  Eventually I hit upon the answer when I started searching for this specific issue rather than searching for WHS-specific problems.  I saw a suggestion that it may be related to the CD-ROM's autoplay.  That immediately made a lot of sense to me, so I tried it out.

    Huzzah!  No more flashing hard drive light.  When I don't access the machine, it's now blessedly silent as it should be. 

    This appears to be a Windows / hardware configuration issue more than a WHS-specific issue, but if anyone else is experiencing this problem, here's how to disable autoplay:

    1) Remote login, then run RegEdit.

    2) Navigate to:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Service\Cdrom

    3) Right-click on AutoRun, and select Modify.

    4) Change the value to 0

    5) Reboot
    • Marked as answer by Dutch Gun Thursday, July 9, 2009 6:14 AM
    Thursday, July 9, 2009 6:13 AM

All replies

  • I doubt that the disk access you're seeing is anything unusual. Many computers have processes running that perform some small bit of i/o on a regular (and frequent) schedule, and I'm pretty sure my test/dev server does the same thing you describe (though I'm rather far from it ATM, and so I can't check).
    I'm not on the WHS team, I just post a lot. :)
    Wednesday, July 8, 2009 3:26 PM
    Moderator
  • Thanks for the reply Ken.  I'd love to hear if anyone else's machine exhibits this behavior.  Keep in mind I've been seeing this non-stop for many days now.  Honestly, I can't think of why a machine that's not even connected to the network would have to read or write that often to the hard drive, especially one with no data to maintain. 





    • Marked as answer by Dutch Gun Thursday, July 9, 2009 5:10 AM
    • Unmarked as answer by Dutch Gun Thursday, July 9, 2009 5:10 AM
    Wednesday, July 8, 2009 4:57 PM
  • Thanks for the reply Ken.  I'd love to hear if anyone else's machine exhibits this behavior.  Keep in mind I've been seeing this non-stop for many days now.  Honestly, I can't think of why a machine that's not even connected to the network would have to read or write that often to the hard drive, especially one with no data to maintain. 






    My DIY server does this as well.  It's blinking on and off so quick, it's barely noticeable.  (Heck, I never noticed it until reading this post.  :)  )
    • Marked as answer by Dutch Gun Thursday, July 9, 2009 5:10 AM
    • Unmarked as answer by Dutch Gun Thursday, July 9, 2009 6:02 AM
    Thursday, July 9, 2009 2:30 AM
    Moderator
  • Thanks for the reply Ken.  I'd love to hear if anyone else's machine exhibits this behavior.  Keep in mind I've been seeing this non-stop for many days now.  Honestly, I can't think of why a machine that's not even connected to the network would have to read or write that often to the hard drive, especially one with no data to maintain. 






    My DIY server does this as well.  It's blinking on and off so quick, it's barely noticeable.  (Heck, I never noticed it until reading this post.  :)  )
    Ok, thank you... That's good to know.  I'll try re-installing some of the data to see if the slowdowns I noticed the first time happen again. 
    Thursday, July 9, 2009 5:10 AM
  • Ok, I guess I'll post what I found out just for posterity's sake, so hopefully someone else can find the answer quicker than I did.

    For the record, it appears it's not normal for WHS to hit the hard drive once per second for eternity.  Eventually I hit upon the answer when I started searching for this specific issue rather than searching for WHS-specific problems.  I saw a suggestion that it may be related to the CD-ROM's autoplay.  That immediately made a lot of sense to me, so I tried it out.

    Huzzah!  No more flashing hard drive light.  When I don't access the machine, it's now blessedly silent as it should be. 

    This appears to be a Windows / hardware configuration issue more than a WHS-specific issue, but if anyone else is experiencing this problem, here's how to disable autoplay:

    1) Remote login, then run RegEdit.

    2) Navigate to:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Service\Cdrom

    3) Right-click on AutoRun, and select Modify.

    4) Change the value to 0

    5) Reboot
    • Marked as answer by Dutch Gun Thursday, July 9, 2009 6:14 AM
    Thursday, July 9, 2009 6:13 AM
  • Ok, I guess I'll post what I found out just for posterity's sake, so hopefully someone else can find the answer quicker than I did.




    I'm certainly glad you did! Not only does it fix it on WHS but it stopped it on 2 different Vista computers that have been flashing at me like friggin' lighthouses for the last year.
    Friday, July 10, 2009 12:51 AM