locked
Sick to death of disabling firewall to see local network RRS feed

  • General discussion

  •  

    I am sick to the point of uninstalling the product, I certainly won't buy another license until it is fixed.

     

    I tell OneCare that my PC is part of a local network and that I want resources to be shared.

    Sometimes this works, mostly it doesn't.

    I have to disable the firewall and then re-establish my shares etc.

    Then usually when the firewall is re-enabled sharing works for a while, until the next power cut or i have to reset my router or there's a full moon  (You get the picture).

     

    This problem is much the same on version 1.0 and 2.0.

     

    I thought perhaps that OneCare could be a decent alternative to Norton and McAfee both of which i've tried and thrown away, both fell over repeatedly and slowed my machine awfully.

     

    Come on guys sort it out, at the moment the best ant-virus programs appear to be the free ones, surely the "mighty" Microsoft can do better.

     

    Friday, January 4, 2008 10:59 AM

All replies

  • Andrew, I don't blame you for being frustrated. Can you describe your network? Wired, wireless, mixed, XP, Vista machines?

    Are your Shares on other machines or are we also talking an NAS?

    In 1.x, the configuring of File and Printer Sharing was pretty flakey and the best solution tended to be to use the Advanced Firewall setting to allow File and Printer Sharing with All - subnet & Internet and it always worked. This was, of course, an issue if your PC also connected to unsecure networks.

    In 2.x, if your network is configured as Home or Work in OneCare, change settings, Firewall tab, configure network, you generally should not have a problem. However, if the PC running OneCare has multiple network adapters active - say a Virtual Adapter for a VM, your network connections will revert to Public and go into locked down mode. To get around this you would once again need to enable File and Printer Sharing for *all* including the Internet on the advanced part of the firewall tab.

    Have you ever contacted support on this issue?

     

    How to reach support - http://forums.microsoft.com/WindowsOneCare/ShowPost.aspx?PostID=2421771&SiteID=2

    If it fails to validate your subscription, select the option that you are using a trial or beta copy and you can proceed to email support without validation once you've signed in.

    -steve

    Saturday, January 5, 2008 2:50 AM
    Moderator
  • Hi Steve,

     

    My network at home which has V1 is a wireless network.

    My network at work which has V2 is wired.

     

    At the moment I have the firewall disabled as this is the only reliable solution.

    I am using routers with built-in firewalls anyway but these are really only providing inbound protection.

     

    The problem seems mainly to occur if there is say a power cut and IP addresses are reallocated by the router but seems to occur after a time anyway.

    The firewall does not revert to "public" is stays on "Home or Work".

    Usually disabling the firewall for an hour an re-establishing the shares fixes things but this is pain in the neck.

    It is also causes problems if I am not there to do it and someone else needs something from my machine.

     

    The problem affects file shares, printers and access to email servers, ie everything.

     

    Andrew Keatley

     

    Tuesday, January 8, 2008 10:37 AM
  • Andrew, thanks for the details.

    My recommendation, then, particularly since you are using routers with built in firewalls, is to go to the Advanced settings for the firewall and enable File and Printer Sharing for Internet or all computers. The hardware firewall will protect you from outside intrusion. And, if you connect to a public network with a roaming PC, it should revert to Public mode and lock down all sharing.

    -steve

     

    Tuesday, January 8, 2008 5:51 PM
    Moderator