locked
Backup crashes when I connect client RRS feed

  • Question

  • Client is XP Home SP3.  Installing connector software fails during the "configuring backup" stage.  The server posts this error in the event log:

    Event Type: Error
    Event Source: Application Error
    Event Category: (100)
    Event ID: 1000
    Date:  7/6/2009
    Time:  10:43:07 AM
    User:  N/A
    Computer: SERVER
    Description:
    Faulting application whsbackup.exe, version 6.0.2030.0, faulting module whsbackup.exe, version 6.0.2030.0, fault address 0x0006213a.

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
    Data:
    0000: 41 70 70 6c 69 63 61 74   Applicat
    0008: 69 6f 6e 20 46 61 69 6c   ion Fail
    0010: 75 72 65 20 20 77 68 73   ure  whs
    0018: 62 61 63 6b 75 70 2e 65   backup.e
    0020: 78 65 20 36 2e 30 2e 32   xe 6.0.2
    0028: 30 33 30 2e 30 20 69 6e   030.0 in
    0030: 20 77 68 73 62 61 63 6b    whsback
    0038: 75 70 2e 65 78 65 20 36   up.exe 6
    0040: 2e 30 2e 32 30 33 30 2e   .0.2030.
    0048: 30 20 61 74 20 6f 66 66   0 at off
    0050: 73 65 74 20 30 30 30 36   set 0006
    0058: 32 31 33 61               213a   

    I've successfully installed the software on a Windows 7 RC PC.

    Any advice or help?

    Thanks,
    dpm

    Sunday, July 5, 2009 3:05 PM

All replies

  • Client is XP Home SP3.  Installing connector software fails during the "configuring backup" stage.  The server posts this error in the event log:

    Event Type: Error
    Event Source: Application Error
    Event Category: (100)
    Event ID: 1000
    Date:  7/6/2009
    Time:  10:43:07 AM
    User:  N/A
    Computer: SERVER
    Description:
    Faulting application whsbackup.exe, version 6.0.2030.0, faulting module whsbackup.exe, version 6.0.2030.0, fault address 0x0006213a.

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
    Data:
    0000: 41 70 70 6c 69 63 61 74   Applicat
    0008: 69 6f 6e 20 46 61 69 6c   ion Fail
    0010: 75 72 65 20 20 77 68 73   ure  whs
    0018: 62 61 63 6b 75 70 2e 65   backup.e
    0020: 78 65 20 36 2e 30 2e 32   xe 6.0.2
    0028: 30 33 30 2e 30 20 69 6e   030.0 in
    0030: 20 77 68 73 62 61 63 6b    whsback
    0038: 75 70 2e 65 78 65 20 36   up.exe 6
    0040: 2e 30 2e 32 30 33 30 2e   .0.2030.
    0048: 30 20 61 74 20 6f 66 66   0 at off
    0050: 73 65 74 20 30 30 30 36   set 0006
    0058: 32 31 33 61               213a   

    I've successfully installed the software on a Windows 7 RC PC.

    Any advice or help?

    Thanks,
    dpm


    Please run chkdsk /r on the client PC.

    Thank you
    Lara Jones [MSFT] | Program Manager
    Community Support and Beta | Windows Home Server Team
    Windows Home Server Team Blog
    Connect Windows Home Server
    Windows Home Server
    Sunday, July 5, 2009 4:35 PM
    Moderator
  • Lara,

    I've done as you asked - same result.

    Pardon my ignorance, but it's the server that appears to fail, not the client.

    Any other suggestions?  I thought XP Home was a supported OS.

    Thanks,
    Dean
    Wednesday, July 8, 2009 3:09 AM
  • Lara,

    I've done as you asked - same result.

    Pardon my ignorance, but it's the server that appears to fail, not the client.

    Any other suggestions?  I thought XP Home was a supported OS.

    Thanks,
    Dean

    If it was the server that's failing, you would have the issue on all PCs.  Are you able to ping your server from that client, both by name and by IP address?  Have you tried completely disabling the firewall on your client?
    Thursday, July 9, 2009 2:20 AM
    Moderator
  • "Are you able to ping your server from that client, both by name and by IP address?  Have you tried completely disabling the firewall on your client?"

    Contacting the server is not a problem.  The installation proceeds, apparently without difficulty, until the installer gets to the "configuring backup" stage.  Then the installation stalls for several minutes, until the installer reports it's lost contact with the server.  Viewing the server's console shows the client in the computer list, but the Network tab reports the backup service stopped, and the server's event log shows multiple intstances of the error in my first post.

    "If it was the server that's failing, you would have the issue on all PCs."

    Please note that the client does not crash or hang.  The error in my original post is in the server's event log, not the client's.

    To clarify, the client is listed in the "computer & backups" screen, but whenever the server attempts to contact that client the module whsbackup.exe crashes.  I cannot get whsbackup.exe to run unless I delete the client from the computers list on the server and reboot it.  If I uninstall the Connector software the client can contact the server, and I can access shared folders with the client.  The problem is the backup function, and it appears to be something specific with this particular client.

    Is there any known desktop software that can cause whsbackup.exe to crash or hang when it attempts to assess a client's backup status?

    Thanks,
    Dean





    Friday, July 10, 2009 2:18 AM