locked
Weird CWA Problem RRS feed

  • Question

  • Hi All,

     

    Few weeks after deploy CWA Server, a problem occurs and i don't have any idea what's happenning...

     

    When a user try to sent messages to another user, the history field inside the CWA was empty. the other user is a Communicator client user, and the message are received without problem.

     

    When a user receive a message from another user, an script error occurs and  the user didn't receive the message.

     

     Script Error:

     

    An error has occurred in the script on this page

     

    Line: 3

    Char: 849924

    Error: 'this.optionManager.GetOptionData().messages' is null or not an object

    Code: 0

    URL: http://(CWAServer)/cwa/Client/3.0.6362.0000/Toast.htm?type=im

     

    Even if i chose continue running scripts on this page, the IM isn't appear for CWA users.

     

     

    Checking the eventvwr, i've this errors:

     

    Event Type: Warning
    Event Source: Perflib
    Event Category: None
    Event ID: 2003
    Date:  6/12/2008
    Time:  4:13:26 PM
    User:  N/A
    Computer: (CWA Server)
    Description:
    The configuration information of the performance library "C:\WINDOWS\system32\aspperf.dll" for the "ASP" service does not match the trusted performance library information stored in the registry. The functions in this library will not be treated as trusted.

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.


    Event Type: Error
    Event Source: Perflib
    Event Category: None
    Event ID: 1008
    Date:  6/12/2008
    Time:  4:13:26 PM
    User:  N/A
    Computer: (CWA Server)
    Description:
    The Open Procedure for service "CWAPerf" in DLL "C:\PROGRA~1\MICROS~1\COMMUN~1\shared\cwaperf.dll" failed. Performance data for this service will not be available. The Status code returned is the first DWORD in the attached data.

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
    Data:
    0000: 05 00 00 00               ....   

     

    Event Type: Warning
    Event Source: Perflib
    Event Category: None
    Event ID: 2003
    Date:  6/12/2008
    Time:  4:13:26 PM
    User:  N/A
    Computer: (CWA Server)
    Description:
    The configuration information of the performance library "C:\WINDOWS\system32\perfts.dll" for the "TermService" service does not match the trusted performance library information stored in the registry. The functions in this library will not be treated as trusted.

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

     

    Event Type: Warning
    Event Source: Perflib
    Event Category: None
    Event ID: 2003
    Date:  6/12/2008
    Time:  4:13:26 PM
    User:  N/A
    Computer: (CWA Server)
    Description:
    The configuration information of the performance library "C:\WINDOWS\system32\inetsrv\w3ctrs.dll" for the "W3SVC" service does not match the trusted performance library information stored in the registry. The functions in this library will not be treated as trusted.

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

     

     

     

    I'd tried to use only 80 port (without certificate), disabled popup blocker, run windows update and put the CWA website as trusted and local intranet zone in IE.

     

    Configuring the CWA as Internal or External, i`d the same problem...

     

     

    Only application logs have errors. System and OCS logs are clean, only with Infos...

     

    I'd tried logging tool too, but without any error...

     

     

    We tested in Windows XP, Vista and 2003 as CWA clients.

     

     

    Regards,

     

     

    Friday, June 13, 2008 12:38 PM

Answers