locked
Installations failed: Can't start MSCRMAsyncService RRS feed

  • Question

  • I am trying to install CRM on a 2003 Server with SQL2008 on the same machine.

    Following the article "How to install CRM with the minimum required permissions" (http://support.microsoft.com/kb/946677) I set up security groups and added installing users and machine to these groups and used a configuration file for installation.

    My configuration file:

    <?xml version="1.0" encoding="windows-1252"?>
    <CRMSetup>
    	<Server>
    		<Patch update="true">C:\MicrosoftCRMInstallation\server_i386.msp</Patch>
    		<SqlServer>COMPUTER1</SqlServer>
    		<Database create="true" update="false"/>
    		<Organization>My Company</Organization>
    		<OrganizationUniqueName>COMPANY</OrganizationUniqueName>
    		<InstallDir>C:\Programme\Microsoft CRM</InstallDir>
    		<basecurrency isocurrencycode="EUR" currencyname="Euro" currencysymbol="€"/>
    		<OrganizationCollation>Latin1_General_CI_AI</OrganizationCollation>	
    		<SQM optin="false"/>
    		<Reporting UseSSL="false" URL="http://COMPUTER1/ReportServer"/>		
    		<Groups autogroupmanagementoff="true">
    			<PrivUserGroup>CN=PrivUserGroup,OU=HM0,OU=Rollen,OU=Gruppen,OU=Dienste,DC=HOLDING,DC=DE</PrivUserGroup>  
    			<SQLAccessGroup>CN=SQLAccessGroup,OU=HM0,OU=Rollen,OU=Gruppen,OU=Dienste,DC=HOLDING,DC=DE</SQLAccessGroup>  
    			<UserGroup>CN=UserGroup,OU=HM0,OU=Rollen,OU=Gruppen,OU=Dienste,DC=HOLDING,DC=DE</UserGroup>  
    			<ReportingGroup>CN=ReportingGroup,OU=HM0,OU=Rollen,OU=Gruppen,OU=Dienste,DC=HOLDING,DC=DE</ReportingGroup>  
    			<PrivReportingGroup>CN=PrivReportingGroup,OU=HM0,OU=Rollen,OU=Gruppen,OU=Dienste,DC=HOLDING,DC=DE</PrivReportingGroup>
    		</Groups>
    	</Server>
    </CRMSetup>
    





    My installation ends with an error message:

    Microsoft.Crm.Setup.Common.RegisterAsyncServiceAction.
    An exception occurred during the Commit phase of the installation. This exception will be ignored and installation will continue. However, the application might not function correctly after installation is complete.
    Time out has expired and the operation has not been completed.

    I can't continue installation, only "Abort" and "Retry".

    Log:

    09:38:19|  Error| System.Exception: Fehler bei der Aktion Microsoft.Crm.Setup.Common.RegisterAsyncServiceAction. ---> System.Configuration.Install.InstallException: An exception occurred during the Commit phase of the installation. This exception will be ignored and installation will continue. However, the application might not function correctly after installation is complete. ---> System.ServiceProcess.TimeoutException: Time out has expired and the operation has not been completed.
       at System.ServiceProcess.ServiceController.WaitForStatus(ServiceControllerStatus desiredStatus, TimeSpan timeout)
       at Microsoft.Crm.ExtendedServiceInstaller.StartService(Object sender, InstallEventArgs e)
       at System.Configuration.Install.InstallEventHandler.Invoke(Object sender, InstallEventArgs e)
       at System.Configuration.Install.Installer.OnCommitted(IDictionary savedState)
       at System.Configuration.Install.Installer.Commit(IDictionary savedState)
       --- End of inner exception stack trace ---
       at System.Configuration.Install.Installer.Commit(IDictionary savedState)
       at System.Configuration.Install.AssemblyInstaller.Commit(IDictionary savedState)
       at Microsoft.Crm.Setup.Common.RegisterAsyncServiceAction.Do(IDictionary parameters)
       at Microsoft.Crm.Setup.Common.Action.ExecuteAction(Action action, IDictionary parameters, Boolean undo)
       --- End of inner exception stack trace ---, Error, RetryCancel, Option1



    I checked MSCRMAsyncService in service. It is not running and I can't start it manually.

    Eventlog:

    The description for Event ID ( 17410 ) in Source ( MSCRMAsyncService )
    cannot be found. The local computer may not have the necessary registry
    information or message DLL files to display messages from a remote computer.
    You may be able to use the /AUXSOURCE= flag to retrieve this description; see
    Help and Support for details. The following information is part of the event: 
    COMPUTER1; Microsoft.Crm.CrmConfigObjectNotFoundException: Server ID Was Not Found at Microsoft.Crm.ServerLocatorService.GetServerIdFromDatabase() at Microsoft.Crm.ServerLocatorService.GetServerId() at Microsoft.Crm.ServerLocatorService.GetServerRoles() at Microsoft.Crm.LocatorService.GetServerRoles() at Microsoft.Crm.Asynchronous.ServerConfiguration.InitializeOrganizationList() at Microsoft.Crm.Asynchronous.ServerConfiguration..ctor(ILocatorService locatorService) at Microsoft.Crm.Asynchronous.ConfigurationFactory.Create(CrmServiceFactory crmServiceFactory, AsyncServiceContext context) at Microsoft.Crm.Asynchronous.AsyncService.InitializeComponents() at Microsoft.Crm.Asynchronous.AsyncService.OnStart(String[] args).

    I don't understand why "Server ID Was Not Found".

    Reboot doesn't help.

    I don't know where MSCRMAsyncService is trying to get Server ID from.
    However, I checked table MSCRM_CONFIG.dbo.Server. It is empty.

    When I start Deployment Manager I get NO server listed under server-nodes.

    Any ideas?


    Thanks

    Friday, June 5, 2009 9:04 AM

Answers

  • solved it:
    I had to change
    <Database create="true" update="false"/>
    to
    <Database create="true" update="true"/>
    Friday, June 5, 2009 2:56 PM