locked
Synctoy 1.4 and 2.0 fail to open -- mscorwks.dll error RRS feed

  • Question

  • I used to have synctoy working beautifully but one of the .net upgrades or service packs has evidently torpedoed something.  I cannot get any version of Synctoy to run.

     

    When I open Synctoy 1.4 right after installing it, I get a message saying it generated an error and has to close.  The details of the error are:

      AppName: synctoy.exe

      AppVer: 1.4.0.0

      AppStamp: 453f990b

      ModName: mscorwks.dll

      ModVer: 2.0.50727.1433

      ModStamp: 471ef729

      fDebug: 0

      Offset: 000dff9d

     

    I can paste the contents of the error report if needed.

     

    I've removed and reinstalled every .net framework I have.  My currently installed versions are (listed in Add/Remove Programs):

    1.1 with KB928366 Hotfix

    2.0 Service Pack 1 with Frameworks 1, CLR, PreXP, CRT, ASP .NET, 2, CA, WinForms, and Dr. Watson

    3.0 with Hotfix KB932471

    3.0 Service Pack 1 with Frameworks WPF 3, WCS, WPF 2, WPF 3 x86, XPS, WF, WCF, WF x86, WPF x86, 1

     

    Windows Update does not tell me that any more fixes or service packs are available.

     

    Can anyone give me help as to how I might get SyncToy working again?  I'm just a lowly end user that depended on it to keep files in sync between two PCs.

     

    I tried installing the 2.0 beta and get the almost the exact same error (AppVer says 2.0.0.0 and AppStamp is different).

     

    -pretzelbag.

    Wednesday, February 27, 2008 7:29 PM

All replies

  • Well, I guess I'm the only one with such a problem since there's been a whopping zero replies.

    In case anyone is still reading this, I tried installing Robocopy GUI version 3.1.2 (came in the "UtilitySpotlight2006_11.exe" file that accompanied the MSDN Utility Spotlight of Nov 2006).

    Sadly, Robocopy also fails, although it gives no error code like Synctoy.

    This must be a .net Framework 2.0 problem, since it's the only common component, yes?

    I am open to anyone's suggestions...

    -pretzelbag.
    Saturday, March 8, 2008 2:03 AM
  • happened to me also. had 2.0 working great and then nothing. "fail to open"  removed and reinstalled same thing. I guess thats why it's beta

    Wednesday, April 16, 2008 7:46 PM
  • Beta or not, I used to be able to get version 1.4 to work, and now none of the versions of SyncToy work for me.  As I mentioned, even Robocopy fails.  I'd guess it's a .net Framework issue, but can't say for sure how SyncToy works with .net's various versions.
    Monday, May 5, 2008 7:40 PM