locked
Project Server 2010 Master Page question RRS feed

  • Question

  • I've already gone through and modified the Project Server 2010 master page (made a copy and used that one v4updated.master)

    Everything works fine, the pages load, everything displays; my issue is with other sub-pages in PWA

    The following pages do not display the modified master page:  Driver Library/Driver Prioritization/Portfolio Analyses/Personal Settings/Server Settings/Manage Timesheets

    The above referenced pages still utilize v4.master 

    Is there a setting which will ensure all pages sub to /PWA will have the new master page applied?  

    Or should I modify the v4.master and see if that fixes the issue?

    Wednesday, March 18, 2015 12:52 PM

Answers

  • I figured out how to get the final pages converted over...a lot of digging but pretty awesome :D

    After the initial configuration of changing the v4.master (or a copy of it) and applying it to the template you have to modify the actual applicationv4.master file found in the following directory

    c:\program files\common files\Microsoft Shared\Web Server Extensions\14\TEMPLATE\LAYOUTS

    you can edit it in notepad or SPD (SPD gives me a couple of errors and shows a blank page)

    In my case I made the exact same modifications to the applicationv4.master as I did to the v4updated.master file, this was discovered by going to the following directory c:\program files\common files\Microsoft Shared\Web Server Extensions\14\TEMPLATE\LAYOUTS\PWA and when you view the "PWA.master" file it states on line 4 "Inherits ....PJMasterPage" MasterPageFile="....applicationv4.master"

    Anyway - went up a directory made modifications and refreshed the web page... BOOM done.. 

    Steps to Modify/BRAND all PWA 2010 sites

    1) Modify the C:\program files\common files\Microsoft Shared\Web Server Extensions\14\TEMPLATE\SiteTemplates\PWA\XML\ONET.xml file

    Search for and remove DisableWebDesignFeatures="wdfopensite"

    Save and exit from  the file

    2) IISRESET from administrative command prompt
    3) Under PWA (http://server/pwa) => Site Actions => Site Settings 
    Manage Site Features (under Site Actions) => Activate SharePoint Server PublishingThis allows Master Page to show up under look and feel

    4) Under PWA (http://server/pwa) => Site Actions => Edit in SharePoint Designer
    5) Select the Master Pages icon on the Left 
    6) Drag and Drop v4.master in the window so it creates v4_copy(1).master => rename to what you like newv4_master.master for example
    7) edit the newv4_master.master file by checking it out 
    8) edit the file - check it back in (publish a major version)
    9) You'll need to approve the file -> you can do it either via SPD or under Master Page Gallery (site actions-> site settings -> Master Page and Page Layouts -> select the drop-down next to newv4_master.master -> select approve/reject 

    10) change the master file/branding -> Site Actions -> Site Settings -> Master Page (under look and feel) 
    11) Change the Site Master Page  and System Master Page to newv4_master.master select the checkbox for "reset all subsites.." => select OK

    12) You'll get an error see here how to fix (
    http://www.projectserver2010blog.com/2010/01/project-server-2010-changing-master.html) - the modifications are done in the appropriate sections on the web.config file under the inetpub directory for the appropriate port (80 for most people)

    13) make the above modifications -> IISRESET 

    14) Go to the directions above and modify the applicationv4.master file -> save and exit the file

    all your Project Server Pages will now have the branding/modifications you wanted


    • Marked as answer by kbwrecker Wednesday, March 18, 2015 3:30 PM
    Wednesday, March 18, 2015 3:30 PM

All replies

  • Hi,

    I do believe that MS doesn't support changing the master page, so you should be careful playing with it.

    That being said, I remember from an old 2010 implementation that deploying a global "look and feel" solution as a feature can bypass the limitations you mention. I'm not technical enough to tell you more, but this can be a good start for further investigations, and maybe other experts will jump in to give you more solutions.


    Hope this helps,


    Guillaume Rouyre, MBA, MVP, P-Seller |

    Wednesday, March 18, 2015 2:43 PM
  • I figured out how to get the final pages converted over...a lot of digging but pretty awesome :D

    After the initial configuration of changing the v4.master (or a copy of it) and applying it to the template you have to modify the actual applicationv4.master file found in the following directory

    c:\program files\common files\Microsoft Shared\Web Server Extensions\14\TEMPLATE\LAYOUTS

    you can edit it in notepad or SPD (SPD gives me a couple of errors and shows a blank page)

    In my case I made the exact same modifications to the applicationv4.master as I did to the v4updated.master file, this was discovered by going to the following directory c:\program files\common files\Microsoft Shared\Web Server Extensions\14\TEMPLATE\LAYOUTS\PWA and when you view the "PWA.master" file it states on line 4 "Inherits ....PJMasterPage" MasterPageFile="....applicationv4.master"

    Anyway - went up a directory made modifications and refreshed the web page... BOOM done.. 

    Steps to Modify/BRAND all PWA 2010 sites

    1) Modify the C:\program files\common files\Microsoft Shared\Web Server Extensions\14\TEMPLATE\SiteTemplates\PWA\XML\ONET.xml file

    Search for and remove DisableWebDesignFeatures="wdfopensite"

    Save and exit from  the file

    2) IISRESET from administrative command prompt
    3) Under PWA (http://server/pwa) => Site Actions => Site Settings 
    Manage Site Features (under Site Actions) => Activate SharePoint Server PublishingThis allows Master Page to show up under look and feel

    4) Under PWA (http://server/pwa) => Site Actions => Edit in SharePoint Designer
    5) Select the Master Pages icon on the Left 
    6) Drag and Drop v4.master in the window so it creates v4_copy(1).master => rename to what you like newv4_master.master for example
    7) edit the newv4_master.master file by checking it out 
    8) edit the file - check it back in (publish a major version)
    9) You'll need to approve the file -> you can do it either via SPD or under Master Page Gallery (site actions-> site settings -> Master Page and Page Layouts -> select the drop-down next to newv4_master.master -> select approve/reject 

    10) change the master file/branding -> Site Actions -> Site Settings -> Master Page (under look and feel) 
    11) Change the Site Master Page  and System Master Page to newv4_master.master select the checkbox for "reset all subsites.." => select OK

    12) You'll get an error see here how to fix (
    http://www.projectserver2010blog.com/2010/01/project-server-2010-changing-master.html) - the modifications are done in the appropriate sections on the web.config file under the inetpub directory for the appropriate port (80 for most people)

    13) make the above modifications -> IISRESET 

    14) Go to the directions above and modify the applicationv4.master file -> save and exit the file

    all your Project Server Pages will now have the branding/modifications you wanted


    • Marked as answer by kbwrecker Wednesday, March 18, 2015 3:30 PM
    Wednesday, March 18, 2015 3:30 PM