locked
can not connect to console using windows 7 RRS feed

  • Question

  • Hi all I have windows 7 Prof installed (TECHNET DOWNLOAD) I am using windows Home Server PP 3 beta.  I am trying to connect to my server via console but it just will not connect saying that "This Computer cannot connect to your home server. Check your network connection and make sure your home server is powered on. If your home server has recently restarted, try again in a few minutes."  I am using the correct passwords and it does connect via the share folders and I can use logmein to get in to the server so all ip address and network connections are ok.

    Many Thanks for your help
    Ian

     

    Tuesday, August 25, 2009 6:24 PM

Answers

  • Well for your Windows 7 machine, this might work. I'm quoting Robert from http://www.homeserverhacks.com/2009/01/running-windows-home-server-connector.html#comments

    "Worked great for me installed 64bit expect I was unable to connect to the Windows Home Server Console and was getting 'This computer cannot connect to your home server'.
    Fix was to edit the hosts file in C:\Windows\System32\drivers\etc to include the address of the Home server and tehn resave it.
    In my case the line was '10.10.1.10 HQSvr # Windows Home Server' where HQSvr is the name of your server.
    You will have to edit the permissions of the Hosts file to allow you to make the changes and save them back."

    I'm glad I could help
    Wednesday, August 26, 2009 8:47 PM

All replies

  • What connector version are you using?
    Check to make sure your server is fully updated, then navigate to http://SERVERNAMEHERE:55000 (replace SERVERNAMEHERE with the name of your server) and download the connector from there.
    Tuesday, August 25, 2009 6:40 PM
  • Hi all I have windows 7 Prof installed (TECHNET DOWNLOAD) I am using windows Home Server PP 3 beta.  I am trying to connect to my server via console but it just will not connect saying that "This Computer cannot connect to your home server. Check your network connection and make sure your home server is powered on. If your home server has recently restarted, try again in a few minutes."  I am using the correct passwords and it does connect via the share folders and I can use logmein to get in to the server so all ip address and network connections are ok.

    Many Thanks for your help
    Ian

     


    Do you have other clients?  If so, are they able to connect using the Console?  If not, the first thing I would suggest is to uninstall PP3 beta.  (Make sure you use the uinstall.cmd file you should have downloaded from Connect.)  If everything works after uninstalling PP3 beta, you should file a bug report on Connect.  If it still doesn't work after uninstalling PP3 beta, you might try temporarily disabling the firewall on both your client and your server to see if it then works.
    Tuesday, August 25, 2009 7:56 PM
    Moderator
  • Hi guys

    Just a quick note im going to try both of your ideas thanks for your help, I have all the latest updates installed on my client and server pc's.  I have allready tryed the firewall idea and it did not make it work :-(
    Just 1 note my father has almost the same setup as me and is using windows 7 he has the same problem, I am going to test it out with a laptop running Vista Sp2 today to see if this could be a windows 7 bug.

    ok im off to try the other ideas will report back asap

    Thanks IAN
    Wednesday, August 26, 2009 9:20 AM
  • Hi Ian,
    is there any security suite installed on the client PC, which may block communication?
    Are clients and server in the same subnet?
    Is DNS configured properly?
    For verifying the last please post the output of the command
    ipconfig /all
    on one client and the server. (There should be no DNS Suffixes.)
    If you ping the server, which address is resolved?

    Best greetings from Germany
    Olaf

    Wednesday, August 26, 2009 1:13 PM
    Moderator
  • below are the client and server ip configs, I am having the problem on more than one client both wins 7 and vista
    if i ping the server if gives me  192.168.1.3

    My Client IP Config


    Windows IP Configuration

       Host Name . . . . . . . . . . . . : Ian-PC
       Primary Dns Suffix  . . . . . . . :
       Node Type . . . . . . . . . . . . : Hybrid
       IP Routing Enabled. . . . . . . . : No
       WINS Proxy Enabled. . . . . . . . : No

    Ethernet adapter Bluetooth Network Connection 2:

       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Bluetooth Device (Personal Area Network) #2
       Physical Address. . . . . . . . . : 00-02-72-80-E9-D1
       DHCP Enabled. . . . . . . . . . . : Yes
       Autoconfiguration Enabled . . . . : Yes

    Ethernet adapter Local Area Connection 3:

       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : IC Plus IP100A 10/100 Fast Ethernet Adapter
       Physical Address. . . . . . . . . : 00-06-4F-5C-2F-01
       DHCP Enabled. . . . . . . . . . . : Yes
       Autoconfiguration Enabled . . . . : Yes

    Wireless LAN adapter Wireless Network Connection:

       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Realtek RTL8187 Wireless 802.11b/g 54Mbps USB 2.0 Network Adapter
       Physical Address. . . . . . . . . : 00-15-AF-07-E2-F4
       DHCP Enabled. . . . . . . . . . . : Yes
       Autoconfiguration Enabled . . . . : Yes

    Ethernet adapter Local Area Connection 2:

       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : NVIDIA nForce Networking Controller #2
       Physical Address. . . . . . . . . : 00-18-F3-F9-D6-A7
       DHCP Enabled. . . . . . . . . . . : Yes
       Autoconfiguration Enabled . . . . : Yes

    Ethernet adapter Local Area Connection:

       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : NVIDIA nForce Networking Controller
       Physical Address. . . . . . . . . : 00-0E-A6-F5-F3-C1
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes
       Link-local IPv6 Address . . . . . : fe80::f1b2:8cf3:f144:4419%11(Preferred)
       IPv4 Address. . . . . . . . . . . : 192.168.1.5(Preferred)
       Subnet Mask . . . . . . . . . . . : 255.255.255.0
       Default Gateway . . . . . . . . . : 192.168.1.254
       DHCPv6 IAID . . . . . . . . . . . : 234884774
       DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-12-20-C2-6E-00-0E-A6-F5-F3-C1
       DNS Servers . . . . . . . . . . . : 192.168.1.254
                                           192.168.1.3
       NetBIOS over Tcpip. . . . . . . . : Enabled

    Ethernet adapter Hamachi:

       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Hamachi Network Interface
       Physical Address. . . . . . . . . : 7A-79-05-CE-37-66
       DHCP Enabled. . . . . . . . . . . : Yes
       Autoconfiguration Enabled . . . . : Yes
       IPv4 Address. . . . . . . . . . . : 5.206.55.102(Preferred)
       Subnet Mask . . . . . . . . . . . : 255.0.0.0
       Lease Obtained. . . . . . . . . . : 26 August 2009 08:59:48
       Lease Expires . . . . . . . . . . : 26 August 2009 20:10:58
       Default Gateway . . . . . . . . . : 5.0.0.1
       DHCP Server . . . . . . . . . . . : 5.0.0.1
       NetBIOS over Tcpip. . . . . . . . : Enabled

    Tunnel adapter isatap.{1F4ADB4D-2FBE-459D-869A-29E8C5222857}:

       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Microsoft ISATAP Adapter
       Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter isatap.{838DD011-1B30-4C32-B570-10EA12C69266}:

       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Microsoft ISATAP Adapter #2
       Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter Local Area Connection* 9:

       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
       Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes
       IPv6 Address. . . . . . . . . . . : 2001:0:d5c7:a2d6:2888:1bd4:affb:b2be(Preferred)
       Link-local IPv6 Address . . . . . : fe80::2888:1bd4:affb:b2be%15(Preferred)
       Default Gateway . . . . . . . . . :
       NetBIOS over Tcpip. . . . . . . . : Disabled

    Tunnel adapter isatap.{1143AB61-4528-4058-91CB-F2F94802EDC0}:

       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Microsoft ISATAP Adapter #3
       Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter 6TO4 Adapter:

       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Microsoft 6to4 Adapter
       Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes
       IPv6 Address. . . . . . . . . . . : 2002:5ce:3766::5ce:3766(Preferred)
       Default Gateway . . . . . . . . . : 2002:c058:6301::c058:6301
       NetBIOS over Tcpip. . . . . . . . : Disabled


    MY Server IP Config

    Windows IP Configuration

       Host Name . . . . . . . . . . . . : server
       Primary Dns Suffix  . . . . . . . : 
       Node Type . . . . . . . . . . . . : Unknown
       IP Routing Enabled. . . . . . . . : Yes
       WINS Proxy Enabled. . . . . . . . : No

    Ethernet adapter Local Area Connection:

       Connection-specific DNS Suffix  . : 
       Description . . . . . . . . . . . : Realtek RTL8139/810x Family Fast Ethernet NIC
       Physical Address. . . . . . . . . : 00-19-66-40-9C-5D
       DHCP Enabled. . . . . . . . . . . : No
       IP Address. . . . . . . . . . . . : 192.168.1.3
       Subnet Mask . . . . . . . . . . . : 255.255.255.0
       Default Gateway . . . . . . . . . : 192.168.1.254
       DNS Servers . . . . . . . . . . . : 192.168.1.254

    Ethernet adapter Hamachi:

     

       Connection-specific DNS Suffix  . : 
       Description . . . . . . . . . . . : Hamachi Network Interface
       Physical Address. . . . . . . . . : 7A-79-00-00-00-01
       DHCP Enabled. . . . . . . . . . . : Yes
       Autoconfiguration Enabled . . . . : No
       IP Address. . . . . . . . . . . . : 5.182.232.193
       Subnet Mask . . . . . . . . . . . : 255.0.0.0
       Default Gateway . . . . . . . . . : 
       DHCP Server . . . . . . . . . . . : 5.0.0.1
       Lease Obtained. . . . . . . . . . : 25 August 2009 15:50:16
       Lease Expires . . . . . . . . . . : 25 August 2010 15:50:16

     

    Wednesday, August 26, 2009 7:23 PM
  • If you have both computers on the same LAN, try to disable Hamachi on the computer and then try again without the VPN.
    Wednesday, August 26, 2009 7:59 PM
  • Ian,

    Can you connect to your server using the remote terminal server client?
    (run mstsc form the Start butten, then specify your server IP, "Administrator" + {server passwors}.

    If you can not connect to the server desktop this way, something is either blocking the terminal server connection or terminal services are disabled.
    Did you check if on your server the "Terminal Services" service is running (login to the server desktop and checking the services mangement console)?

    - Theo.

    No home server like Home Server
    Wednesday, August 26, 2009 8:17 PM
    Moderator
  • yea had the problem before hamachi, i have uninstalled it on client and still not working :-(
    Wednesday, August 26, 2009 8:30 PM
  • I forgot to ask, is this 32 or 64 bit Windows 7?
    Wednesday, August 26, 2009 8:35 PM
  • 64bit windows 7 and 32bit windows vista
    Wednesday, August 26, 2009 8:36 PM
  • I can connect by remote desktop and by logmein and both work ok. But I still cant use console..
    Wednesday, August 26, 2009 8:39 PM
  • That might your problem right there, I'm not sure whether 64 bit Windows 7 is supported yet, I think it should be though. I'll check right now...
    Wednesday, August 26, 2009 8:42 PM
  • Even if it is not supported yet I still have the same problem with a 32bit vista and that is, unless having my windows 7 pc on the network has caused the problem but I cant see how !

    :-) Thanks for all your help guys so far ...
    Wednesday, August 26, 2009 8:44 PM
  • Well for your Windows 7 machine, this might work. I'm quoting Robert from http://www.homeserverhacks.com/2009/01/running-windows-home-server-connector.html#comments

    "Worked great for me installed 64bit expect I was unable to connect to the Windows Home Server Console and was getting 'This computer cannot connect to your home server'.
    Fix was to edit the hosts file in C:\Windows\System32\drivers\etc to include the address of the Home server and tehn resave it.
    In my case the line was '10.10.1.10 HQSvr # Windows Home Server' where HQSvr is the name of your server.
    You will have to edit the permissions of the Hosts file to allow you to make the changes and save them back."

    I'm glad I could help
    Wednesday, August 26, 2009 8:47 PM
  • I can connect by remote desktop and by logmein and both work ok. But I still cant use console..
    When you connect by remote desktop or logmein are you able to run the console from the server desktop? It sounds to me like either A) you have one or more ports blocked somehow or B) you have a name resolution problem on your network.
    I'm not on the WHS team, I just post a lot. :)
    Wednesday, August 26, 2009 8:58 PM
    Moderator
  • AHH  YES YES YES Thanks guys for all your help.

    Thanks once again

    IAN (UK)
    Wednesday, August 26, 2009 9:09 PM
  • I assume your Hamachi network adapter was the culprit.
    Best greetings from Germany
    Olaf
    Thursday, August 27, 2009 7:49 AM
    Moderator