locked
Dynamic Resource (.svc) not hosting on windows 8.1 RRS feed

  • Question

  • Hi,

    Today my machine got upgraded to 8.1 and now I am facing following issue with embedded resource particularly svc.

    My dll has a svc file which was accepting hits earlier and now it is not. I moved the build to other machine it is working but only not on my machine. URL which is getting generated is as follows :

    /App_Dynamic_Resource/MyDLL,com.org.namespace.Service.MyService.svc

    Same url was getting generated earlier and now on other machines as well, but not working on my machine only.

    Thanks,

    Durgesh Chaudhary.


    Thanks, Durgesh Chaudhary. http://home.techphernalia.com

    • Moved by Caillen Friday, November 29, 2013 8:11 AM
    Tuesday, November 26, 2013 1:22 PM

Answers

  • You might ask them over here.

    http://forums.iis.net/

     

     

     


    Regards, Dave Patrick ....
    Microsoft Certified Professional
    Microsoft MVP [Windows]

    Disclaimer: This posting is provided "AS IS" with no warranties or guarantees , and confers no rights.

    • Proposed as answer by Just Karl Monday, December 2, 2013 4:21 AM
    • Marked as answer by Just Karl Saturday, December 7, 2013 4:50 PM
    Friday, November 29, 2013 10:41 AM

All replies

  • Also normal svc files and other embedded JS are fetched but only embedded svc are not fetched

    Thanks, Durgesh Chaudhary. http://home.techphernalia.com

    Tuesday, November 26, 2013 1:25 PM
  • Hi Durgesh,

    Sorry I don't fully understand you.

    You mean you hosted a WCF service on your machine, and you couldn't consume this WCF service after your OS upgrading to 8.1, is that right? If it didn't work, what error messages have you got?

    If that is the case, I suspect that you have some problems with the configuration of the IIS, or you didn't turn on the HTTP Activation feature in Windows Features.

    Enable HTTP Activation

    I just found this thread talking about similar question, I hope you could find what you want here:

    WCF on IIS8; *.svc handler mapping doesn't work

    By the way, this is Visual C# forum which is for questions regarding Visual C# language. I hope you post your question in the correct forum so that you could get more helpful responses.

    Thanks.


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.




    • Edited by Caillen Friday, November 29, 2013 8:07 AM
    Wednesday, November 27, 2013 9:25 AM
  • I have already checked that (I confirmed again right now). The issue is not with all the .svc only embedded ones on IIS 8.5 (the one which comes with Windows 8.1), I also confirmed it on other Win 8.1 machines and they all are having the same problem.

    Regarding forum, Can you please move it to right forum.


    Thanks, Durgesh Chaudhary. http://home.techphernalia.com

    Friday, November 29, 2013 7:52 AM
  • Hi Durgesh,

    I am moving your question to the moderator forum ("Where is the forum for..?"). The owner of the forum will direct you to a right forum. Thanks for your understanding.

    And I strongly recommend that you describe your question with detailed information so that others can give you more help.

    Thanks.


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Friday, November 29, 2013 8:11 AM
  • You might ask them over here.

    http://forums.iis.net/

     

     

     


    Regards, Dave Patrick ....
    Microsoft Certified Professional
    Microsoft MVP [Windows]

    Disclaimer: This posting is provided "AS IS" with no warranties or guarantees , and confers no rights.

    • Proposed as answer by Just Karl Monday, December 2, 2013 4:21 AM
    • Marked as answer by Just Karl Saturday, December 7, 2013 4:50 PM
    Friday, November 29, 2013 10:41 AM